Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th June 2009, 13:15
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default verry verry slow directory listung with pure-ftpd

The connection to pure-ftpd works. But hours later the content of the directorys are shown.

I've tried several ftp clients but each client say hours "working ..."
I'm using pure-ftpd --without-capabilities for virtuozzo

Any idea why that is so slow?
Reply With Quote
Sponsored Links
  #2  
Old 27th June 2009, 13:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Most like ly a problem with name resolution. You should disable nameresolution in the pureftpd configuration. The Option is named "DontResolve".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th June 2009, 13:39
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Where to set this option?

I can't find pure-ftpd.conf to edit. Does /etc/default/pure-ftpd-common replace /etc/pure-ftpd/pure-ftpd.conf ?
Where are the pure-ftpd start options been set like "-b -A -u 1000 -E -B"?

My question arises by reading the pure-ftpd webseite
Code:
Unlike many daemons, Pure-FTPd doesn't read any configuration file (but for
LDAP and SQL). Instead, it uses command-line options. For instance, the '-H'
flag is designed to speed up highly loaded servers, by avoiding DNS lookups.
To enable this, just add it to the server name:

/usr/local/sbin/pure-ftpd -H
So I suppose "-H" does the same as "DontResolve"?

Last edited by tom; 27th June 2009 at 13:53.
Reply With Quote
  #4  
Old 27th June 2009, 13:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Which Linux distribution?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 27th June 2009, 14:04
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by till View Post
Which Linux distribution?
Debian Lenny
Reply With Quote
  #6  
Old 27th June 2009, 14:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Execeute these commands to turn off resolving:

Code:
echo 'yes' > /etc/pure-ftpd/conf/DontResolve
/etc/init.d/pure-ftpd-mysql restart
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
tom (27th June 2009)
  #7  
Old 27th June 2009, 14:25
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Ok, pure-ftpd works with the -H option now.
BUT still the directory listing ist verry slow. It seem to me it's only very slow if no files are in the directory which is chosen to list the content.
Directories with content like web,tmp are fast in listing the files.

By the way:I'm suppised about the differens
Code:
h1:/etc/pure-ftpd/conf# ls -al
insgesamt 48
drwxr-xr-x 2 root root 4096 27. Jun 14:11 .
drwxr-xr-x 5 root root 4096 27. Jun 13:35 ..
-rw-r--r-- 1 root root   36  2. Nov 2008  AltLog
-rw-r--r-- 1 root root    4 27. Jun 11:30 BrokenClientsCompatibility
-rw-r--r-- 1 root root    4 27. Jun 11:30 ChrootEveryone
-rw-r--r-- 1 root root    4 27. Jun 14:10 DontResolve
-rw-r--r-- 1 root root    5  2. Nov 2008  MinUID
-rw-r--r-- 1 root root   29 25. Jun 21:52 MySQLConfigFile
-rw-r--r-- 1 root root    4  2. Nov 2008  NoAnonymous
-rw-r--r-- 1 root root    4  2. Nov 2008  PAMAuthentication
-rw-r--r-- 1 root root   28  2. Nov 2008  PureDB
-rw-r--r-- 1 root root    3  2. Nov 2008  UnixAuthentication
and
Code:
vi /var/lib/dpkg/info/pure-ftpd-common.conffiles
/etc/logrotate.d/pure-ftpd-common
/etc/ftpallow
/etc/pure-ftpd/conf/AltLog
/etc/pure-ftpd/conf/MinUID
/etc/pure-ftpd/conf/NoAnonymous
/etc/pure-ftpd/conf/PAMAuthentication
/etc/pure-ftpd/conf/PureDB
/etc/pure-ftpd/conf/UnixAuthentication
/etc/pure-ftpd/pureftpd-dir-aliases
Should it not be tell the same files?

Last edited by tom; 27th June 2009 at 15:31.
Reply With Quote
  #8  
Old 2nd July 2009, 22:43
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

The reason for verry slow directory listing - actually is mean read "working ..." an waitin - is the firewall in together with passiv ftp. Passiv ftp is not possible if the ispconfig default firefall is enabled. Without the firewall passiv ftp is possible. I dont unterstand why, because the ports 21,20 are still oben with the active firewall.

How to configure firewall to go with passiv ftp?
Propably iptable should open port from 21-1024 but how to configure with ispconfig? 21-1024 or 21:1024 gives a configuration error.

Last edited by tom; 2nd July 2009 at 22:56.
Reply With Quote
  #9  
Old 3rd July 2009, 08:42
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
 
Default

To get passive working properly, you need to do a few things:

- Make up a range between 1025 and 65535 .. (f.e. 3000-4000)
- Add that range to you firewall, so those ports are open (accepted)
- Now open the pure-ftpd config file and look for a line that says "PassivePortRange", uncomment this line and change it to: PassivePortRange 3000 4000
- restart pure-ftpd

If the ISPConfig filewall script is giving you a hard time use:

iptables -A INPUT -p tcp -m multiport --dports 3000:4000 -j ACCEPT

p.s. i would never use port numbers < 1024 for your own usage, since most of them are reserved for other services, which COULD lead to other problems.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17


All times are GMT +2. The time now is 12:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.