#1  
Old 9th July 2009, 15:16
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default PHP 5 warning session

Hi All,

I've problem with session, in php script i've this warning :

Quote:
Warning: Unknown: open(/var/lib/php5/sess_3f16fe202b755a37bb4c1d04d2a9acf7, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php5) in Unknown on line 0
If script uses session for login on private party, the session are not save and user are reject ...

What is the correct path to work with ispconfig ?

Thank you

PS : warning are present in fcgi and suphp
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's

Last edited by Gimly; 9th July 2009 at 15:22.
Reply With Quote
Sponsored Links
  #2  
Old 9th July 2009, 17:42
sirrus sirrus is offline
Junior Member
 
Join Date: May 2009
Location: Frankfurt am Main
Posts: 15
Thanks: 4
Thanked 1 Time in 1 Post
Send a message via ICQ to sirrus Send a message via Skype™ to sirrus
Default

You should post some more informations. What URL did you try? Which version of ISPConfig? Please provide the output of

Code:
ls -la /var/lib/php5
Reply With Quote
  #3  
Old 9th July 2009, 20:45
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

Quote:
Originally Posted by sirrus View Post
What URL did you try ?
The problem exist for over 300 website ...

Quote:
Originally Posted by sirrus
Which version of ISPConfig?
Last stable (you can see it on my signature ...)

Code:
ns1:~# ls -al /var/lib/php5/
total 8
drwx-wx-wt  2 root root 4096 jui  9 20:39 .
drwxr-xr-x 28 root root 4096 jun 30 22:08 ..
ns1:~#
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #4  
Old 9th July 2009, 21:36
sirrus sirrus is offline
Junior Member
 
Join Date: May 2009
Location: Frankfurt am Main
Posts: 15
Thanks: 4
Thanked 1 Time in 1 Post
Send a message via ICQ to sirrus Send a message via Skype™ to sirrus
Default

Maybe your config files are wrong. This could be caused by a template.

The single config files under /etc/apache2/sites-enabled/* should habe a line like this:

Code:
php_admin_value session.save_path /var/www/clients/client1/web1/tmp
If this is not the case please edit /usr/local/ispconfig/server/conf/vhost.conf.master to represent this (only a snippet - the file should be several lines long):

Code:
<tmpl_if name='php' op='==' value='mod'>
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@<tmpl_var name='domain'>" 
    php_admin_value upload_tmp_dir <tmpl_var name='document_root'>/tmp
    php_admin_value session.save_path <tmpl_var name='document_root'>/tmp
    php_admin_value open_basedir <tmpl_var name='document_root'>:/usr/share/php5
</tmpl_if>
Reply With Quote
The Following User Says Thank You to sirrus For This Useful Post:
Gimly (9th July 2009)
  #5  
Old 9th July 2009, 21:53
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

I add this value php_admin_value session.save_path <tmpl_var name='document_root'>/tmp
to suphp and cgi, now I test.

I'll become later to confirm the solution
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #6  
Old 10th July 2009, 07:53
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

It work fine for all website ^^ but not for ISPConfig :

https://www.espace4you.org:81/

you can access by https://ns1.espace4you.org:81/ without error, but the valid SSL certificate is for www.espace4you.org and not ns1.espace4you.org and I want to my customers (clients) access by www.espace4you.org.

If you have an idea ?

thank you
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #7  
Old 10th July 2009, 09:24
sirrus sirrus is offline
Junior Member
 
Join Date: May 2009
Location: Frankfurt am Main
Posts: 15
Thanks: 4
Thanked 1 Time in 1 Post
Send a message via ICQ to sirrus Send a message via Skype™ to sirrus
Default

ISPConfig needs to be modified in
Quote:
/etc/apache2/sites-enabled/000-ispconfig.vhost
but this should be a fcgi handled domain. Therefor you should modify

Quote:
/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
And the issue with SSL is caused by your certificate. You need to create a new certificate - this can be selfsigned as it is now. I suggest to buy a "real" certificate for this domain.
Reply With Quote
  #8  
Old 10th July 2009, 10:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,338 Times in 4,188 Posts
Default

Quote:
Warning: Unknown: open(/var/lib/php5/sess_3f16fe202b755a37bb4c1d04d2a9acf7, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php5) in Unknown on line 0
Just close all browser windows so that you get a new session for ISPConfig. This error is normal if you use e.g. fcgi while you had mod_php used before in ispconfig as the session file is owned by a different user then and the session file gets deleted when you close all browser windows.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Gimly (10th July 2009)
  #9  
Old 10th July 2009, 13:51
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
 
Default

Thank you for your precision Till
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help setting up domainpop with postfix kameelperdza Installation/Configuration 6 15th June 2009 07:49
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
[Postfix] Quota doesn't work krzysiek HOWTO-Related Questions 8 2nd March 2009 15:57
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 23:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.