Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th June 2009, 03:40
tonysch tonysch is offline
Member
 
Join Date: Mar 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default Email not flowing...

I have setup a fresh install of ISPconfig 3 on Ubuntu 9.04, per the perfect server doc... All went well, no problems.
When I attempt to send or receive email, I am unable to either way. I also do not receive NDRs on either side.
I can telnet to port 25 with proper results.

Here is my mail log from a few tests...

Any help would be greatly appreciated.
Thanks
Tony

Jun 25 01:37:36 srv03 postfix/qmgr[3309]: 8EBE4893F: from=<tschnellbach@gmail.com>, size=1863, nrcpt=1 (queue active)
Jun 25 01:37:36 srv03 postfix/error[18504]: 8EBE4893F: to=<tony@schnellit.com>, relay=none, delay=0.39, delays=0.33/0.01/0/0.05, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Jun 25 01:38:06 srv03 postfix/smtpd[18499]: disconnect from mail-ew0-f221.google.com[209.85.219.221]
Reply With Quote
Sponsored Links
  #2  
Old 25th June 2009, 10:02
wouterw wouterw is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

Check this topic. You probably don't have amavis / clamav installed or activated.
Reply With Quote
  #3  
Old 25th June 2009, 13:02
tonysch tonysch is offline
Member
 
Join Date: Mar 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is there any where (documentation) on what processes should/shouldn't be installed and running?
Also, is there any documentation on POST ISPconfig install or admin guides?

OK I followed the link...
I restarted clanmav... OK
I restarted amavis...
Stopping amavisd: (not running).
Starting amavisd: Problem in Amavis:KIM code: Can't locate Crypt/OpenSSL/RSA.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at (eval 82) line 27.
BEGIN failed--compilation aborted at (eval 82) line 27.
(failed).
Reply With Quote
  #4  
Old 25th June 2009, 13:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,494
Thanks: 813
Thanked 5,261 Times in 4,125 Posts
Default

Install your server exactly as described in the perfect setup guide for ispconfig 3. The guides can be found here:

http://www.ispconfig.org/documentation.htm
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 25th June 2009, 15:07
tonysch tonysch is offline
Member
 
Join Date: Mar 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That is what I followed... to the "T".
Even copy/pasted all the scripts...

Thanks
Tony
Reply With Quote
  #6  
Old 25th June 2009, 15:26
wouterw wouterw is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

Check this bugreport
Reply With Quote
  #7  
Old 25th June 2009, 18:48
tonysch tonysch is offline
Member
 
Join Date: Mar 2006
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

That fixed her right up...

Thank you
Reply With Quote
  #8  
Old 19th July 2009, 22:42
Stown Stown is offline
Member
 
Join Date: Jun 2009
Location: Limburg, NL
Posts: 82
Thanks: 12
Thanked 5 Times in 5 Posts
Send a message via Skype™ to Stown
Default

I have sort of the same problem on my centOS server.

This is what i have:
[root@server1 scripts]# /etc/init.d/amavisd restart
Shutting down Mail Virus Scanner (amavisd): [ OK ]
Starting Mail Virus Scanner (amavisd): fetch_modules: error loading optional module Mail/SpamAssassin/Plugin/DKIM.pm:
Can't locate Mail/DKIM.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8) at /usr/lib/perl5/vendor_perl/5.8.8/Mail/SpamAssassin/Plugin/DKIM.pm line 77.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/Mail/SpamAssassin/Plugin/DKIM.pm line 77.
Compilation failed in require at /usr/sbin/amavisd line 197.
[ OK ]

I cannot find any package named libmail-dkim-perl for centOS?
Reply With Quote
  #9  
Old 20th July 2009, 10:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,494
Thanks: 813
Thanked 5,261 Times in 4,125 Posts
Default

http://www.howtoforge.com/forums/showthread.php?t=37557
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 18th August 2009, 04:23
micheal-808 micheal-808 is offline
Junior Member
 
Join Date: Jun 2009
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I am having a similar Problem with amavis when following step by step the installation guide from The Perfect OpenSUSE 11.1 Server

The following error message:

Code:
atom035:/usr/sbin # /etc/init.d/amavis start
Starting virus-scanner (amavisd-new): fetch_modules: error loading optional module MIME/Decoder/BinHex.pm:
  Can't locate Convert/BinHex.pm in @INC (@INC contains: /usr/lib/perl5/5.10.0/i586-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl) at /usr/lib/perl5/vendor_perl/5.10.0/MIME/Decoder/BinHex.pm line 43.
  BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.10.0/MIME/Decoder/BinHex.pm line 43.
  Compilation failed in require at /usr/sbin/amavisd line 197.
  The value of variable $myhostname is "atom035", but should have been
  a fully qualified domain name; perhaps uname(3) did not provide such.
  You must explicitly assign a FQDN of this host to variable $myhostname
  in amavisd.conf, or fix what uname(3) provides as a host's network name!
I dont know at all what i have to do, only the last part of the error file was fixed by myseld

Code:
Compilation failed in require at /usr/sbin/amavisd line 197.
  The value of variable $myhostname is "atom035", but should have been
  a fully qualified domain name; perhaps uname(3) did not provide such.
  You must explicitly assign a FQDN of this host to variable $myhostname
  in amavisd.conf, or fix what uname(3) provides as a host's network name!
It was not hard to define the hostname in the config file but i still get the whole error message!

I hope someone can help me out!

Thanks

---

EDIT:

Ive worked some of the problems out with installing:

perl-Convert-BinHex

The only Problem now is this:

Code:
Compilation failed in require at /usr/sbin/amavisd line 197.
  The value of variable $myhostname is "atom035", but should have been
  a fully qualified domain name; perhaps uname(3) did not provide such.
  You must explicitly assign a FQDN of this host to variable $myhostname
  in amavisd.conf, or fix what uname(3) provides as a host's network name!
But i am wondering! Ive modified the amavisd.conf file and have added the correct host in Line 152 and this error still appears

Last edited by micheal-808; 18th August 2009 at 04:39.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 03:39
email forward problem createch General 5 10th December 2008 14:14
CacheALL email problem no.2 Snowman General 2 2nd August 2007 09:45
Multiple MySQL Queries - with Postfix-mysql, courier-authmysql, maildrop-mysql... snowfly HOWTO-Related Questions 4 7th July 2006 04:19
email forwarding locally consumes all resources rdells General 20 1st May 2006 19:43


All times are GMT +2. The time now is 10:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.