Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd June 2009, 12:42
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Smile How to allow .htaccess file

Can someone tell me step by step how to allow .htaccess file? I need it for mod-rewrite.

Thank you
Reply With Quote
Sponsored Links
  #2  
Old 22nd June 2009, 13:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

This is allowed and configured by default, no changes nescessary.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd June 2009, 19:06
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
This is allowed and configured by default, no changes nescessary.
Thank for answer, but when I copy .htaccess file to /web10/ folder and refresh page, I get Internal server error.
Reply With Quote
  #4  
Old 22nd June 2009, 19:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Then check the exact error message in the error message of the logfile. I'am sure that your .htaccess file contains other settings beside mod_rewrite rules.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 27th June 2009, 10:14
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Then check the exact error message in the error message of the logfile. I'am sure that your .htaccess file contains other settings beside mod_rewrite rules.
But when i copy .htaccess to /web10/web/ directory, I can't see it in the dir. It will disappear.

.htaccess file contains only mod_rewrite rules.s
Reply With Quote
  #6  
Old 27th June 2009, 11:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

The is there and uploaded correctly but your FTP client or pureftpd hides hidden files (files that start with a dot). Take a look at the settings of the ftp client and the pureftpd configuration file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 27th June 2009, 11:21
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
The is there and uploaded correctly but your FTP client or pureftpd hides hidden files (files that start with a dot). Take a look at the settings of the ftp client and the pureftpd configuration file.
Mustn't I allow mod-rewrite in Apache directives when I'm adding a website?
Reply With Quote
  #8  
Old 27th June 2009, 11:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Quote:
Originally Posted by Skprorok View Post
Mustn't I allow mod-rewrite in Apache directives when I'm adding a website?
No. Mod_rewrite is alaways enabled. But this has nothing to do with your original problem.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 27th June 2009, 11:37
Skprorok Skprorok is offline
Member
 
Join Date: Jun 2009
Posts: 56
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
No. Mod_rewrite is alaways enabled. But this has nothing to do with your original problem.
my .htaccess file contains this:

RewriteEngine On
RewriteRule ^uzivatel/(.*) /index.php?id=8&user_name=$1 [QSA]
RewriteRule ^(.*)/(.*).xml /index.php?id=$1 [QSA]

Where is error log of the website?
Reply With Quote
  #10  
Old 27th June 2009, 11:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
 
Default

In the log directory of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
.htaccess

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 20:17
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 03:40
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
jamed up my table borders?? Boon-Dog-Danny Installation/Configuration 5 23rd September 2006 16:12


All times are GMT +2. The time now is 04:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.