Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 22nd June 2009, 15:53
KillerSneak KillerSneak is offline
Junior Member
 
Join Date: Jul 2008
Posts: 17
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
No. This can not work for all domains, only for the main domain of the server if you create it as website. If you want to use it like this, you will either have to create a symlink or install the applications in the site or use apache rewrite rules. Also see the plugin that is available for this:

http://www.howtoforge.com/forums/showthread.php?t=34917
Don't think it's appropiate to link to a plugin that doesn't seem to work?
Reply With Quote
Sponsored Links
  #12  
Old 22nd June 2009, 15:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,386 Times in 4,231 Posts
Default

Quote:
Don't think it's appropiate to link to a plugin that doesn't seem to work?
Dont you think ist appropriate to post this instead of reading my whole post?

The plugin works as good as it is possible with this approach. If you would have read my post then you should know why and when it works and when not and wehen to use one of the other solutions that I mentioned.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 23rd June 2009, 01:38
kvand kvand is offline
Junior Member
 
Join Date: Jun 2009
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by danielborene View Post
- Are you trying to access server01.ensocode.com from a computer outside of the network, inside of the network or local-host(The actual Server)
I have tried accessing server01.ensocode.com from both the internal network and from outside, both to no avail.

Quote:
Originally Posted by danielborene View Post
phpmyadmin
- make sure you have a phpmyadmin.conf under /etc/apache2/conf.d/
I do not have a phpmyadmin.conf there, what should I do?

Quote:
Originally Posted by danielborene View Post
Webmail
- Make sure you have the link folder webmail under /var/www
- Make sure the link is pointing to the right folder. /usr/share/squirrelmail/
Type ls -la /var/www and it will show you the link of webmail

I'm actually using RoundCube 0.2.2 which is much nicer than squirrelmail, and it is working beautifully.
The installation of RoundCube I followed actually adds the /webmail to every virtual host you create, with squirrelmail you have to create a link manually to each website you add.
If you like I can post the instructions on how to setup RoundCube email.
All the links and such are there, and they're pointing to the correct locations...What should I do?
Reply With Quote
  #14  
Old 23rd June 2009, 09:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,386 Times in 4,231 Posts
Default

Quote:
I have tried accessing server01.ensocode.com from both the internal network and from outside, both to no avail.
Then the domains does not exist. Create A DNS A-Record for server01.ensocode.com pointing to the IP address of your webserver.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
kvand (23rd June 2009)
  #15  
Old 23rd June 2009, 16:26
kvand kvand is offline
Junior Member
 
Join Date: Jun 2009
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Does it take a while for the new DNS records to take effect? I added a new zone, an A-Record, and an alias for "server01.ensocode.com". So far it has not had any effect.

What should I do?

Sorry for the headache Till, and thank you for your help in this matter. It is very much appreciated.
Reply With Quote
  #16  
Old 23rd June 2009, 16:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Yes, it can take up to 72 hours until DNS changes propagate.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 28th June 2009, 05:51
kvand kvand is offline
Junior Member
 
Join Date: Jun 2009
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default

The DNS record that I put into the server did not change anything. I was unable to access "server01.ensocode.com" internally and externally.

Perhaps I entered the DNS record wrong?
Reply With Quote
  #18  
Old 28th June 2009, 10:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,386 Times in 4,231 Posts
Default

First, make sure that you enter the record on the correct server. This is mots likely the server of the provider were you registered ensocode.com and not your local server. Then you will have to wait some time as falko mentioned above.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #19  
Old 30th June 2009, 01:38
kvand kvand is offline
Junior Member
 
Join Date: Jun 2009
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Alrighty, I made an A-Record on my DNS service and "server01.ensocode.com" is a valid URL now. However, Squirrelmail and phpmyadmin are still 404 when I try "server01.ensocode.com/webmail" and "server01.ensocode.com/phpmyadmin".
Reply With Quote
  #20  
Old 14th July 2009, 13:05
F4LLEN F4LLEN is offline
Junior Member
 
Join Date: Jul 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I too am missing the phpmyadmin.conf under /etc/apache2/conf.d/, can someone please enlighten me on where to obtain this file? assuming that this is the reason why my phpmyadmin is returning a 404?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
phpmyadmin problem on ubuntu mail server virtual domains almeister9 HOWTO-Related Questions 1 19th September 2008 16:52


All times are GMT +2. The time now is 06:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.