Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th June 2009, 20:46
kvand kvand is offline
Junior Member
 
Join Date: Jun 2009
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Question phpmyadmin and squirrelmail are 404 & ClamAV is outdated

Hello,

First of all, I would like to compliment Falko on writing "The Perfect Server - Ubuntu 9.04 [ISPConfig 3]" everything went smoothly on the install (especially for a Linux newbie like me ). However, several issues have popped up:

1)When using my hostname (server01.ensocode.com) in the URL bar of a web browser, I get a "Server Not Found" error.

2)When using my external ip I can access ISPConfig 3, but not Squirrelmail or phpmyadmin.

3)ClamAV is "Out of date" and I have no idea how to update from v0.95.1 to v0.95.2.

4)Also, this is minor but I figured I should mention it: the mod_rewrite Apache module is not working with Permalinks in Wordpress (v2.8).


Again, I'm a complete newbie to Linux and I know this is all pretty vague...If you would like me to copy/paste some output from commands up here I will be more than glad to oblige.

Thank you very much.

Last edited by kvand; 6th December 2010 at 00:45.
Reply With Quote
Sponsored Links
  #2  
Old 18th June 2009, 23:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

1) make sure that the hostname server01.ensocode.com existsb in dns.
2) But you can access them with the internal IP?
3) thats ok. You have the latest avalable version for ubuntu already installed the antivirus signatures are up to date.
4) Thats normal too. Switch to suphp os php-fcgi + suexec.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
kvand (19th June 2009)
  #3  
Old 19th June 2009, 03:46
kvand kvand is offline
Junior Member
 
Join Date: Jun 2009
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default

1) How would I go about checking? Is there a specific command I should use or file I should check?

2)Yes, both the internal and external IP addresses work. I get an error when using server01.ensocode.com...I get a 404 whenever I try my IP + /webmail or /phpmyadmin.

3)Yay!

4)I'm using SuPHP at the moment.

Last edited by kvand; 19th June 2009 at 03:48.
Reply With Quote
  #4  
Old 20th June 2009, 01:21
danielborene danielborene is offline
Junior Member
 
Join Date: Jun 2009
Posts: 24
Thanks: 7
Thanked 2 Times in 1 Post
Default

- Are you trying to access server01.ensocode.com from a computer outside of the network, inside of the network or local-host(The actual Server)

phpmyadmin
- make sure you have a phpmyadmin.conf under /etc/apache2/conf.d/

Webmail
- Make sure you have the link folder webmail under /var/www
- Make sure the link is pointing to the right folder. /usr/share/squirrelmail/
Type ls -la /var/www and it will show you the link of webmail

I'm actually using RoundCube 0.2.2 which is much nicer than squirrelmail, and it is working beautifully.
The installation of RoundCube I followed actually adds the /webmail to every virtual host you create, with squirrelmail you have to create a link manually to each website you add.
If you like I can post the instructions on how to setup RoundCube email.
Reply With Quote
  #5  
Old 22nd June 2009, 09:27
KillerSneak KillerSneak is offline
Junior Member
 
Join Date: Jul 2008
Posts: 17
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Rermember

PhpMyAdmin =
http://www.domain.com:8080/phpmyadmin/

Webmail =
http://www.domain.com:8080/webmail/

For some reason you have to give in the ports?
Reply With Quote
  #6  
Old 22nd June 2009, 11:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

If you have to use a port or not depends on the setup and Linux distribution.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 22nd June 2009, 14:26
KillerSneak KillerSneak is offline
Junior Member
 
Join Date: Jul 2008
Posts: 17
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
If you have to use a port or not depends on the setup and Linux distribution.
Well i followed the 11.1 SuSe + IPS3 tutorial and this is the only way i can access it.

Another problem i have is that from a clients control panel:
When trying to access webmail (squirrel mail) it gets indeed the 404
http://server1.donotarguehostedservers.com/webmail <- this link isn't correct and should be
8080/webmail
Any way to fix this?

I'm writing up a 11.1 + ISP3 config for SuSe x64 but i need some bugs / issues solved before i can try and share it. At this moment the documentation as here on the site is incomplete and the ISP3 documentation itself is even worse (no pun intened)

Like now my clients can receive E-mail from who and where ever but still can't send e-mails?

Another thing / request
Maybe usefull to show clients/users here how they can get everything woring when they have registerd a domain @ godaddy and want to run ISP3 with it. as I don't fully understand the Total DNS controll at godaddy and how to incorp nameservers ? I understand i need 2 seperate IP adresses? While this isn't being said anywhere in any tutorials here.
Reply With Quote
  #8  
Old 22nd June 2009, 15:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
I'm writing up a 11.1 + ISP3 config for SuSe x64 but i need some bugs / issues solved before i can try and share it. At this moment the documentation as here on the site is incomplete and the ISP3 documentation itself is even worse (no pun intened)
Just installed it on friday on OpenSuSE 11.1 with the guide and it worked out of the box, no bugs or issues. What are the exact problems that you have?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
KillerSneak (22nd June 2009)
  #9  
Old 22nd June 2009, 15:22
KillerSneak KillerSneak is offline
Junior Member
 
Join Date: Jul 2008
Posts: 17
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Just installed it on friday on OpenSuSE 11.1 with the guide and it worked out of the box, no bugs or issues. What are the exact problems that you have?
the problem is

www.domain.ltd/webmail -> should direct to Squirrelmail not?
www.domain.ltd/phpmyadmin -> should direct to PhpMyAdmin not?

in my case it's

www.domain.ltd:8080/webmail
www.domain.ltd:8080/phpmyadmin

And the link in the client's panel to goto the webmail doesn't work but get's directed to:

http://server1.donotarguehostedservers.com/webmail
Reply With Quote
  #10  
Old 22nd June 2009, 15:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
 
Default

Quote:
www.domain.ltd/webmail -> should direct to Squirrelmail not?
www.domain.ltd/phpmyadmin -> should direct to PhpMyAdmin not?
No. This can not work for all domains, only for the main domain of the server if you create it as website. If you want to use it like this, you will either have to create a symlink or install the applications in the site or use apache rewrite rules. Also see the plugin that is available for this:

http://www.howtoforge.com/forums/showthread.php?t=34917
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
phpmyadmin problem on ubuntu mail server virtual domains almeister9 HOWTO-Related Questions 1 19th September 2008 16:52


All times are GMT +2. The time now is 10:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.