Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th June 2009, 15:51
AlyK AlyK is offline
Junior Member
 
Join Date: Jan 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix & Courier w/ mailstore on SMB Share(NAS) fetch failure...

Hey all. I have successfully followed the howto for Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (CentOS 5.3 x86_64) (but for x86) and I have implemented this system successfully a few times. However I seem to have hit a issue. I have a situation where i have to place the mailstore on a windows NAS. I can sucessfully mounted the share with the correct gid/uid and i can get postfix to delivery mail to it properly however i can't seem to get courier to fetch the mail / display mail in any app (squirrel for example).

It shows that there is in new messages eg: [Inbox (2)] but isn't able to display the mail itself.

I have also attempted to maually telnet into the imap server and fetch mail and recieved the following error:
a fetch 2 body[text]
* 2 FETCH ()
* NO Cannot open message 2
a OK FETCH completed.
a fetch 1 body[text]
* 1 FETCH ()
* NO Cannot open message 1
a OK FETCH completed.

After trying manually or via an mail app i see the following errors in the /var/log/maillog:
Jun 18 09:33:48 mail01 imapd: rename(./new/1245268538.V17I22ed9bM285388.mail01.company.net,S= 1034,./cur/1245268538.V17I22ed9bM285388.mail01.company.net,S= 1034:2,)
failed: No such file or directory


fstab:
//192.168.0.50/linuxmail /MailStoreAmun cifs username=net/linuxmail,password=Password1,uid=vmail,gid=vmail,a uto,iocharset=utf8,file_mode=0700,dir_mode=0700 0 0
I have also tried modes 0777 just to test with no change in results.

authmysql(key parts for this issue):
MYSQL_UID_FIELD 5000
MYSQL_GID_FIELD 5000
MYSQL_HOME_FIELD "/MailStoreAmun"
MYSQL_MAILDIR_FIELD CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/')

After some Googling i have read that it might be use to the MYSQL_MAILDIR_FIELD string, however i don't feel this is the exact issue as all permissions and and paths are all relative to the file system and i can't see how it would be affected just because this is a smb share.
Any help would be greatly appreciated. Thanks to all in advance.

Last edited by AlyK; 18th June 2009 at 19:55.
Reply With Quote
Sponsored Links
  #2  
Old 19th June 2009, 16:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

I guess this is a permissions problem. Maybe it has something to do with dir_mode=0700 in your fstab?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th June 2009, 16:36
Flash Flash is offline
Member
 
Join Date: Oct 2008
Posts: 33
Thanks: 2
Thanked 4 Times in 3 Posts
Default

I recently set up a vmail server myself also with courier. What I noticed is that Courier expects exactly the right user/group else it will not work.

so if you have user alyk (uid 1000?) with group users (uid 100?) set up in your database, make sure its like that on the directory aswell. a quick chown -R should do the trick.
Reply With Quote
  #4  
Old 22nd June 2009, 16:26
AlyK AlyK is offline
Junior Member
 
Join Date: Jan 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default No go :(

Hey all,
I have made a few adjustments as per your guys posts and i am still having the same issue. I changed the file, dir mode to 0777 just for test and that didn't change anything i also removed those two entries and it also didn't change anything. I have confirmed the UID and GID as per the HOWTO is set to 5000 across the mount, postfix, and courier.

I continue to get the same error. Postfix can deliver without issues courier can see mail is in the bin, but it just can't show it. I am stumped any idea's??
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota... killfrog HOWTO-Related Questions 3 25th September 2009 21:45
Virtual Users And Domains With Postfix, Courier And MySQL faalhaas HOWTO-Related Questions 1 21st August 2008 20:16
Virtual Users With Postfix, PostfixAdmin, Courier, Mailscanner,Mailwatch CentOS 5.2 tecstream HOWTO-Related Questions 3 16th July 2008 22:10
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 03:39


All times are GMT +2. The time now is 06:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.