#1  
Old 25th June 2009, 10:14
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 149
Thanks: 27
Thanked 13 Times in 10 Posts
 
Default Remoting Framework problem

EDIT: Sorry for posting this in the wrong forum accidentally. I have opened this thread in the ISPConfig 2 forum now.

Hi,

I have searched and read older posts, but they don't seem to comply with my problem.

First of all, I have a freshly installed Debian Lenny Server (installed as documented in the perfect setup howto) with ISPConfig 2.2.32.

To get the remoting framework working, I took the following steps:
  • Installing libxml2 (apt-get install libxml2-dev)
  • Installing ispconfig_remoting_ext_beta4.2.1_os.pkg via the ISPConfig update feature (success)
  • Creating a user for remoting in ISPConfig->Tools->remoting->user, giving all rights to him
  • Creating a reseller (to have some data to play with)
  • Enabling the CURL extension on my local Windows/XAMPP installation (inside [Path-to-XAMPP]\apache\bin edit php.ini; un-comment the line ";extension=php_curl.dll" by removing the semicolon)
  • Editing test.php: change server IP and user data.
  • Also commented out the 'get reseller list' example in test.php
  • copy test.php to XAMPP\htdocs\test\ directory and run it...

I get no error message, but all I get from running test.php is 'Script end ...'
Running other example functions also did not work (I just tried functions made for reading data)

When I call https://www.myservername.com:81/remote/index.php, I get

Code:
<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
−
<SOAP-ENV:Body>
−
<SOAP-ENV:Fault>
<faultcode>Server</faultcode>
<faultactor>method '' not defined in service ''</faultactor>
<faultstring/>
−
<detail>
<soapVal xsi:type="xsd:string"/>
</detail>
</SOAP-ENV:Fault>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
−
<!--

soap_server: entering parseRequest() on 09:59 2009-06-25
soap_server: Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
soap_server: Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
soap_server: Accept-Encoding: gzip,deflate
soap_server: Accept-Language: de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
soap_server: Connection: keep-alive
soap_server: Cookie: PHPSESSID=9c1d9bedc052d0ad8135a09f241df362; sessionispconfig=2090f3d08f810a0beaefd6bb3a10cdde; roundcube_sessid=1c174934073ec9ec0fb5ed190611c30f
soap_server: Host: ###.###.###.###:81
soap_server: Keep-Alive: 300
soap_server: User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
soap_server: got encoding: UTF-8
soap_server: method name: 
soap_server: method '' not found!
soap_server: parser debug: 
soap_parser: xml was empty, didn't parse!

soap_server: server sending...

-->
which seems to be ok to me.

Any hints?

Last edited by teves; 26th June 2009 at 13:44. Reason: Sorry, wrong forum
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
autosignup remoting framework howto detailed kextra1 Tips/Tricks/Mods 21 1st March 2012 06:59
Remoting Problem 2.2.30 kextra1 Installation/Configuration 3 4th April 2009 09:55
remoting framework problem with 2.2.14 mumbly Installation/Configuration 27 11th July 2007 20:17
Remoting framework: 'Error: Server' NTAuthority Installation/Configuration 4 29th June 2007 00:25
ISPConfig Remoting Framework tsj5j Installation/Configuration 1 22nd June 2007 11:19


All times are GMT +2. The time now is 22:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.