Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th June 2009, 16:11
JimmiJames JimmiJames is offline
Member
 
Join Date: Jun 2006
Posts: 51
Thanks: 4
Thanked 0 Times in 0 Posts
Default DNS server not working externally!

I've setup a DNS server(Debian ispconfig3 perfect server). It works fine internally with domains that we own, but it doesn't resolve any other domain on the internet.

Any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 13th June 2009, 07:05
Artanis Artanis is offline
Junior Member
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also having this issue on one of my ispconfig3 servers.

the nameservers in /etc/resolve.conf are all pingable as are all external IP's i've tried, but all I can't resolve any DNS records.
Reply With Quote
  #3  
Old 13th June 2009, 08:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,389 Times in 4,234 Posts
Default

http://www.howtoforge.com/forums/showthread.php?t=35633
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 13th June 2009, 11:24
Artanis Artanis is offline
Junior Member
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Tried that, anything else?
Reply With Quote
  #5  
Old 14th June 2009, 14:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's in your /etc/resolv.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 14th June 2009, 15:49
Artanis Artanis is offline
Junior Member
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
nameserver 64.85.160.4
nameserver 209.165.240.227
nameserver 208.67.222.222
First two being VPS providers nameservers, last being OpenDNS nameserver.
Reply With Quote
  #7  
Old 15th June 2009, 14:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you add
Code:
nameserver 145.253.2.75
in the first place?
Does
Code:
dig google.com
work then?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 15th June 2009, 22:09
JimmiJames JimmiJames is offline
Member
 
Join Date: Jun 2006
Posts: 51
Thanks: 4
Thanked 0 Times in 0 Posts
Default

I can dig, I can ping, tried different nameservers still doesn't work. I have 3 debian machines, none have DNS working.
Reply With Quote
  #9  
Old 17th June 2009, 10:54
ajhart ajhart is offline
Junior Member
 
Join Date: Jun 2009
Posts: 15
Thanks: 4
Thanked 0 Times in 0 Posts
Default DNS not working.

Hi guys.
First off, I'm quite new to this all and strugling my head off. I don't know much of this all but I can make some sence of Linux and ISPConfig. (What a Noob!?) ha ha

Right, I'm running ISPConfig 3 on Fedora 10 setuped through Perfect Server tut.
I have 3 eth cards in my server, one for internal (10.1.1.210) firewalled by mikrotik router and the other two with a public ip each (196.212.216.75, ADSL fiber Billion router) and (196.212.78.51 ASDL sat Cisco router) ISP provider @ Datapro. The two DNS I got fromm them is 168.210.2.2 and 196.14.239.2, where I get my internet from.

What I intend to do is to use one public ip for a ns1 and the second for a ns2 and register a domain gbsecwireless.co.za.

So first, this is how my server cfg looks like:

Code:
[global]
webserver=apache
mailserver=postfix
dnsserver=mydns

[server]
auto_network_configuration=
ip_address=10.1.1.210
netmask=255.255.255.0
gateway=10.1.1.1
hostname=server.gbsecwireless.co.za
nameservers=168.210.2.2, 196.14.239.2

[mail]
module=postfix_mysql
maildir_path=/var/vmail/[domain]/[localpart]
homedir_path=/var/vmail
mailuser_uid=5000
mailuser_gid=5000
mailuser_name=vmail
mailuser_group=vmail
relayhost=
relayhost_user=
relayhost_password=
mailbox_size_limit=0
message_size_limit=0

[getmail]
getmail_config_dir=/etc/getmail

[web]
website_basedir=/var/www
website_path=/var/www/clients/client[client_id]/web[website_id]
website_symlinks=/var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/
vhost_conf_dir=/etc/httpd/conf/sites-available
vhost_conf_enabled_dir=/etc/httpd/conf/sites-enabled

[fastcgi]
fastcgi_starter_path=/var/www/php-fcgi-scripts/[system_user]/
fastcgi_starter_script=.php-fcgi-starter
fastcgi_alias=/php/
fastcgi_phpini_path=/etc/
fastcgi_children=8
fastcgi_max_requests=5000
fastcgi_bin=/usr/bin/php-cgi

[jailkit]
jailkit_chroot_home=/home/[username]
jailkit_chroot_app_sections=basicshell editors extendedshell netutils ssh sftp scp groups jk_lsh
jailkit_chroot_app_programs=/usr/bin/groups /usr/bin/id /usr/bin/dircolors /bin/basename /usr/bin/dirname /usr/bin/nano
Second, I created a new client and a mail domain



Then I added a site



And then I added a DNS Zone with records





I added a DNS record on my mikrotik so I can access the site www.gbsecwireless.co.za from my internal network


And it is working perfectley fine. I installed Joomla and its working like a dream.

Code:
[root@server ~]# cat /etc/resolv.conf
# Generated by NetworkManager
search gbsecwireless.co.za gbsecwireless.co.za gbsecwireless.co.za
nameserver 168.210.2.2
[root@server ~]# dig google.com

; <<>> DiG 9.5.1-P2-RedHat-9.5.1-2.P2.fc10 <<>> google.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63250
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;google.com.                    IN      A

;; ANSWER SECTION:
google.com.             106     IN      A       74.125.127.100
google.com.             106     IN      A       74.125.67.100
google.com.             106     IN      A       74.125.45.100

;; Query time: 40 msec
;; SERVER: 168.210.2.2#53(168.210.2.2)
;; WHEN: Wed Jun 17 09:53:46 2009
;; MSG SIZE  rcvd: 76

[root@server ~]#
Now the thing is, when I try to regester the domain gbsecwireless.co.za at co.za uniform, they tell me that they can't resolve my forward or PTR dns. I can ping both public ip's and co.za as well. Could it maybe be because of my ISP or is there something wrong with my config.

Any help would be very apreciated!!
Thanks in advance!!
__________________
SYSTEM FAILURE
Resistance is futile
Reply With Quote
  #10  
Old 17th June 2009, 12:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

@ajhart: Please open a new thread.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 22:08
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
Problem with keeping Apache alive bobeq Server Operation 3 29th November 2007 16:11
How set DNS entry for different server? SupuS Installation/Configuration 1 12th June 2006 09:48
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 08:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.