Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th June 2009, 10:54
n0h4t n0h4t is offline
Junior Member
 
Join Date: Jun 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Yet Another Internal Server Error/.htaccess Post

Hi All,

Firstly thanks to Falko, Till and the other moderators for a great job they are doing here.

I have installed a php script by the name of "amember" on an ISPConfig controlled machine running Centos 5.2 & Apache 2 and I get this "internal error 500" message with my .htaccess files. These files are necessary for my "amember" script and altering them is not an option.

I have read similar posts on this forum and tried many of the solutions and I have come to a dead end and wondered if anyone would be kind enough to give me some advice.

Sample Error.log:
Quote:
[Mon Jun 15 14:55:24 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:24 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:24 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:25 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:25 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:25 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:25 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:25 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:25 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:26 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:26 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:26 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:26 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:26 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 14:55:26 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: Options not allowed here
[Mon Jun 15 15:37:22 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
[Mon Jun 15 15:37:22 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
[Mon Jun 15 15:37:25 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
[Mon Jun 15 15:37:25 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
[Mon Jun 15 15:39:41 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
[Mon Jun 15 15:39:41 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
[Mon Jun 15 15:46:29 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
[Mon Jun 15 15:46:29 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
[Mon Jun 15 16:39:32 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
[Mon Jun 15 16:39:32 2009] [alert] [client 85.180.187.166] /var/www/web15/web/.htaccess: <Directory not allowed here
Things I Tried httpd.conf:-

General
Quote:
# First, we configure the "default" to be a very restrictive set of
# permissions.
#
<Directory /var/www/web15/web>
AllowOverride All
</Directory>
&

Directories
Quote:
# AllowOverride None

<Directory "/var/www/web15/web">
Options +FollowSymLinks +Includes -Indexes
AllowOverride All
# AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all

<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>
.htaccess file in root:-
Quote:
Options +FollowSymLinks
RewriteEngine On
RewriteCond %{HTTP_HOST} ^fxsignaltrader\.co.uk$ [NC]
RewriteRule ^(.*)$ http://www.fxsignaltrader.co.uk/$1 [R=301,L]

IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
IndexIgnore */*
IndexIgnore *.gif *.jpg

<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
.htaccess file in sample directory:-
Quote:
########### AMEMBER START #####################
Options +FollowSymLinks
RewriteEngine On

## allow access for product #1
RewriteCond %{HTTP_COOKIE} amember_nr=([a-zA-Z0-9]+)
RewriteCond /home/signal/public_html/fxstam/data/new_rewrite/%1-1 -f
RewriteRule ^(.*)$ - [L]

## if user is not authorized, redirect to login page
# BrowserMatch "MSIE" force-no-vary
RewriteCond %{QUERY_STRING} (.+)
RewriteRule ^(.*)$ http://www.fxsignaltrader.co.uk/fxstam/plugins/protect/new_rewrite/login.php?v=-1&url=%{REQUEST_URI}?%{QUERY_STRING} [L,R]
RewriteRule ^(.*)$ http://www.fxsignaltrader.co.uk/fxstam/plugins/protect/new_rewrite/login.php?v=-1&url=%{REQUEST_URI} [L,R]
########### AMEMBER FINISH ####################
Just in case this might be needed the Virtualhost entry:-
Quote:
######################################
# Vhost: www.fxsignaltrader.co.uk:80
######################################
#
#
<VirtualHost 208.70.146.253:80>
ServerName www.fxsignaltrader.co.uk:80
ServerAdmin radley@fxsignaltrader.com
DocumentRoot /var/www/web15/web
ServerAlias fxsignaltrader.co.uk blog.fxsignaltrader.co.uk
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
Alias /cgi-bin/ /var/www/web15/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web15/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_flag safe_mode On
php_admin_value open_basedir /var/www/web15/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /var/www/web15/phptmp/
php_admin_value session.save_path /var/www/web15/phptmp/
<IfModule mod_ruby.c>
<Directory /var/www/web15/web>
Options +ExecCGI
</Directory>
RubyRequire apache/ruby-run
#RubySafeLevel 0
<Files *.rb>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
<Files *.rbx>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
</IfModule>
<IfModule mod_python.c>
<Directory /var/www/web15/web>
Options +Indexes +FollowSymLinks +MultiViews
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
allow from all
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/var/www/web15/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web15/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web15/user/$1/web/$3
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
RewriteRule .* - [F]
</IfModule>
</VirtualHost>

As with the other people with similar problems when I rename my .htaccess files everything works fine, well the error doesn't occur. Sorry for such a long post!

Thanks in advance!

Best Regards,

Dave
Reply With Quote
Sponsored Links
  #2  
Old 16th June 2009, 15:12
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,418
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

The error message explians it already, you have options in your .htaccess file that yre not allowed for .htaccess files in your setup. So the solution is the same then posted in all similar threads, either you add these directives to the apache directives field of the website in ispconfig which is the preferred solution or you allow overriding of all values trogh .htaccess files which works but is insecure.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th June 2009, 15:34
HooGLaNDeR HooGLaNDeR is offline
Member
 
Join Date: Sep 2006
Posts: 49
Thanks: 7
Thanked 1 Time in 1 Post
Default

It seems that mod rewrite hasn't been enabled.
__________________
A computer is almost human - except that it does not blame its mistakes on another computer.
Reply With Quote
  #4  
Old 16th June 2009, 15:52
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,418
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

No, thats not related to mod_rewrite. Just do what I suggested above.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 16th June 2009, 17:37
n0h4t n0h4t is offline
Junior Member
 
Join Date: Jun 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Till & Hooglander for taking the time to answer my post. I 'll give it a try later tonight, thanks again.

Best Regards,

Dave
Reply With Quote
  #6  
Old 16th June 2009, 17:43
HooGLaNDeR HooGLaNDeR is offline
Member
 
Join Date: Sep 2006
Posts: 49
Thanks: 7
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by n0h4t View Post
Thanks Till & Hooglander for taking the time to answer my post. I 'll give it a try later tonight, thanks again.

Best Regards,

Dave
You can use the "thanks" button under the post This has the same effect.
__________________
A computer is almost human - except that it does not blame its mistakes on another computer.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
procmail problem - mail delivery Lobanak Installation/Configuration 4 1st March 2009 22:24
Apache LoadBalanced, Ldirector. eterzella HOWTO-Related Questions 6 7th February 2009 15:43
Connection dropped by IMAP server gublym Server Operation 5 23rd January 2009 09:47
Help! Why do I see message about Apache, CPanel & WHM. I don't run cpanel! websissy Installation/Configuration 3 18th November 2008 22:16
got 500 internal server error tried to enable chmod from FTP smilem Installation/Configuration 13 17th January 2008 01:34


All times are GMT +2. The time now is 16:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.