Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th April 2006, 12:38
r12dk r12dk is offline
Junior Member
 
Join Date: Apr 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with saslauthd - Debian Perfect setup 3.1 + ISPConfig

Hello

Looking at the forums, it looks like lots of people have the same problem as me. But still, none of the solutions work for me. So ill just make yet another post.

My problem is that i cannot auth with saslauthd, to send mails over smtp.

log from authd
Code:
Apr 12 12:11:21 server02 saslauthd[13840]: (pam_unix) check pass; user unknown
Apr 12 12:11:21 server02 saslauthd[13840]: (pam_unix) authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=
Apr 12 12:11:22 server02 saslauthd[13840]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying authentication module
Apr 12 12:11:22 server02 saslauthd[13840]: do_auth         : auth failure: [user=web1_peter@server02.host.eu] [service=smtp] [realm=server02.host.eu] [mech=pam] [reason=PAM auth error]
and some ps
Code:
server02:/home/peter# ps aux | grep sasl
root     13836  0.0  0.0   6188  1744 ?        Ss   12:09   0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root     13837  0.0  0.0   6188  1744 ?        S    12:09   0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root     13838  0.0  0.0   6064  1572 ?        S    12:09   0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root     13839  0.0  0.0   6188  1744 ?        S    12:09   0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
root     13840  0.0  0.0   6188  1744 ?        S    12:09   0:00 /usr/sbin/saslauthd -m /var/spool/postfix/var/run/saslauthd -r -a pam
And telnetting to 25 gives:

Code:
250-server02.host.eu
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
And, hmm, what else, everything is like the "perfekt setup" for sarge 3.1.

Thanks for any help.

Peter

Last edited by r12dk; 13th April 2006 at 21:08.
Reply With Quote
Sponsored Links
  #2  
Old 12th April 2006, 16:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The user "web1_peter@server02.host.eu" can not exist, usernames in linux never have @ signs.

You must use just "web1_peter" as smtp username.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th April 2006, 16:47
r12dk r12dk is offline
Junior Member
 
Join Date: Apr 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hmm, your right.

In thunderbird (just tested with evolution also) i only write "web1_peter" as username for smtp. Then, where does @serve... come from?

Any idea where it might come from?

Thanks
Peter
Reply With Quote
  #4  
Old 12th April 2006, 23:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by r12dk
Then, where does @serve... come from?
What do you mean with this?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 13th April 2006, 14:31
r12dk r12dk is offline
Junior Member
 
Join Date: Apr 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The logs shows

Code:
auth failure: [user=web1_peter@server02.host.eu] [service=smtp] [realm=server02.host.eu] [mech=pam] [reason=PAM auth error]
And i only login with "web1_peter" not "web1_peter@server02.host.eu" as till pointed out to be the problem. Then iam asking, if someone knows why "web1_peter" gets to be "web1_peter@server02.host.eu" `?

I have tested in thunderbird and evolution, same result for both.
Reply With Quote
  #6  
Old 13th April 2006, 23:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Please check your email clients again that they really use web1_peter instead of web1_peter@server02.host.eu.

What's in /etc/postfix/sasl/smtpd.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 14th April 2006, 00:07
r12dk r12dk is offline
Junior Member
 
Join Date: Apr 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Ahh i found it.

Quite simple really. You did tell me in the other thread to follow the howto 100% and not look left and right. In the howto you write

Code:
 postconf -e 'smtpd_sasl_local_domain ='
but later in the box for main.cf you write

Code:
smtpd_sasl_local_domain = $myhostname
And then when authing with "web1_peter" it of course translates to "web1_peter@server02.host.eu"

So when fixing this, all works well.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Setup - Debian Sarge (3.1) problems bbking HOWTO-Related Questions 8 20th January 2008 19:58
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 20:58
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42
ISPConfig setup error with Debian Sarge Rocky Installation/Configuration 13 11th November 2005 00:47
Problems installing ISPConfig Debian Sarge hschel Server Operation 4 22nd August 2005 19:46


All times are GMT +2. The time now is 16:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.