Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th June 2009, 11:39
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Question SMTP Authentication not enabled on 3.0.1.3 / Ubuntu 9.04

Hi,
i just installed a Server, according to http://www.howtoforge.com/perfect-se...04-ispconfig-3 and now i realised that SMTP-Auth is not enabled.

Code:
telnet localhost 25
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 xxxxxx ESMTP Postfix (Ubuntu)
I already made a forum search but i could not find anything :/
How can i enable the SMTP-Auth?

Thanks in advance! Fabian
Reply With Quote
Sponsored Links
  #2  
Old 11th June 2009, 18:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,419
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

SMTP-Auth is always enabled in a ispconfig setup. You can rerun the the ispconfig setup with the update.php script if you have overwritten any config files.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 12th June 2009, 15:28
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Default

i have not changed any files, but i will give the update a try, thanks
Reply With Quote
  #4  
Old 16th June 2009, 15:14
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Default

i updated ispconfig from SVN since it was not able to find a new stable release using /usr/local/ispconfig/server/scripts/ispconfig_update.sh

- still no auth.

As i said before, i have not changed any files. Just installed ISPConfig on a clean Lenny-Installation.

Code:
Operating System: Debian Lenny/Sid or compatible

This application will update ISPConfig 3 on your server.
MySQL root password []: xxxxxx

Reconfigure Services? (yes,no) [yes]: 

Configuring Postfix
Configuring Jailkit
Configuring SASL
Configuring PAM
Configuring Courier
Configuring Spamassassin
Configuring Amavisd
Configuring Getmail
Configuring Pureftpd
Configuring MyDNS
Configuring Apache
Configuring vlogger
Configuring Database
Configuring Firewall
Updating ISPConfig
ISPConfig Port [8080]: 

Reconfigure Crontab? (yes,no) [yes]: 

Updating Crontab
Restarting services ...
 * Stopping MySQL database server mysqld
   ...done.
 * Starting MySQL database server mysqld
   ...done.
 * Checking for corrupt, not cleanly closed and upgrade needing tables.
 * Stopping Postfix Mail Transport Agent postfix
   ...done.
 * Starting Postfix Mail Transport Agent postfix
   ...done.
 * Stopping SASL Authentication Daemon saslauthd
   ...done.
 * Starting SASL Authentication Daemon saslauthd
   ...done.
Stopping amavisd: amavisd-new.
Starting amavisd: amavisd-new.
 * Stopping ClamAV daemon clamd
   ...done.
 * Starting ClamAV daemon clamd 
LibClamAV Warning: ***********************************************************
LibClamAV Warning: ***  This version of the ClamAV engine is outdated.     ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************
   ...done.
 * Stopping Courier authentication services authdaemond
   ...done.
 * Starting Courier authentication services authdaemond
   ...done.
 * Stopping Courier IMAP server...
   ...done.
 * Starting Courier IMAP server...
   ...done.
 * Stopping Courier IMAP-SSL server...
   ...done.
 * Starting Courier IMAP-SSL server...
   ...done.
 * Stopping Courier POP3 server...
   ...done.
 * Starting Courier POP3 server...
   ...done.
 * Stopping Courier POP3-SSL server...
   ...done.
 * Starting Courier POP3-SSL server...
   ...done.
 * Restarting web server apache2
 ... waiting    ...done.
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -O clf:/var/log/pure-ftpd/transfer.log -A -u 1000 -E -b -B
Update finished.
root@scooby:/usr/local/ispconfig/server/scripts# telnet localhost 25
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 xxx.xxx.de ESMTP Postfix (Ubuntu)
quit
Connection closed by foreign host.
Reply With Quote
  #5  
Old 16th June 2009, 15:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,419
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

Please post an excerpt of your mail log.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 16th June 2009, 16:11
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
Default

during update:

Code:
postfix/master[15075]: terminating on signal 15
postfix/master[1243]: daemon started -- version 2.5.5, configuration /etc/postfix
amavis[1305]: starting.  /usr/sbin/amavisd-new at xxx.xxx.xxx amavisd-new-2.6.2 (20081215), Unicode aware, LANG="en_US.UTF-8"
amavis[1305]: Perl version               5.010000
amavis[1310]: Net::Server: Group Not Defined.  Defaulting to EGID '119 119'
amavis[1310]: Net::Server: User Not Defined.  Defaulting to EUID '110'
amavis[1310]: Module Amavis::Conf        2.203
amavis[1310]: Module Archive::Zip        1.18
amavis[1310]: Module BerkeleyDB          0.34
amavis[1310]: Module Compress::Zlib      2.015
amavis[1310]: Module Convert::TNEF       0.17
amavis[1310]: Module Convert::UUlib      1.11
amavis[1310]: Module Crypt::OpenSSL::RSA 0.25
amavis[1310]: Module DBD::mysql          4.008
amavis[1310]: Module DBI                 1.607
amavis[1310]: Module DB_File             1.816_1
amavis[1310]: Module Digest::MD5         2.36_01
amavis[1310]: Module Digest::SHA         5.45
amavis[1310]: Module Digest::SHA1        2.11
amavis[1310]: Module IO::Socket::INET6   2.54
amavis[1310]: Module MIME::Entity        5.427
amavis[1310]: Module MIME::Parser        5.427
amavis[1310]: Module MIME::Tools         5.427
amavis[1310]: Module Mail::DKIM::Signer  0.33
amavis[1310]: Module Mail::DKIM::Verifier 0.33
amavis[1310]: Module Mail::Header        2.04
amavis[1310]: Module Mail::Internet      2.04
amavis[1310]: Module Mail::SPF           v2.006
amavis[1310]: Module Mail::SpamAssassin  3.002005
amavis[1310]: Module Net::DNS            0.63
amavis[1310]: Module Net::Server         0.97
amavis[1310]: Module NetAddr::IP         4.022
amavis[1310]: Module Socket6             0.20
amavis[1310]: Module Time::HiRes         1.9711
amavis[1310]: Module URI                 1.37
amavis[1310]: Module Unix::Syslog        1.1
amavis[1310]: Amavis::DB code      loaded
amavis[1310]: Amavis::Cache code   loaded
amavis[1310]: SQL base code        loaded
amavis[1310]: SQL::Log code        NOT loaded
amavis[1310]: SQL::Quarantine      NOT loaded
amavis[1310]: Lookup::SQL code     loaded
amavis[1310]: Lookup::LDAP code    NOT loaded
amavis[1310]: AM.PDP-in proto code loaded
amavis[1310]: SMTP-in proto code   loaded
amavis[1310]: Courier proto code   NOT loaded
amavis[1310]: SMTP-out proto code  loaded
amavis[1310]: Pipe-out proto code  NOT loaded
amavis[1310]: BSMTP-out proto code NOT loaded
amavis[1310]: Local-out proto code loaded
amavis[1310]: OS_Fingerprint code  NOT loaded
amavis[1310]: ANTI-VIRUS code      loaded
amavis[1310]: ANTI-SPAM code       loaded
amavis[1310]: ANTI-SPAM-SA code    loaded
amavis[1310]: Unpackers code       loaded
amavis[1310]: DKIM code            loaded
amavis[1310]: Tools code           NOT loaded
amavis[1310]: Found $file            at /usr/bin/file
amavis[1310]: No $dspam,             not using it
amavis[1310]: No $altermime,         not using it
amavis[1310]: Internal decoder for .mail
amavis[1310]: No decoder for       .F   
amavis[1310]: Found decoder for    .Z    at /bin/uncompress
amavis[1310]: Internal decoder for .gz  
amavis[1310]: Found decoder for    .bz2  at /bin/bzip2 -d
amavis[1310]: Found decoder for    .lzo  at /usr/bin/lzop -d
amavis[1310]: No decoder for       .rpm  tried: rpm2cpio.pl, rpm2cpio
amavis[1310]: Found decoder for    .cpio at /usr/bin/pax
amavis[1310]: Found decoder for    .tar  at /usr/bin/pax
amavis[1310]: Found decoder for    .deb  at /usr/bin/ar
amavis[1310]: Internal decoder for .zip 
amavis[1310]: No decoder for       .7z   tried: 7zr, 7za, 7z
amavis[1310]: No decoder for       .rar  tried: unrar-free
amavis[1310]: Found decoder for    .arj  at /usr/bin/arj
amavis[1310]: Found decoder for    .arc  at /usr/bin/nomarch
amavis[1310]: Found decoder for    .zoo  at /usr/bin/zoo
amavis[1310]: No decoder for       .lha 
amavis[1310]: No decoder for       .doc  tried: ripole
amavis[1310]: Found decoder for    .cab  at /usr/bin/cabextract
amavis[1310]: No decoder for       .tnef
amavis[1310]: Internal decoder for .tnef
amavis[1310]: Found decoder for    .exe  at /usr/bin/arj
amavis[1310]: Using primary internal av scanner code for ClamAV-clamd
amavis[1310]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
amavis[1310]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.34, libdb 4.6
authdaemond: stopping authdaemond children
authdaemond: modules="authmysql", daemons=5
authdaemond: Installing libauthmysql
authdaemond: Installation complete: authmysql
connect via telnet:
Code:
postfix/smtpd[2132]: connect from xxx.dip.t-dialin.net[xx.xx.xx.xx]
Reply With Quote
  #7  
Old 16th June 2009, 19:13
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 262 Times in 208 Posts
Default

What makes you think that auth is not enabled?
Did you try typing
Code:
ehlo localhost
when connected via telnet?

Output should be like this:
Code:
ehlo localhost
250-xxxx.xxxxx.de
250-PIPELINING
250-SIZE
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
Reply With Quote
  #8  
Old 17th June 2009, 09:31
fuban fuban is offline
Junior Member
 
Join Date: Sep 2005
Posts: 19
Thanks: 0
Thanked 2 Times in 2 Posts
 
Default

uh, that works. had in mind that the "AUTH PLAIN LOGIN" messages show up on connect.
sorry about the confusion.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Uploads timing out Gaartok Server Operation 3 10th May 2009 18:04
Postfix issues NewMee Installation/Configuration 7 20th April 2009 18:52
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 13:49
The classic MySQL connect error swggy Installation/Configuration 13 10th April 2008 21:45
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47


All times are GMT +2. The time now is 17:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.