Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th April 2006, 20:09
rustyteck rustyteck is offline
Junior Member
 
Join Date: Apr 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default ispconfig and phpbb

ok installed and thanks to till running smoothly! my first real glitch is my installed phpbb which now resides in my web dir with my other files wont allow access. im guessing its not a php error as phpmyadmin works fine.
the error in the web log file is as follows:

[alert] [client 192.168.0.100 /srv/www/pages/web8/web/board/.htaccess: php_value not allowed here

my .htaccess from inside the board directory contains :
php_value upload_max_filesize 999M

what have i missed?
Reply With Quote
Sponsored Links
  #2  
Old 11th April 2006, 21:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Quote:
Originally Posted by rustyteck
[alert] [client 192.168.0.100 /srv/www/pages/web8/web/board/.htaccess: php_value not allowed here
This error is not directly PHP related, its a apache setting. The error means that setting php values in .htaccess files is not allowed, which is generally a good idea for security reasons.

Try to remove the line "php_value upload_max_filesize 999M" from your .htaccess file and put it in the apache directives window in the website settings in ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th April 2006, 22:23
rustyteck rustyteck is offline
Junior Member
 
Join Date: Apr 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default worked!

worked like a charm! my users websites are moved and weoking great! ive been able to change their urls with some dns entries from the ~username to username.domain.com but is there an easy way to have it linked? ie i have tried making a symlink from www.domain.com/~username to username.domain.com but it gives me the file not found error.... im thinking it may be due to my having the userdir in apache config? any ideas?
Reply With Quote
  #4  
Old 12th April 2006, 11:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

You can try some rewrite rules in an .htaccess file in the user's web directory. http://httpd.apache.org/docs/1.3/misc/rewriteguide.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.