Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th June 2009, 21:00
etpoole60 etpoole60 is offline
Junior Member
 
Join Date: Jun 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default The Perfect Server - CentOS 5.3 [ISPConfig 3] error

I was going throught the steps and go to suPHP, in particular:

cd /tmp
wget http://suphp.org/download/suphp-0.7.1.tar.gz
tar xvfz suphp-0.7.1.tar.gz
cd suphp-0.7.1/
./configure --prefix=/usr --sysconfdir=/etc --with-apr=/usr/bin/apr-1-config --with-apxs=/usr/sbin/apxs --with-apache-user=apache --with-setid-mode=owner --with-php=/usr/bin/php-cgi --with-logfile=/var/log/httpd/suphp_log --enable-SUPHP_USE_USERGROUP=yes
make
make install


However, when processing the .configure I received the following:

checking for APR... yes
checking for dynamic Apache module support (via APXS)... cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201.
cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201.
./configure: line 20370: /: is a directory
cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201.
cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201.
cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201.
found at /usr/sbin/apxs (version )
checking for set-UID/set-GID mode... ok - using owner
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating src/apache/Makefile
config.status: creating src/apache2/Makefile
config.status: creating src/config.h
config.status: src/config.h is unchanged
config.status: executing depfiles commands


So I searched for the files in question and was returned the following:

[root@jpdsys1 suphp-0.7.1]# cd $HOME
[root@jpdsys1 ~]# find / -name apxs
/usr/sbin/apxs
[root@jpdsys1 ~]# find / -name config_vars.mk
/usr/lib64/httpd/build/config_vars.mk
/usr/lib/httpd/build/config_vars.mk

So, it appears all of the required files are on the machine, but what needs to be done to correct this error?

Gene
Reply With Quote
Sponsored Links
  #2  
Old 16th June 2009, 16:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Did you disable SELinux?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th June 2009, 01:32
etpoole60 etpoole60 is offline
Junior Member
 
Join Date: Jun 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default The Perfect Server - CentOS 5.3 [ISPConfig 3] error

Yes sir. I just entered:

system-config-securitylevel

And SELinux shows as disabled.

Since this is a build I can re-do, I searched and found suphp in rpm form. I installed it and copied the module from the rpm's default location to the location your process was expecting and I was able to start HTTPD without error. But, I am sure that this will not work in the long run.

Gene
Reply With Quote
  #4  
Old 22nd July 2009, 00:04
boatrsp boatrsp is offline
Junior Member
 
Join Date: Oct 2006
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi,

Exactly the same problem here.
I double-checked SELinux, and here too it's disabled.

Robert
Reply With Quote
  #5  
Old 23rd July 2009, 16:15
boatrsp boatrsp is offline
Junior Member
 
Join Date: Oct 2006
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

This seems to be related to a bug in yum for CentOS.
See http://bugs.centos.org/view.php?id=2934
I re-installed apr-devel and httpd-devel, and it worked.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 16:22
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Could not make OpenSSL yontengyatso Installation/Configuration 3 3rd November 2005 10:50


All times are GMT +2. The time now is 10:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.