Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st March 2006, 00:28
benbalbo benbalbo is offline
Member
 
Join Date: Oct 2005
Posts: 50
Thanks: 0
Thanked 4 Times in 4 Posts
Default Second server cannot send email to own domain (hosted on first server)

I have installed ISPConfig on a second server and am unable to send email to anything@main-domain.com.

The issue lies in the fact that both servers use the same domain: server1.main-domain.com and server2.main-domain.com.

Both servers have main-domain.com in the local-host-names file, so server2 thinks it manages email for that domain, when in fact it's server1.

I've had a look at /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php to work out where this main domain is being added to find a way of not adding it to the list, but have come unstuck.

Any advice would be greatly appreciated!

A note to Till - I'm sorry I still haven't gotten round to doing the translation tool. I've been slack! Life has been quite busy lately, and I've not been getting enough sleep. I understand if you get someone else to do this job, but if not, I will get round to it just as soon as I get my life back :-)

Thanks!
Ben

Last edited by benbalbo; 1st March 2006 at 00:31.
Reply With Quote
Sponsored Links
  #2  
Old 1st March 2006, 10:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Did you create a web site for main-domain.com on server 2? Then go to that web site in ISPConfig and select "External Mailserver" for that domain.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st March 2006, 12:19
benbalbo benbalbo is offline
Member
 
Join Date: Oct 2005
Posts: 50
Thanks: 0
Thanked 4 Times in 4 Posts
Default

Thanks Falko - worked perfectly. Don't know why I didn't think of it myself...
Reply With Quote
  #4  
Old 13th March 2006, 08:47
benbalbo benbalbo is offline
Member
 
Join Date: Oct 2005
Posts: 50
Thanks: 0
Thanked 4 Times in 4 Posts
Default

Well I'm not sure why, but this domain is still marked as using an external mail server, but it keeps getting added to the local-host-names file. I'm starting to look into why, but if anyone has any ideas, I'd appreciate them.

Will post back if I find out the answer.
Reply With Quote
  #5  
Old 13th March 2006, 09:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

Quote:
Originally Posted by benbalbo
Well I'm not sure why, but this domain is still marked as using an external mail server, but it keeps getting added to the local-host-names file. I'm starting to look into why, but if anyone has any ideas, I'd appreciate them.
Do you have more the one web (subdomains) of this domain? Then please check all of these wbstes if they cotain this domain as co-domain and set these co-domaibs to external too.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 13th March 2006, 12:11
benbalbo benbalbo is offline
Member
 
Join Date: Oct 2005
Posts: 50
Thanks: 0
Thanked 4 Times in 4 Posts
Default

Thanks for the tip Till. It helped me debug the problem.

I checked the isp_isp_web table and found that the optionen_local_mailserver was linked to the main web name, not the co-domains.

If I edit the main web for www.main-domain.com and remove www from the hostname (leave it blank) and save, then it works - main-domain.com disappears from the local-host-names file. I need to be careful though, because when I edit this web agian, the blank hostname box defaults to www.

So in effect what I'm experiencing is the inability to specify an external mail server for any FQDN other than the main domain for the site (co-domains don't affect local-host-names) and that setting hostname to blank in the ispconfig admin console leads it to default to www upon next save.

Is this intended? Is this fixed in the latest verion? (I haven't upgraded to the version of ISPConfig that came out a few weeks ago yet).

Thanks!
Ben
Reply With Quote
  #7  
Old 13th March 2006, 12:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

In the ISPConfig interface, every co-domain has an options tab where you can set mailserver to external for this co-domain. This is independant from the "external mailserver" setting of the domain of the main website. Have you set mailserver to external on the option tab of all co-domains of the website?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 14th March 2006, 03:20
benbalbo benbalbo is offline
Member
 
Join Date: Oct 2005
Posts: 50
Thanks: 0
Thanked 4 Times in 4 Posts
Default

Thanks again Till, I wasn't aware of that tab :-)

Now I have another problem though - having made that change.

I have 10 clients who use theirname.main-domain.com and I've set up the site to have theirname as the host and main-domain.com as the domain name.

There are now many entries in isp_isp_domain with host NULL and domain main-domain.com. I've also noticed that if these clients wish to create an email address for themselves, it's set as @main-domain.com, not @theirname.main-domain.com

I presume that I have to put theirname.main-domain.com as the domain, and leave the hostname blank?

I'll try it and see what happens, but would like to know what the 'official' way os to set these up.

Thanks,
Ben
Reply With Quote
  #9  
Old 14th March 2006, 03:32
benbalbo benbalbo is offline
Member
 
Join Date: Oct 2005
Posts: 50
Thanks: 0
Thanked 4 Times in 4 Posts
Default

Okay - putting the full names in as the domain name seems to have fixed it.

BB
Reply With Quote
  #10  
Old 14th March 2006, 08:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
 
Default

Quote:
Originally Posted by benbalbo
Thanks again Till, I wasn't aware of that tab :-)

Now I have another problem though - having made that change.

I have 10 clients who use theirname.main-domain.com and I've set up the site to have theirname as the host and main-domain.com as the domain name.

There are now many entries in isp_isp_domain with host NULL and domain main-domain.com. I've also noticed that if these clients wish to create an email address for themselves, it's set as @main-domain.com, not @theirname.main-domain.com

I presume that I have to put theirname.main-domain.com as the domain, and leave the hostname blank?

I'll try it and see what happens, but would like to know what the 'official' way os to set these up.

Thanks,
Ben

If you create a new website like user.domain.com, please check if ISPConfig created a new co-domain with empty host automatically. You must delete these automatically created co-domains. This is fixed in ISPConfig 2.2.0.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive email mzo Installation/Configuration 17 3rd November 2011 15:59
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
Server Not Autorative for Domain Error drbista Installation/Configuration 10 20th December 2005 16:41
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 06:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.