Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th October 2009, 20:52
Eric Pinxteren Eric Pinxteren is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Question Changed ip, internet connection problem

Hallo,

I recently installed a new server with ispconfig 3, everything worked fine. I run multiple websites with different clients and multiple mail and ftp users. But I just changed my server ip address and gateway configuration, and canít connect to server with ftp or send/receive mail.

I think I donít have internet connection on my linux system, what is strange because I can connect to the different websites on server and get a connection with putty. if I am logged on the server, I canít get a connection with different aps like apt-get update,links, or wget.

This are the configurations I changed:

From:
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#allow-hotplug eth0
auto eth0
iface eth0 inet static
        address 192.168.120.120
        netmask 255.255.255.0
        network 129.168. 120.0
        broadcast 192.168. 120.255
        gateway 192.168. 120.1
To:
Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#allow-hotplug eth0
auto eth0
iface eth0 inet static
        address 192.168.2.120
        netmask 255.255.255.0
        network 129.168.2.0
        broadcast 192.168.2.255
        gateway 192.168.2.254
After that I did:
Code:
/etc/init.d/networking restart
And changed the host
From:
Code:
127.0.0.1       localhost.localdomain   localhost
192.168.120.120   LinuxServer.j2e.nl      LinuxServer
To:
Code:
127.0.0.1       localhost.localdomain   localhost
192.168.2.120   LinuxServer.j2e.nl      LinuxServer
And did:
Code:
echo LinuxServer.j2e.nl      > /etc/hostname
/etc/init.d/hostname.sh start
I hope you can help me, thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 13th October 2009, 20:56
Franz Franz is offline
Senior Member
 
Join Date: Jul 2009
Location: Cakovec
Posts: 117
Thanks: 7
Thanked 24 Times in 18 Posts
Send a message via Skype™ to Franz
Default

did you change DNS record, or external IP was not changet?
__________________
my PAGE
VoIP
my IT help blog
Reply With Quote
  #3  
Old 13th October 2009, 22:46
Eric Pinxteren Eric Pinxteren is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Iím new to servers and Linux, i did not work with the tab DNS in ISPconfig. And yes my external ip has changed, but I donít think thatís the problem?, I donít have internet from inside the server..
Reply With Quote
  #4  
Old 13th October 2009, 22:51
Franz Franz is offline
Senior Member
 
Join Date: Jul 2009
Location: Cakovec
Posts: 117
Thanks: 7
Thanked 24 Times in 18 Posts
Send a message via Skype™ to Franz
Default

can you ping, like ping google.com?
__________________
my PAGE
VoIP
my IT help blog
Reply With Quote
  #5  
Old 14th October 2009, 09:07
Eric Pinxteren Eric Pinxteren is offline
Junior Member
 
Join Date: Sep 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No i can't ping any website on wan.., i can ping in the lan.
Reply With Quote
  #6  
Old 14th October 2009, 09:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: LŁneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
 
Default

Please make sure that you entered the IP of a working and reachable external DNS Server in the /etc/resolv.conf file on your Linux server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
internet connection, ip address

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Attacks on MTA dclardy Installation/Configuration 4 29th September 2009 16:50
My php scripts don't send e-mail html forms. CombatGod Installation/Configuration 5 8th November 2006 10:16
kann keine mails empfangen odin1 Installation/Configuration 5 6th July 2006 12:13
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30
Internet Mail Problem deezone Installation/Configuration 9 22nd February 2006 21:09


All times are GMT +2. The time now is 02:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.