Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th September 2009, 15:28
id10t id10t is offline
Senior Member
 
Join Date: Nov 2008
Posts: 240
Thanks: 2
Thanked 22 Times in 22 Posts
Default SNI support? single ip, multiple SSL hosts

http://wiki.apache.org/httpd/NameBasedSSLVHostsWithSNI

Apparently SNI is supported by browsers already (and has been) AND it lets you use one IP, multiple vhosts, and multiple SSL certs.

Could this be integrated into ISPConfig? If not 2, it would be a major reason for me to rebuild and go to ISPConfig 3 ....

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 30th September 2009, 09:35
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,687
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
 
Default

The last time I tested it, SNI was not precompiled into the apache packages of the major Linux distributions. If this has changed , we can add this feature in ISPConfig. Otherwise poeple would enable it and then complain that it does not work with their setup.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
id10t (30th September 2009)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
server Installation Configuration deco5003 Installation/Configuration 12 5th August 2009 12:00
Installation -- pcre_exec.c:403: internal compiler error: Segmentation fault zerman Installation/Configuration 2 23rd September 2008 23:58
Update php shajazzi Server Operation 6 6th April 2008 18:20
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! micko_escalade Installation/Configuration 35 30th March 2007 11:31
ISPConfig Failure on SuSe 9.3 gimhan90 Installation/Configuration 13 2nd February 2006 10:29


All times are GMT +2. The time now is 10:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.