Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th June 2009, 13:55
Widda Widda is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Canon Pixma MP170 driver

hello!
I'm asking for some help in downloading the driver and using my printer again.
I know, from following some links to databases, that this printer is Linux compatible.
I have Mandriva 2009.0.
I've also followed links to drivers, but don't understand what I'm seeing,
strings of symbols, linux terminology, (CUPS etc etc) and not even sure where the driver is amongst it all,
new to linux, but I'm in at the deep end, Windows deleted! no regrets but plenty of difficulty!
Reply With Quote
Sponsored Links
  #2  
Old 11th June 2009, 18:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's your printer model, and what exactly have you done so far?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th June 2009, 19:03
Widda Widda is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've upgraded to 2009.1 now.
The printer model is Canon Pixma MP170 printer/scanner/copier.

Sorry to say, I've been so busy loading packets (from your mandriva o9.1/gnome recipe), I've forgotten everything I did with the printer.
I might remember after a sleep.( it's 0200 in Australia)
Reply With Quote
  #4  
Old 12th June 2009, 18:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Accoring to http://openprinting.org/show_printer...on-PIXMA_MP170 , you should install the gutenprint driver. At the bottom of the page, there are also download links for rpm packages.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 13th June 2009, 19:54
Widda Widda is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks falco,
I d'loaded that stuff, didnt know where they might land or what to do with them, but no detection of printer. after a long time thought of opening ControlCentre, where there was a new printer config button, installed everything it wanted; also I noticed my printer is listed as available in the "Scanner' section.

Since then I've been around to so many places and options, but all I can remember is a CUPS issue - the troubleshooter said go to system and find it;
I ticked it there.
There was one place that said 'Can't autodect if parallel ports are used' and I changed something.
Sorry it's all vague. I don't know how to remember all this stuff to tell the story! Logs might be the answer to that I suppose.

After downloading Gutenprint and a couple of RPMs, what would one normally do next? I'm sure something different from my actions.
Reply With Quote
  #6  
Old 13th June 2009, 20:03
Widda Widda is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

oops: falko
Reply With Quote
  #7  
Old 14th June 2009, 15:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you just download the RPMs, or did you also install them?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 14th June 2009, 17:56
Widda Widda is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not sure.
Where would they be if I did?
I'll look for them.
Oh, i'll look in 'Installed' column under Software in Control Room
Reply With Quote
  #9  
Old 14th June 2009, 18:15
Widda Widda is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The ones I chose were x86 32 bit (RPM for LSB 3.1)
and (RPM for LSB 3.2). Didn't download any DEBs.

But I can't find whether they're installed.
Reply With Quote
  #10  
Old 15th June 2009, 08:46
Widda Widda is offline
HowtoForge Supporter
 
Join Date: Jun 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I just downloaded the RPMs again, and opened with default installer, and they went to /tmp, so I went there and found a folder called Gutenprint 5.2.3. , and inside that are many mysteries which I do not touch.

But time to test the printer again.
Reply With Quote
Reply

Bookmarks

Tags
canon, driver, printer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Manual loading of skge and sky2 driver in the 2.4.26 based system tommyclee Kernel Questions 5 23rd January 2009 14:59
Mandriva 2008.1 Spring squealing miodragz Installation/Configuration 6 18th May 2008 00:41
Server sometimes (1 or 2 hrs) down :/ edge Server Operation 25 31st July 2006 14:44
Installing and Compiling a driver... MikeX Kernel Questions 1 12th July 2006 13:46
colocation problem d3m0nic Installation/Configuration 14 24th June 2006 00:18


All times are GMT +2. The time now is 15:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.