Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th April 2006, 21:36
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Arrow Automated Backups With rdiff-backup

At this time i try to setup rdiff according "Automated Backups With rdiff-backup" at URL http://www.howtoforge.com/linux_rdiff_backup

After the command:
ssh-copy-id -i ~/.ssh/id_rsa.pub root@server1.example.com

An error occurs:

21
/usr/bin/ssh-copy-id: ERROR: No identities found

And i do not understand why...

Anyone knows what could be wrong?


Hans
Reply With Quote
Sponsored Links
  #2  
Old 11th April 2006, 15:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Did you follow the tutorial to the letter? Maybe you made a typo somewhere.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th April 2006, 16:10
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Post This is exactly what i did...

Both servers are Debian servers.

STEP 1:
On the backup-server (backup.mydomain.tld) I gave the command:

apt-get install rdiff-backup

On the webserver (server1.mydomain.tld) I gave the command:

apt-get install rdiff-backup

STEP 2:
On backup.mydomain.tld I gave all the commands following from now on:

groupadd -g 3500 rdiff-backup
useradd -u 3500 -s /bin/false -d /backup -m -c "rdiff-backup" -g rdiff-backup rdiff-backup

su -m rdiff-backup
cd /backup
ssh-keygen -t rsa

I gave two times an <enter> according the How to.

I created the file /backup/.ssh/config using the command $ nano /backup/.ssh/config with this contents:

host server1_backup
hostname server1.mydomain.tld
user root
identityfile /backup/.ssh/id_rsa
compression yes
cipher blowfish
protocol 2

When I wanted to save this file I got a message in the nano editor, that I have no permission to save the file. I decided to switch to root, by giving the command su and gave the root’s password.

Now the file /backup/.ssh/config was created with the contents mentioned above.

Now I gave the command: chmod -R go-rwx /backup/.ssh

And finally the command:

ssh-copy-id -i ~/.ssh/id_rsa.pub root@server1.mydomain.tld

Then I receive the error on backup.mydomain.tld

21
/usr/bin/ssh-copy-id: ERROR: No identities found

Maybe I did something wrong, but I don’t think that I make a mistake by typing as I use Putty.
Cut and paste is not that difficult.

Can you help me further with this information?


Hans
Reply With Quote
  #4  
Old 11th April 2006, 18:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Exclamation

Quote:
Originally Posted by Hans
When I wanted to save this file I got a message in the nano editor, that I have no permission to save the file. I decided to switch to root, by giving the command su and gave the root’s password.
You must be root during the whole tutorial!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th April 2006, 20:36
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Default

I am a little further now but i did not succeed.

After these next two commands (at the end to test the backup) an error occurs:

cd /backup
rdiff-backup server1_backup::/boot boot

ssh: server1_backup: Name or service not known
Fatal Error: Truncated header string (problem probably originated remotely)

Couldn't start up the remote connection by executing

ssh -C server1_backup rdiff-backup --server

Remember that, under the default settings, rdiff-backup must be
installed in the PATH on the remote system. See the man page for more
information on this. This message may also be displayed if the remote
version of rdiff-backup is quite different from the local version (0.13.4).

I do not understand, i did everything exactly as in the how to...

What could this be? Please let me know.

Do I have this error because my backup-server is Debian 32 bit and my server 64 bit? If yes, i wonder if i can use rdiff-backup between these two servers...
And if yes, how to solve this problem?
Or is it recomended to use another backup system?


Hans

Last edited by Hans; 12th April 2006 at 08:37.
Reply With Quote
  #6  
Old 12th April 2006, 11:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by Hans
cd /backup
rdiff-backup server1_backup::/boot boot

ssh: server1_backup: Name or service not known
Fatal Error: Truncated header string (problem probably originated remotely)
The name server1_backup is not known by your system. Either enter server1_backup and its IP address in /etc/hosts, or use server1_backup's IP address, e.g.

Code:
rdiff-backup 192.168.0.100::/boot boot
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 12th April 2006, 12:54
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Default

On my backup server (backup.mydomain.tld) the file contents of /backup/.ssh/config is:

host server1_backup (This name is specified by me)
hostname server1.mydomain.tld (the name of the server to be back-upped).
user root
identityfile /backup/.ssh/id_rsa
compression yes
cipher blowfish
protocol 2

On my other server server1.mydomain.tld (=to be back-upped), the file contents of file /root/.ssh/authorized_keys is:

command="rdiff-backup --server --restrict-read-only /",from="FULL DNS NAME OF THE BACKUP-SERVER",no-port-forwarding,no-X11-forwarding,no-pty <the key>= rdiff-backup@backup.mydomain.tld


So i do not understand why the names are not recognised.
One more question:
My backup-server is not ping-able from the Internet.
Could that be a reason?

Hans

Last edited by Hans; 12th April 2006 at 15:14.
Reply With Quote
  #8  
Old 12th April 2006, 22:28
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Arrow Still not working

It seems so easy but it is not and it takes me a lot of time.
There is still something wrong, i do not understand!

At Step 4 at URL http://www.howtoforge.com/linux_rdiff_backup_p2

I gave the commands cd /backup
rdiff-backup server1::/boot boot

Then the server asks for a password (3 times)

Then an error occurs:

---
Permission denied (publickey,keyboard-interactive).
Fatal Error: Truncated header string (problem probably originated remotely)

Couldn't start up the remote connection by executing

ssh -C server1 rdiff-backup --server

Remember that, under the default settings, rdiff-backup must be
installed in the PATH on the remote system. See the man page for more
information on this. This message may also be displayed if the remote
version of rdiff-backup is quite different from the local version (0.13.4).

---
For information:

The contents of /backup/.ssh/config on the backup server is:

host server1
hostname server1.mydomain.tld
user root
identityfile /backup/.ssh/id_rsa
compression yes
cipher blowfish
protocol 2
Reply With Quote
  #9  
Old 13th April 2006, 23:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's in /root/.ssh/authorized_keys on server1.example.com?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 14th April 2006, 08:40
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
 
Default

Falko,

for security reasons i give you the information in a private message.


Hans
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Backup routine for ISPConfig-equipped server IntnsRed General 4 5th May 2006 17:29
Backup question Piccent Installation/Configuration 10 13th March 2006 00:12
How of create an automated backup of system+files jeremy Installation/Configuration 13 25th February 2006 13:23
TPS Fedora Core 4 Managing e-mail adr + Backup Hagforce HOWTO-Related Questions 9 22nd February 2006 14:59
ISPConfig Backups SleeperZ Feature Requests 0 9th November 2005 09:36


All times are GMT +2. The time now is 11:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.