Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 10th April 2006, 11:24
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

I, did a new installation and now I get this in the mail.log:

Quote:
<web3_test@mail.server-domain.top> (expanded from <test@virtual-domain.top>): mail
for mail.server-domain.top loops back to myself
and
Quote:
Apr 10 10:09:15 sarge03 postfix/smtp[1744]: warning: host server-domain.top[71.111.111.111] greeted me with my own hostname www.server-domain.top
Apr 10 10:09:15 sarge03 postfix/smtp[1744]: warning: host server-domain.top[71.111.111.111] replied to HELO/EHLO with my own hostname www.server-domain.top
Apr 10 10:09:15 sarge03 postfix/smtp[1744]: 9F4A8BE40: to=<web3_test@mail.server-domain.top>, orig_to=<test@virtual-host.top>, relay=server-domain.top[71.111.111.111], delay=0, status=bounced (mail for mail.server-domain.top loops back to myself)
Apr 10 10:09:15 sarge03 postfix/smtpd[1740]: lost connection after EHLO from unknown[10.0.3.128]
Apr 10 10:09:15 sarge03 postfix/smtpd[1740]: disconnect from unknown[10.0.3.128]
Apr 10 10:09:15 sarge03 postfix/cleanup[1743]: D4E42BF04: message-id=<20060410080915.D4E42BF04@www.server-domain.top>
Apr 10 10:09:15 sarge03 postfix/qmgr[1496]: D4E42BF04: from=<>, size=2714, nrcpt=1 (queue active)
Apr 10 10:09:15 sarge03 postfix/qmgr[1496]: 9F4A8BE40: removed
Apr 10 10:09:16 sarge03 postfix/smtp[1744]: D4E42BF04: to=<info@xx-domain.top>, relay=mailin.webmailer.top[192.67.198.37], delay=1, status=sent (250 2.0.0 k3A89Q9v008244 Message accepted for delivery)
Apr 10 10:09:16 sarge03 postfix/qmgr[1496]: D4E42BF04: removed
and


Quote:
Apr 10 05:14:00 sarge03 postfix/smtpd[4052]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Apr 10 05:14:00 sarge03 postfix/smtpd[4052]: warning: unknown[10.0.3.128]: SASL LOGIN authentication failed

any idea?
Reply With Quote
Sponsored Links
  #12  
Old 10th April 2006, 12:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

To your first error: Add the line:

mail.server-domain.top

at the end of the file /etc/postfix/local-host-names and restart postfix.

To your sasl error:

Did you get an error when you restart the sasl auth daemon?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 10th April 2006, 17:01
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by till
To your first error: Add the line:
mail.server-domain.top
at the end of the file /etc/postfix/local-host-names and restart postfix.
To your sasl error:
Did you get an error when you restart the sasl auth daemon?
No errors when saslauthd is starting

I found an bloddy config mistake:
Quote:
main.cf configuration error: mailbox_size_limit is smaller than message_size_limit
I've set up the mailbox_size_limit more than message_size_limit and now I'm receivng all the lost mail:-)


What I don't now: Were can I edit message_size_limit?

tom
Reply With Quote
  #14  
Old 10th April 2006, 18:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by tom
No errors when saslauthd is starting
What's the output of
Code:
ps aux|grep saslauthd
?
Which distribution do you use?

Quote:
Originally Posted by tom
What I don't now: Were can I edit message_size_limit?

tom
You can set it in /etc/postfix/main.cf. If it isn't set there, Postfix takes the default values that you can see when you run
Code:
postconf -d
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 10th April 2006, 18:58
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by falko
What's the output of
Code:
ps aux|grep saslauthd
?
Quote:
root 6774 0.0 0.4 3824 764 pts/0 S+ 17:43 0:00 grep saslauthd
Which distribution do you use?
Debian3.1

You can set it in /etc/postfix/main.cf. If it isn't set there, Postfix takes the default values that you can see when you run
Code:
postconf -d
I've added message_size_limit = 1024 in /etc/postfix/main.cf restarted postfix and then postconf -d|less but whis no change.
Reply With Quote
  #16  
Old 10th April 2006, 19:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by tom
I've added message_size_limit = 1024 in /etc/postfix/main.cf
This sets the message size limit to 1024 bytes... I guess you mean 10240000 (10MB)?


Quote:
Originally Posted by tom
then postconf -d|less but whis no change.
Code:
postconf -d
always shows the default settings. If you want to see your current settings, run
Code:
postconf -n
Did you do the Postfix/saslauthd configuration as described here? http://www.howtoforge.com/perfect_setup_debian_sarge_p4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 10th April 2006, 19:40
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Quote:
This sets the message size limit to 1024 bytes... I guess you mean 10240000 (10MB)?
No, that should be smal for some tests.


Quote:
Code:
postconf -d
always shows the default settings. If you want to see your current settings, run
Code:
postconf -n
ok

Quote:
Did you do the Postfix/saslauthd configuration as described here? http://www.howtoforge.com/perfect_setup_debian_sarge_p4
Exactly I did

tom
Reply With Quote
  #18  
Old 12th April 2006, 22:02
sultan_muhd sultan_muhd is offline
Junior Member
 
Join Date: Apr 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ohhh no it is realy confusing me i search a lot of stuff on the net but didnt succied postfix is running well port no 25 is ok but cant recieve mail from outside world. i dont know much about DNS(bind) but when i dig mx it looks like this
; <<>> DiG 9.3.1 <<>> mx mydomainname.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41902
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomainname.com. IN MX

;; Query time: 4 msec
;; SERVER: 10.0.0.138#53(10.0.0.138)
;; WHEN: Wed Apr 12 21:02:33 2006
;; MSG SIZE rcvd: 29
Reply With Quote
  #19  
Old 12th April 2006, 22:05
sultan_muhd sultan_muhd is offline
Junior Member
 
Join Date: Apr 2006
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default nop not yet

ohhh no it is realy confusing me i search a lot of stuff on the net but didnt succied postfix is running well port no 25 is ok but cant recieve mail from outside world. i dont know much about DNS(bind) but when i dig mx it looks like this
; <<>> DiG 9.3.1 <<>> mx mydomainname.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 41902
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mydomainname.com. IN MX

;; Query time: 4 msec
;; SERVER: 10.0.0.138#53(10.0.0.138)
;; WHEN: Wed Apr 12 21:02:33 2006
;; MSG SIZE rcvd: 29
Reply With Quote
  #20  
Old 12th April 2006, 23:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

PLease ask your ISP if they block port 25. Many ISP do that!
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot receive emails skeeta Installation/Configuration 18 22nd April 2006 17:02
Send mail but don't receive domenico Installation/Configuration 9 27th January 2006 12:16
Unable to receive emails?!!! nandhu HOWTO-Related Questions 7 24th October 2005 00:49
Can't SEND eMails. DanceNgine Installation/Configuration 21 6th October 2005 19:12
Cannot receive emails skeeta Installation/Configuration 10 3rd September 2005 10:14


All times are GMT +2. The time now is 09:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.