#1  
Old 2nd June 2009, 23:27
z33k3r z33k3r is offline
Member
 
Join Date: Jan 2007
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Rouge MX Record - [SOLVED]

Quick help topic:

I had a domain full functional and working, but then I realized that the mail server was set to Localhost when it was in actuality a remote server. So I changed it over to remote and saved. Now if I dig from the command line, I still get the localserver as the MX record. I need to clear it so that it looks to the outside world for direction...

How would one go about doing this?

Last edited by z33k3r; 5th June 2009 at 18:44. Reason: Change title to represent solved status.
Reply With Quote
Sponsored Links
  #2  
Old 3rd June 2009, 09:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

MX records have nothing to do with the remote server setting. To change the mx server you have to change the dns settings for the domain
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 3rd June 2009, 09:12
z33k3r z33k3r is offline
Member
 
Join Date: Jan 2007
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default Ok, so...

Ok, I see you and raise you a, "Where/what do I change to maket his work?"
Reply With Quote
  #4  
Old 3rd June 2009, 16:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

You have to modify the DNS records on the authoritative nameservers for your domain. You can out these nameservers by running
Code:
dig ns yourdomain.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd June 2009, 18:45
z33k3r z33k3r is offline
Member
 
Join Date: Jan 2007
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So I have checked my sources and from the server, it states that the name servers are in the right place (off site). Using MXtoolbox.com, tested and verified that the MX pointed to a mail.domain.tld and then that resolved IP had a correct reverse DNS entry.

But... when I "dig type mx domain.tld" i get the sever's IP address... Thus my rouge record...
Reply With Quote
  #6  
Old 4th June 2009, 08:16
z33k3r z33k3r is offline
Member
 
Join Date: Jan 2007
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anybody have pointers here? I am not a DNS guy by any means...
Reply With Quote
  #7  
Old 4th June 2009, 08:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please post the exact dig command you used and the completeoutput that you got.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 4th June 2009, 19:00
z33k3r z33k3r is offline
Member
 
Join Date: Jan 2007
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry to change directions here, but I check DNS and it has updated fully. Now I started looking in the mail logs and I am getting the following in my Postfix logs (edited for privacy):

Code:
Jun  4 09:08:56 ts1 postfix/pickup[12452]: 26662C3409F: uid=33 from=<www-data>
Jun  4 09:08:56 ts1 postfix/cleanup[13168]: 26662C3409F: message-id=<20090604160856.26662C3409F@server.domain.tld>
Jun  4 09:08:56 ts1 postfix/qmgr[654]: 26662C3409F: from=<www-data@server.domain.tld>, size=1694, nrcpt=1 (queue active)
Jun  4 09:08:56 ts1 postfix/local[13261]: 26662C3409F: to=<user@targetdomain.tld>, relay=local, delay=0.06, delays=0.05/0/0/0.01, dsn=5.1.1, status=bounced (unknown user: "user")
Jun  4 09:08:56 ts1 postfix/cleanup[13168]: 36348C340BC: message-id=<20090604160856.36348C340BC@server.domain.tld>
Jun  4 09:08:56 ts1 postfix/bounce[13289]: 26662C3409F: sender non-delivery notification: 36348C340BC
As you can see, it's trying to deliver locally instead of on the appropriate remote server...
Reply With Quote
  #9  
Old 4th June 2009, 19:22
z33k3r z33k3r is offline
Member
 
Join Date: Jan 2007
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do I need to add a slave record or something in the DNS manager (I don't host the dns, though i have the req. DNS software installed for ISPC)?
Reply With Quote
  #10  
Old 5th June 2009, 13:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Is targetdomain.tld listed in /etc/postfix/local-host-names?
What's in /etc/resolv.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
post fix error after a year aberrio Server Operation 5 5th May 2009 21:33
Setting up MX record for static host for mail server yngwie Server Operation 1 5th March 2009 19:03
Prevent unwanted DNS A record SupuS Feature Requests 3 20th August 2008 00:21
Webalizer/Angolizer Geo IP Error Mesasge jamesuk HOWTO-Related Questions 3 19th November 2007 13:57
Postfix delivery problem erebus Installation/Configuration 6 28th October 2007 16:20


All times are GMT +2. The time now is 02:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.