Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd June 2009, 05:24
kkng kkng is offline
Junior Member
 
Join Date: Jun 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Web Server offline with a different port

I recently set up LAMP + ISPConfig. Everything seems to be working fine, except Web Server showing offline in ISPC3. Im using a different port instead of the standard port. If I add Listen 127.0.0.1 in httpd.conf it give me an error "Address already in use"? Can you shed some light on me please.

firewall is off.

Thank you.

Last edited by kkng; 2nd June 2009 at 06:42.
Reply With Quote
Sponsored Links
  #2  
Old 2nd June 2009, 08:30
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 262 Times in 208 Posts
Default

Quote:
Originally Posted by kkng View Post
I recently set up LAMP + ISPConfig. Everything seems to be working fine, except Web Server showing offline in ISPC3. Im using a different port instead of the standard port. If I add Listen 127.0.0.1 in httpd.conf it give me an error "Address already in use"? Can you shed some light on me please.

firewall is off.

Thank you.
If you use a different port than 80 ispconfig will not recognize apache is running. ispconfig checks for a listening port 80 to show if apache is running.
Reply With Quote
  #3  
Old 3rd June 2009, 07:56
kkng kkng is offline
Junior Member
 
Join Date: Jun 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Smile Solved

I think I found the answer, here is what I changed: (Centos5.3, ISPConfig3.0.1)

in /usr/local/ispconfig/server/conf/vhost.conf.master
change <VirtualHost <tmpl_var name='ip_address'>: your_port>

in /usr/local/ispconfig/server/conf/apache_ispconfig.conf.master
change NameVirtualHost {tmpl_var name="ip_address"}:your_port

restart httpd, it is now showing Web server online in ISPC3
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail Question: installed smf forum on centos perfect server setup with ispconfig happz Installation/Configuration 7 22nd August 2008 13:15
Rejecting outbound mail tristanlee85 General 11 20th May 2007 17:04
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 22:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.