#1  
Old 18th April 2009, 00:46
samuch samuch is offline
Member
 
Join Date: Apr 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Default Migrate Sites From 2 to 3

So I know you can't upgrade a server from ISPConfig 2 to 3. However, is there any possible way to move sites from a server running 2, to a server running 3?

We've recently upgraded our servers and installed 3 on a new one. We want to kill the old server but need some way to migrate those sites and accounts.

Forgive me if this has been pointed out somewhere already but I couldn't find it.
Sponsored Links
  #2  
Old 18th April 2009, 17:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

You can simply copy over the files to the new server. You might have to modify configuration files (e.g. paths, database details, etc.) though.

You can create SQL dumps of your databases and then import them into empty databases on the new server: http://www.howtoforge.com/faq/6_3_en.html
http://www.howtoforge.com/faq/6_4_en.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #3  
Old 18th April 2009, 17:25
samuch samuch is offline
Member
 
Join Date: Apr 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey Falko,

Thanks for the response. Can you clarify a bit more for me? I can understand moving the site content and exporting and importing the mysql databases, but what about user email accounts?

Were you meaning to create the site on the new version 3 server and then move the site content? That makes sense. I guess I'm just hungup on moving all the email accounts.

Thanks!
  #4  
Old 18th April 2009, 19:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

As explained in many posts, you can not migrate a ispconfig 2 server to ispconfig 3. This means if you want to use a ispconfig 3 server for your sites, you will have to create all sites and user accounts in ispconfig 3 manually. Mail accounts can not be moved directly, you can just try to copy the maildir files of every account and fiolder manually to the new locations on the new server and dont forget to chnage all owb´nerships to the vmail user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #5  
Old 19th April 2009, 04:08
DantePasquale DantePasquale is offline
Senior Member
 
Join Date: Feb 2007
Location: Lakewood, OH US
Posts: 108
Thanks: 10
Thanked 3 Times in 3 Posts
Send a message via AIM to DantePasquale
Default

Hi Till, I'm going to tackle this tomorrow, but was wondering if you could clarify the maildir setup for ISPConfig 3. Is it the same as ISPConfig 2? Not sure what you mean by "vmail" user for ownership under ISPConfig 3?

Thanks, Danté
  #6  
Old 19th April 2009, 17:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

http://www.howtoforge.com/forums/sho...light=imapsync
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #7  
Old 1st June 2009, 00:45
DantePasquale DantePasquale is offline
Senior Member
 
Join Date: Feb 2007
Location: Lakewood, OH US
Posts: 108
Thanks: 10
Thanked 3 Times in 3 Posts
Send a message via AIM to DantePasquale
Default

Hi Guys,

I setup a laptop according to the howto, Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.10). My idea was to use imapsync to copy the imap datat from my server to the laptop and then install Ubuntu 9 and ISPConfig 3, then copy the imap data from the laptop to the server.

I downloaded and built imapsync per the instructions with imapsync. This is strange, but it would connect to the server without any problems, but wouldn't connect to the laptop.

I'm pretty sure that the problem lies in the way the email address for the howto uses a full email address, eg someuser@somedomain.com. I think imapsync doesn't deal with the @ sign. If I put the email in double quotes, it didn't matter. I tried to escape the @ with a \ backslash, but then the backslash got passed into the imap server and no match was found.

I tried setting up the laptop with email address of 'someuser' without the @somedomain.com, but that wouldn't work.

To complicate things, I can connect to the laptops mail service with Thunderbird (using SSL) with someuser@somedomain.com as the connect string!

I guess the question is, since imapsync is perl, how can I pass in the @somedomain.com so that it gets passed to the imap server correctly??

Thanks, Danté
  #8  
Old 1st June 2009, 11:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
 
Default

You posted to the wrong thread, this thread is about ispconfig and you dont use ispconfig. I moved your post here:

http://www.howtoforge.com/forums/showthread.php?t=35751
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Sites & DNS Setup Jayson Wonder Installation/Configuration 27 11th December 2008 19:08
Help - virtual sites - email not working - what FQDN? sagor Installation/Configuration 4 26th April 2008 20:00
all sites are getting "Index of /" page instead of the domain directory jagnag1 Installation/Configuration 3 17th December 2006 13:18
error sites disabled but still indevidual error sites tom Installation/Configuration 3 13th May 2006 13:37
Sites Viewed From Server Go To Shared IP mojosound General 4 3rd April 2006 21:13


All times are GMT +2. The time now is 06:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.