Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th August 2005, 10:07
andlo andlo is offline
Junior Member
 
Join Date: Aug 2005
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Question email: loops back to myself

I am testing ISPConfig on Mandrake 10.2, and followed the perfekt (and it is perfect) guide.

Only differende is that the server also is acting as a firewall and router for my LAN.

But I cant get emails working.

Persons sending to a emailadres on my ISPConfig is getting this message back from postfix:

<web2_otherdomain.dk@domain.dk> (expanded from <andlo@otherdomain.dk>): mail for domain.dk loops back to myself


I'll dont understand what is wrong...

/A
Reply With Quote
Sponsored Links
  #2  
Old 11th August 2005, 10:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by andlo
I am testing ISPConfig on Mandrake 10.2, and followed the perfekt (and it is perfect) guide.

Only differende is that the server also is acting as a firewall and router for my LAN.

But I cant get emails working.

Persons sending to a emailadres on my ISPConfig is getting this message back from postfix:

<web2_otherdomain.dk@domain.dk> (expanded from <andlo@otherdomain.dk>): mail for domain.dk loops back to myself


I'll dont understand what is wrong...

/A
Put domain.dk at the end of /etc/postfix/local-host-names (after #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####) and restart Postfix:
Code:
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th August 2005, 10:49
andlo andlo is offline
Junior Member
 
Join Date: Aug 2005
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Put domain.dk at the end of /etc/postfix/local-host-names (after #### MAKE MANUAL ENTRIES BELOW THIS LINE! ####) and restart Postfix:
Code:
/etc/init.d/postfix restart
Better, but still no email komming throu

from /var/log/mail/info:

Aug 11 10:43:12 batman postfix/pickup[3722]: 745143369B: uid=10007 from=<web2_andlo>
Aug 11 10:43:12 batman postfix/cleanup[4128]: 745143369B: message-id=<20050811084312.745143369B@opensoft.dk>
Aug 11 10:43:12 batman postfix/local[4131]: F062333683: to=<web2_andlo@opensoft.dk>, orig_to=<andlo@sodemark.dk>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail -f-)
Aug 11 10:43:12 batman postfix/qmgr[3723]: F062333683: removed
Aug 11 10:43:12 batman postfix/qmgr[3723]: 745143369B: from=<web2_andlo@opensoft.dk>, size=359, nrcpt=1 (queue active)
Aug 11 10:43:12 batman postfix/local[4131]: 745143369B: to=<admispconfig@localhost.opensoft.dk>, orig_to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)

Reply With Quote
  #4  
Old 11th August 2005, 10:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

Quote:
Originally Posted by andlo
Better, but still no email komming throu

from /var/log/mail/info:

Aug 11 10:43:12 batman postfix/pickup[3722]: 745143369B: uid=10007 from=<web2_andlo>
Aug 11 10:43:12 batman postfix/cleanup[4128]: 745143369B: message-id=<20050811084312.745143369B@opensoft.dk>
Aug 11 10:43:12 batman postfix/local[4131]: F062333683: to=<web2_andlo@opensoft.dk>, orig_to=<andlo@sodemark.dk>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail -f-)
Aug 11 10:43:12 batman postfix/qmgr[3723]: F062333683: removed
Aug 11 10:43:12 batman postfix/qmgr[3723]: 745143369B: from=<web2_andlo@opensoft.dk>, size=359, nrcpt=1 (queue active)
Aug 11 10:43:12 batman postfix/local[4131]: 745143369B: to=<admispconfig@localhost.opensoft.dk>, orig_to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)


Have you selected the correct value for your server (Maildir or mailbox) in the
ISPConfig controlpanel settings?
Reply With Quote
  #5  
Old 11th August 2005, 11:04
andlo andlo is offline
Junior Member
 
Join Date: Aug 2005
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Have you selected the correct value for your server (Maildir or mailbox) in the
ISPConfig controlpanel settings?
Yes and no....

What is the correct value ?

/A
Reply With Quote
  #6  
Old 11th August 2005, 11:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

Quote:
Originally Posted by andlo
Yes and no....

What is the correct value ?

/A
That depends on your server configuration. But as you dont receive any mail yet, yust change the value and try if you receive mail In most cases Maildir should work.
Reply With Quote
  #7  
Old 11th August 2005, 11:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Which POP3 daemon are you using?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 11th August 2005, 11:15
andlo andlo is offline
Junior Member
 
Join Date: Aug 2005
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Which POP3 daemon are you using?
ipop3

The mail is delivered to the users Maildir. But webmail'en cant see it.
Reply With Quote
  #9  
Old 11th August 2005, 11:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

ipop3 is using mbox so you have to turn off Maildir in your ISPConfig web interface (Management -> Server -> Settings -> Email).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 11th August 2005, 12:13
andlo andlo is offline
Junior Member
 
Join Date: Aug 2005
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko
ipop3 is using mbox so you have to turn off Maildir in your ISPConfig web interface (Management -> Server -> Settings -> Email).
And now It works.

Thanks - and thanks for a pretty good system.

/A
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hiding email addresses myles Programming/Scripts 5 1st December 2008 12:09
email client configuration davidg General 3 22nd August 2005 16:40
Monitor Email Traffic mike Server Operation 1 9th May 2005 16:15
Cannot send email - Sendmail/FC3 ingo Server Operation 2 24th April 2005 19:24


All times are GMT +2. The time now is 14:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.