Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #71  
Old 5th December 2012, 08:42
dicenl dicenl is offline
Junior Member
 
Join Date: Dec 2012
Location: Netherlands
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Argh! i was so hopefull this morning. checked the www.url.nl/stats but still no go. there is a pull down menu with "Jump to previous stats: 2012-12" In the websites stats folders there are only 2 files. The .htaccess, default install file and a index.php but thats it.

So again i run
Code:
/usr/bin/php -q /usr/local/ispconfig/server/cron_daily.php
and there still is a rename issue
Code:
UPDATE mail_traffic SET traffic = 5098189 WHERE traffic_id = 1PHP Warning:  rename(/var/www/clients/client1/web1/web/stats/awstats.www.xxx.nl.html,/var/www/clients/client1/web1/web/stats/awsindex.html): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 240
PHP Warning:  rename(/var/www/clients/client1/web4/web/stats/awstats.gallery3.xxx.nl.html,/var/www/clients/client1/web4/web/stats/awsindex.html): No such file or directory in /usr/local/ispconfig/server/cron_daily.php on line 240
any suggestions?

By the way, this happens in 2 setups. I got one at home, my own private VM workstation home servers (with isp server os Centos 6.3 x86_64) and also at work on ESX 5i (also isp server os Centos 6.3 x86_64)
Reply With Quote
Sponsored Links
  #72  
Old 5th December 2012, 09:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

The rename error occurs because awstats has not created any statistics files, so the rename is not the issue here. Is the path to the awsats buildstaticpages script in ispconfig under system > server config correct?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #73  
Old 5th December 2012, 11:26
dicenl dicenl is offline
Junior Member
 
Join Date: Dec 2012
Location: Netherlands
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yeah, look like its okay.

output of all the awstats settings in the server config section:

Code:
]# ll /etc/awstats/
total 208
-rw-r--r-- 1 root root   199 Dec  5 08:50 awstats.digipeet.xxx.nl.conf
-rw-r--r-- 1 root root   190 Dec  5 08:50 awstats.forum.xxx.nl.conf
-rw-r--r-- 1 root root   199 Dec  5 08:50 awstats.gallery3.xxx.nl.conf
-rw-r--r-- 1 root root 61678 Nov 30 21:36 awstats.ispconfig1.xxx.nl.conf
-rw-r--r-- 1 root root 61665 Oct  7  2011 awstats.localhost.localdomain.conf
-rw-r--r-- 1 root root 61665 Oct  7  2011 awstats.model.conf
-rw-r--r-- 1 root root   184 Dec  5 08:50 awstats.www.xxx.nl.conf
Code:
# ll /var/lib/awstats/
total 92
-rw-r--r-- 1 root root  7122 Dec  2 13:01 awstats112012.ispconfig1.i-xxxl.txt
-rw-r--r-- 1 root root  7714 Dec  2 13:01 awstats112012.localhost.localdomain.txt
-rw-r--r-- 1 root root 36655 Dec  5 11:01 awstats122012.ispconfig1.xxx.txt
-rw-r--r-- 1 root root 37402 Dec  5 11:01 awstats122012.localhost.localdomain.txt
Code:
]# ll /usr/share/awstats/wwwroot/cgi-bin/awstats.pl
-rwxr-xr-x 1 root root 657790 Oct 16  2010 /usr/share/awstats/wwwroot/cgi-bin/awstats.pl
Code:
 ll /usr/share/awstats/tools/awstats_buildstaticpages.pl
-rwxr-xr-x 1 root root 19594 Oct  7  2011 /usr/share/awstats/tools/awstats_buildstaticpages.pl
Reply With Quote
  #74  
Old 5th December 2012, 14:13
dicenl dicenl is offline
Junior Member
 
Join Date: Dec 2012
Location: Netherlands
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

okay, found it. the answer was in an other forum

http://www.howtoforge.com/forums/sho...t=55417&page=2

cp /etc/awstats/awstats.model.conf /etc/awstats/awstats.conf
Reply With Quote
Reply

Bookmarks

Tags
403, forbidden, webalizer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
IMAP doesn't work..as i followed the Perfect Setup for Fedora 4 asokaajay Server Operation 11 10th June 2007 14:57
403 Forbidden (Permission to /) rannia_ptaha Installation/Configuration 9 25th January 2007 18:36
403 Error- Forbidden! on form submit Macord General 4 11th December 2006 22:22
problem with Webalizer (403 Error- Forbidden!) kong121s Installation/Configuration 9 28th April 2006 10:33


All times are GMT +2. The time now is 06:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.