Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #51  
Old 31st August 2009, 07:41
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 426
Thanks: 33
Thanked 55 Times in 38 Posts
Send a message via Skype™ to SamTzu
Default

Plaahhh...

It's obvious in hindsight.
/etc/webalizer/webalizer.conf

Change the values for incremental and hostname if you suffer from this problem.


Quote:
Incremental yes

# IncrementalName allows you to specify the filename for saving the
# incremental data in. It is similar to the HistoryName option where the
# name is relative to the specified output directory, unless an absolute
# filename is specified. The default is a file named "webalizer.current"
# kept in the normal output directory. If you don't specify "Incremental"
# as 'yes' then this option has no meaning.

#IncrementalName webalizer.current

# ReportTitle is the text to display as the title. The hostname
# (unless blank) is appended to the end of this string (seperated with
# a space) to generate the final full title string.
# Default is (for english) "Usage Statistics for".

ReportTitle Usage statistics for

# HostName defines the hostname for the report. This is used in
# the title, and is prepended to the URL table items. This allows
# clicking on URL's in the report to go to the proper location in
# the event you are running the report on a 'virtual' web server,
# or for a server different than the one the report resides on.
# If not specified here, or on the command line, webalizer will
# try to get the hostname via a uname system call. If that fails,
# it will default to "localhost".

HostName server47
If you have problems with stats make sure that...

1) You have created a password for the site on ISPConfig3
(User is admin) If this dont work then you get 500 error.
(Check the .htpasswd_stats file.)

server43: ls -ahl /var/www/shop.internet-content.net/ total 28K
drwxr-xr-x 6 root root 4.0K 2009-09-08 13:13 .
drwxr-xr-x 12 root root 4.0K 2009-09-04 13:20 ..
drwxr-xr-x 2 web22 client1 4.0K 2009-09-01 13:54 cgi-bin
-rw-rw-r-- 1 root root 40 2009-09-08 13:13 .htpasswd_stats
lrwxrwxrwx 1 web22 client1 50 2009-09-01 13:54 log -> /var/log/ispconfig/http /shop.internet-content.net
drwxr-xr-x 2 web22 client1 4.0K 2009-09-01 13:54 ssl
drwxrwxrwx 3 web22 client1 4.0K 2009-09-02 16:13 tmp
drwxr-xr-x 19 web22 client1 4.0K 2009-09-02 16:17 web


2) If you only can see 1 days worth of data make sure to edit /etc/webalizer/webalizer.conf
Incremental yes

3) If you have moved your site from ISPConfig2 server make sure that the web/stats/ folder does not contain any old .ht**** files.

4) If you have custom .htaccess file on your /web/ root try to rename it and see if the stats start to work.
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent


Last edited by SamTzu; 8th September 2009 at 12:28.
Reply With Quote
The Following User Says Thank You to SamTzu For This Useful Post:
rodvazco (2nd March 2012)
Sponsored Links
  #52  
Old 30th November 2009, 01:50
Norm Norm is offline
Junior Member
 
Join Date: Nov 2009
Posts: 2
Thanks: 0
Thanked 1 Time in 1 Post
Default I have my webalizer stats now.

Hello,

I installed ISPConfig a few days ago onto Ubuntu 9.10 64 bit and getting on fine with it after a few operator errors.

I've had the same problem with getting webalizer stats being produced just as previous writers mentioned.

I did notice in the ISPConfig cron.log that GEOip.dat could not be found at /usr/share/geoip so the ISPConfig cron.daily did not run properly. Seems this was not installed so I installed it with apt-get install geoip-database.

I ran the cron.daily script and my webalizer files are in the /stats folder now and I can access them as I should.

Sorry this is a few months late but I read through the forums and didn't see this mentioned as a possible solution.

Norm
Reply With Quote
  #53  
Old 5th November 2012, 09:04
abdi abdi is offline
Senior Member
 
Join Date: Sep 2012
Posts: 118
Thanks: 0
Thanked 10 Times in 6 Posts
Default

My problem is even more weired ..

my /stats folder has ALL the files however I get 403 error when accessing them through the browser.

And funny thing is if I rename any of those files to .php then I can see its contents fine, seeming to me that .html is not working on my /stats/ folder ...

in the logs i have:

tail -f /var/www/clients/client1/web1/log/error.log

2012/11/05 08:32:54 [error] 2333#0: *3820 open() "/var/www/clients/client1/web1/.htpasswd_stats" failed (2: No such file or directory), client: 41.190.204.67, server: domain.net, request: "GET /stats/ HTTP/1.1", host: "www.domain.net"

2012/11/05 08:32:58 [error] 2333#0: *3832 open() "/var/www/clients/client1/web1/.htpasswd_stats" failed (2: No such file or directory), client: 41.190.204.67, server: jolis.net, request: "GET /stats/undefined HTTP/1.1", host: "www.domain.com", referrer:

Last edited by abdi; 5th November 2012 at 09:34.
Reply With Quote
  #54  
Old 5th November 2012, 09:39
abdi abdi is offline
Senior Member
 
Join Date: Sep 2012
Posts: 118
Thanks: 0
Thanked 10 Times in 6 Posts
Default

OK, indeed that missing file is the root cause of all problems since when I disable it in /etc/nginx/sites-enabled

" auth_basic_user_file /var/www/clients/client1/web1/.htpasswd_stats;" everything works fine.

However if I try to manually create it with:

# touch /var/www/clients/client1/web1/.htpasswd_stats
touch: cannot touch `/var/www/clients/client1/web1/.htpasswd_stats': Permission denied

I get the above, implying my server is unable to create it and that explains why ALL sites can't show /stats/

Till any advice on why my system can't create that file in that path? Thanks
Reply With Quote
  #55  
Old 6th November 2012, 12:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
ls -la /var/www/clients/client1/web1/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #56  
Old 6th November 2012, 19:27
abdi abdi is offline
Senior Member
 
Join Date: Sep 2012
Posts: 118
Thanks: 0
Thanked 10 Times in 6 Posts
Default

root@puck384 dbadmin # ls -la /var/www/clients/client1/web1/
total 2816
drwxr-xr-x 17 root root 4096 Oct 27 00:32 .
drwxr-xr-x 18 root root 4096 Oct 31 09:20 ..
drwxr-xr-x 2 web1 client1 4096 Oct 27 00:32 backup
-rwxr-xr-x 1 web1 client1 0 Oct 26 16:26 .bash_history
drwxr-xr-x 2 root root 4096 Oct 26 16:26 bin
drwxr-xr-x 2 web1 client1 4096 Oct 26 16:24 cgi-bin
drwxr-xr-x 2 root root 4096 Nov 6 08:05 dev
drwxr-xr-x 6 root root 4096 Oct 26 16:26 etc
drwxr-xr-x 4 root root 4096 Oct 26 16:26 home
drwxr-xr-x 3 root root 4096 Oct 26 16:26 lib
lrwxrwxrwx 1 root root 4 Oct 26 16:26 lib64 -> /lib
drwxr-xr-x 2 root root 4096 Nov 6 00:30 log
drwx--x--- 2 web1 client1 4096 Oct 26 16:24 private
drwx------ 2 web1 client1 4096 Oct 26 16:26 .ssh
drwxr-xr-x 2 root root 4096 Oct 26 18:18 ssl
drwxrwxrwx 2 web1 client1 2805760 Nov 6 18:25 tmp
drwxr-xr-x 6 root root 4096 Oct 26 16:26 usr
drwxr-xr-x 3 root root 4096 Oct 26 16:26 var
drwx--x--- 43 web1 client1 12288 Nov 6 10:05 web
root@puck384 dbadmin #
Reply With Quote
  #57  
Old 6th November 2012, 19:38
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,187
Thanks: 829
Thanked 5,417 Times in 4,259 Posts
Default

Quote:
Till any advice on why my system can't create that file in that path? Thanks
The directory is protected to ensure that no user can create files there.

I guess you use the ispconfig beta and not a release version as the beta has a known bug in the stats password protection function which has already been fixed in svn.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #58  
Old 17th November 2012, 10:00
abdi abdi is offline
Senior Member
 
Join Date: Sep 2012
Posts: 118
Thanks: 0
Thanked 10 Times in 6 Posts
Default

Till, do kindly share with me the Beta SVN URL and or installation instructions ...Thanks

Till should I use this: svn://svn.ispconfig.org/ispconfig3/trunk/ ?

Edit: I used the above SVN and indeed the /stats/ issue is now resolved. Thanks ...

Last edited by abdi; 17th November 2012 at 12:04.
Reply With Quote
  #59  
Old 18th November 2012, 16:26
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,187
Thanks: 829
Thanked 5,417 Times in 4,259 Posts
Default

Quote:
Till should I use this: svn://svn.ispconfig.org/ispconfig3/trunk/ ?
The stable branch which contains the fixes for ispconfig 3.0.5 is:

svn://svn.ispconfig.org/ispconfig3/branches/ispconfig-3.0.5
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #60  
Old 2nd December 2012, 10:59
dicenl dicenl is offline
Junior Member
 
Join Date: Dec 2012
Location: Netherlands
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Just started with ispconfig 3.0.4.6 and loving it! i also dont have any stats. just joining the conversation and giving my config info:

Centos 6.3 x86_64
httpd apache
Followed the perfect server install (ispconfig 3 + courier ...)

Checks performed in previous posts:

# getenforce
Disabled
# which webalizer
/usr/bin/webalizer

ls -la /etc | grep webalizer
drwxr-xr-x 2 root root 4096 Dec 2 10:25 webalizer
-rw-r--r-- 1 root root 23734 Dec 2 10:25 webalizer.conf

ls -al /etc/webalizer
total 16
drwxr-xr-x 2 root root 4096 Dec 2 10:25 .
drwxr-xr-x. 124 root root 12288 Dec 2 10:25 ..
lrwxrwxrwx 1 root root 19 Nov 30 23:14 webalizer.conf -> /etc/webalizer.conf


ls -la /var/www/clients/client1/web8/
total 28
drwxr-x--x 6 web8 client1 4096 Dec 2 10:36 .
drwxr-xr-x 6 root root 4096 Dec 1 11:26 ..
drwxr-x--x 2 web8 client1 4096 Dec 1 10:16 cgi-bin
-rwxr-xr-x 1 root root 40 Dec 1 16:36 .htpasswd_stats
lrwxrwxrwx 1 root root 38 Dec 1 10:16 log -> /var/log/ispconfig/httpd/www.xxxx.nl
drwxr-x--x 2 web8 client1 4096 Dec 1 10:16 ssl
drwxrwxrwx 2 web8 client1 4096 Dec 1 20:06 tmp
drwx--x--- 7 web8 client1 4096 Dec 1 16:46 web

In sites / statistics have set admin password

Is there a way to force the creation of stats or do i realy have to wait 24 hours for it to happen automaticly?
Reply With Quote
Reply

Bookmarks

Tags
403, forbidden, webalizer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
IMAP doesn't work..as i followed the Perfect Setup for Fedora 4 asokaajay Server Operation 11 10th June 2007 14:57
403 Forbidden (Permission to /) rannia_ptaha Installation/Configuration 9 25th January 2007 18:36
403 Error- Forbidden! on form submit Macord General 4 11th December 2006 22:22
problem with Webalizer (403 Error- Forbidden!) kong121s Installation/Configuration 9 28th April 2006 10:33


All times are GMT +2. The time now is 14:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.