#1  
Old 25th May 2009, 16:58
kaushalshriyan kaushalshriyan is offline
Junior Member
 
Join Date: Apr 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default cluster setup

Hi,

My setup are as below :-

mthost04 -172.26.1.112 (primary node)
mthost03 - 172.26.1.133 (standby node)
mthost05 - 172.26.1.109(apache server)
mthost02 - 172.26.1.174(apache server)

I have heartbeat 2.99 and ldirectord running on mthost04 and mthost03. when i stop apache on either of mthost05/02 it works as expected. when i stop primary node (mthost04) the failover does not happen. means to say that mthost03 does not take over. I am using /var/lib/heartbeat/crm/cib.xml file for resources

Please let me know if anyone needs my logs or my configurations.

Thanks and Regards

Kaushal
Reply With Quote
Sponsored Links
  #2  
Old 26th May 2009, 08:55
kaushalshriyan kaushalshriyan is offline
Junior Member
 
Join Date: Apr 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Again,

Checking in again for my query. :-)

Thanks,

Kaushal
Reply With Quote
  #3  
Old 26th May 2009, 22:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Did you use a HowtoForge tutorial to set this up?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 28th May 2009, 13:36
kaushalshriyan kaushalshriyan is offline
Junior Member
 
Join Date: Apr 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi,

I have followed http://www.howtoforge.org/high_avail...apache_cluster

My setup are as below :-

mthost02 - 172.26.1.127(primary node)
mthost05 - 172.26.1.109(standby node)
mthost04 -172.26.1.124 (apache node)
mthost03 - 172.26.1.169 (apache node)
VirtualIP - 172.26.1.10

I have heartbeat and ldirectord running on mthost02 and mthost05. when i stop apache on either of mthost05/02 it works as expected. when i stop primary node (mthost02) the failover does not happen. means to say that mthost05 does not take over.

ha.cf
################################################## #########
logfacility local0
bcast eth0 # Linux
mcast eth0 225.0.0.1 694 1 0
auto_failback on
node mthost02
node mthost05
respawn hacluster /usr/lib/heartbeat/ipfail
apiauth ipfail gid=haclient uid=hacluster
################################################## #########

haresources
################################################## ################################################## #######
mthost02 ldirectord::ldirectord.cf LVSSyncDaemonSwap::master IPaddr2::172.26.1.10/24/eth0:1/172.26.255.255
################################################## ################################################## #######

ldirectord.cf
################################################## #########
checktimeout=10
checkinterval=2
autoreload=no
logfile="local0"
quiescent=no

virtual=172.26.1.10:80
real=172.26.1.124:80 gate
real=172.26.1.169:80 gate
fallback=127.0.0.1:80 gate
service=http
request="ldirector.html"
receive="Test Page"
scheduler=lc
protocol=tcp
################################################## #########

when i stop heartbeat on mthost02 - 172.26.1.127(primary node), the machine freezes.there is no ERROR in daemon.log

Please let me know if you need more information.

Thanks and Regards

Kaushal
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig setup - DNS, router and general access problems ingvar Installation/Configuration 6 31st July 2010 13:13
MySQL Cluster - Tables not synced tfunky Server Operation 4 6th April 2007 22:22
MySQL Cluster On FC5 : error while unpacking from engine asyadiqin HOWTO-Related Questions 7 28th October 2006 17:37
Load-Balanced MySQL Cluster Error with Cluster stylez HOWTO-Related Questions 12 1st October 2006 04:55
Debian perfect setup network problem reddogg Installation/Configuration 2 18th January 2006 22:04


All times are GMT +2. The time now is 23:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.