#1  
Old 13th May 2009, 14:47
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default Pure-ftp problem

Hi, cant log in to FTP true Router, but its no problem when login true LAN.

Syslog:
May 13 14:30:15 s08 pure-ftpd: (?@?) [ERROR] Sorry, invalid address given

i got port 20 & 21 open to the server.

rgds
//M
Reply With Quote
Sponsored Links
  #2  
Old 13th May 2009, 16:00
tio289 tio289 is offline
Member
 
Join Date: Mar 2009
Posts: 70
Thanks: 2
Thanked 14 Times in 9 Posts
Default

Hi, ftp uses more ports that two(20,21). It uses random ports for passive connections. You must open/forward more ports..range of ports and configure these ports on pureftpd server. Or you can turn on on your router DMZ function --> All queries will be forwarded to IP in DMZ setting. For example:



that is if your server is on LAN side. (IF you have public IP that you can optionaly use active mode). IF your server is on WAN side you must have turned on passive mode in your ftp client

BTW, this post more fall to general that ispconfig....moderator, would you move this post?

Last edited by tio289; 13th May 2009 at 16:37.
Reply With Quote
  #3  
Old 14th May 2009, 19:36
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default

Hi,
Thanks for replay.

whare do i put -p 5000-6000 som it always start whit that options som passive mode works, maybe in /etc/init.d/pure-ftp some whare ?
im using Debian5 Lenny.

//M
Reply With Quote
  #4  
Old 14th May 2009, 19:38
tio289 tio289 is offline
Member
 
Join Date: Mar 2009
Posts: 70
Thanks: 2
Thanked 14 Times in 9 Posts
Default

better solution is turn on DMZ
Reply With Quote
  #5  
Old 14th May 2009, 21:16
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default

im testing ISPC3 on a temp site behind a router, so i cant move it to DMZ.

need help to start pure-ftp whit -p 5000-6000 =)

thanks
//M

--------------
Anyone ?

Last edited by trexen; 15th May 2009 at 11:22.
Reply With Quote
  #6  
Old 15th May 2009, 12:53
tio289 tio289 is offline
Member
 
Join Date: Mar 2009
Posts: 70
Thanks: 2
Thanked 14 Times in 9 Posts
Default

can you draw, how look you network? router, server, client pc
Reply With Quote
  #7  
Old 15th May 2009, 13:47
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default plz

Need help how to start pure-ftp whit -p 5000-6000 ?plz
Reply With Quote
  #8  
Old 16th May 2009, 15:50
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Post

Need help how to start pure-ftp whit -p 5000-6000 ?plz
Reply With Quote
  #9  
Old 18th May 2009, 13:59
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Cool

I still got problem, any help plz ? =)

//M
Reply With Quote
  #10  
Old 25th May 2009, 17:25
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
 
Default

I still got problem, any help plz ? =)

//M

50% Solution =)

add /etc/pure-ftpd/conf/PassivePortRange
and put 5000 6000 in the PassivePortRange file i create

and restart /etc/init.d/pure-ftpd-mysql restart

I now can login whit FTP but not upload any file =(

Last edited by trexen; 25th May 2009 at 23:57.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Remoting framework - Problem with ftp user creation Whitenoise General 2 13th May 2009 12:16
Troubleshooting FTP bswinnerton Installation/Configuration 4 10th October 2008 19:34
ftp is very slow and asks for user/passwd continuously chico58 Installation/Configuration 7 8th October 2008 12:43
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 21:12
FTP 101 the basics koegies Installation/Configuration 7 17th November 2005 15:55


All times are GMT +2. The time now is 22:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.