Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th May 2009, 17:25
simple69 simple69 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Default Changing address for squirrelmail

Hello,

Sorry if this has been covered before but I have googled and search here for the answer already...

I followed falkos great guide on setting up my mail system. Awesome guide everything works great as is.

http://www.howtoforge.com/virtual-us...ail-ubuntu8.10

I am trying to change the address for squirrel mail so that my users can type in http://webmail.theirdomain.com/ instead of having to use http://www.theirdomain.com/squirrelmail/ I have ready many pages today and can't get one of them to work. I am pretty sure it has something to do with the squirrelmail.conf file falko had us copy to the apache2/conf.d folder but I am not sure. I tried enabling the virtual host and using ServerAlias webmail.* but that does not seem to work.

Any help would be appreciated . I am working with Ubuntu 8.10. Thanks
Reply With Quote
Sponsored Links
  #2  
Old 21st May 2009, 14:17
simple69 simple69 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Default

bump
still looking for help
Reply With Quote
  #3  
Old 22nd May 2009, 16:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

How did you modify squirrelmail.conf?
Did you create a DNS record for the webmail subdomain?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 22nd May 2009, 16:32
simple69 simple69 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Default

thanks for the reply. I uncommented the section for the virtual host
and added the ServerAlias webmail.* that is sort of what it said in there to do. I am not sure how or were I would create a DNS record for webmail.domain.com. Could you point me in the right direction or maybe I am going at this all wrong and you have a better way. would appreciate your help further.
Reply With Quote
  #5  
Old 23rd May 2009, 13:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please check if there's a DNS record for webmail.domain.com:
Code:
dig webmail.domain.com
If not, you have to create one on the authoritative nameservers for domain.com which you can find out like this:
Code:
dig ns domain.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 23rd May 2009, 14:45
simple69 simple69 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Thanks falko that led me in the right direction. I created the DNS record for webmail on my hosting site and then for some reason i had to change the ServerName field to webmail.domain.com for it to work. The ServerAlais entry does not seem to work for some reason. Anyways it is working now just fine. Thanks again for your help.

Also thanks again for a great guide. Yours has been far the easiest to follow and it actually works.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix not responding to telnet CarbonCopy Server Operation 6 8th May 2009 05:39
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Changing ISPConfig IP address ? avanmessen Tips/Tricks/Mods 3 12th September 2008 17:21
chgrp error new user DKA General 15 28th July 2008 17:45
Postfix and Changing From Address vanderkerkoff Server Operation 3 21st December 2007 16:41


All times are GMT +2. The time now is 18:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.