Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st May 2009, 11:31
spyda46 spyda46 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Users And Domains With Postfix, Courier And MySQL - CentOS

Hi guys,

I ve been following this howto but when i come to test SMTP i have a problem, could anyone help?

The problem is that when i run ehlo localhost i only get

250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

the howto says "If you see the lines 250-STARTTLS and 250-AUTH PLAIN LOGIN everything is fine"

I dont see them :-( - could anyone tell me why, i have followed the howto step by step so far, Thanks
Reply With Quote
Sponsored Links
  #2  
Old 21st May 2009, 12:57
spyda46 spyda46 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am also getting this error when trying ti authenticate my test user -

[root@mail1 vmail]# telnet localhost pop3
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
+OK Hello there.
user testuser@domain.co.uk
+OK Password required.
pass test
-ERR chdir exampledomain/testuser/ failed
Reply With Quote
  #3  
Old 21st May 2009, 13:17
spyda46 spyda46 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok i can login now, but the user is not getting any emails - i am not getting any bounce backs either - maillog doesnt show any errors ? :S

May 21 12:14:51 mail1 pop3d: LOGOUT, user=testuser@drwotson.co.uk, ip=[::ffff:62.72.154.34], port=[63133], top=0, retr=0, rcvd=12, sent=39, time=0
May 21 12:15:34 mail1 postfix/postfix-script: stopping the Postfix mail system
May 21 12:15:34 mail1 postfix/master[29346]: terminating on signal 15
May 21 12:15:34 mail1 sendmail[29627]: alias database /etc/aliases rebuilt by jim
May 21 12:15:34 mail1 sendmail[29627]: /etc/aliases: 76 aliases, longest 10 bytes, 765 bytes total
May 21 12:15:34 mail1 postfix/postfix-script: starting the Postfix mail system
May 21 12:15:34 mail1 postfix/master[29673]: daemon started -- version 2.3.3, configuration /etc/postfix
May 21 12:16:08 mail1 pop3d: Connection, ip=[::ffff:62.72.154.34]
May 21 12:16:08 mail1 pop3d: LOGIN, user=testuser@drwotson.co.uk, ip=[::ffff:62.72.154.34], port=[63666]
May 21 12:16:08 mail1 pop3d: LOGOUT, user=testuser@drwotson.co.uk, ip=[::ffff:62.72.154.34], port=[63666], top=0, retr=0, rcvd=12, sent=39, time=0
Reply With Quote
  #4  
Old 21st May 2009, 14:53
spyda46 spyda46 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I can login my accout now stil lcant get any emails, must be postfix related, i can see anyhthing obvious - i am getting these bouncebacks -

( ive edited my real domain BTW)
---------------------------------------------------------------------
This is the mail system at host domain.

I'm sorry to have to inform you that your message could not be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can delete your own text from the attached returned message.

The mail system

<testuser@domain.net>: unknown user: "testuser"

-----------------------------------------------------

I ve created the testuser in the users table as - testuser@domain.net -

Any ideas ? - Thanks
Reply With Quote
  #5  
Old 21st May 2009, 16:09
spyda46 spyda46 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok I am nearly there - please can someone advise on this last step -

Maillog shows-

May 21 14:58:57 mail1 postfix/virtual[31765]: E1A0117B806A: to=<testuser@domain.com>, relay=virtual, delay=0.35, delays=0.32/0.01/0/0.02, dsn=4.2.0, status=deferred (maildir delivery failed: create maildir file /home/vmail/domain.com/testuser/tmp/1242914337.P31765.mail1.domain.com: Permission denied)

i have chown 777 -R on /home/vmail/ - no such luck - can someone point me in the right direction ?
Reply With Quote
  #6  
Old 21st May 2009, 16:38
spyda46 spyda46 is offline
Junior Member
 
Join Date: May 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

All fixed now -
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.10) VTCop HOWTO-Related Questions 9 9th April 2009 16:17
Virtual Users And Domains With Postfix, Courier And MySQL (CentOS 5.1) nacef HOWTO-Related Questions 4 2nd September 2008 13:03
Virtual Users And Domains With Postfix, Courier And MySQL Secondary MX acoghlan HOWTO-Related Questions 1 8th March 2008 05:02
Virtual Users And Domains With Postfix, Courier And MySQL - "apt-get" and Courier burritonator HOWTO-Related Questions 3 15th March 2006 20:11
Problem with Virtual Users And Domains With Postfix, Courier And MySQL Howto fenix Server Operation 4 11th March 2006 02:53


All times are GMT +2. The time now is 14:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.