Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th March 2009, 06:57
slaeya slaeya is offline
Junior Member
 
Join Date: Mar 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default ISPConfig3 - Install Webmail Tutorial?

Hi,

I was wondering if anyone had a more comprehensive tutorial for install webmail with ISPConfig3 ***AFTER*** ISPConfig3 is installed. I find this one hard to follow and have now reformatted my server for the 6th time this week because I was mucking around with files / things I did not understand. I am using Ubuntu 8.10 and can't say I'm very linux savvy. I know the bare basics.

This is a snippet off http://www.ispconfig.org/docs/INSTALL_UBUNTU_8.10.txt which I found hard to follow and ended up messing up big time.
Code:
 
10.2) Horde (Webmail) - horde.org
*******************************************************************************
First of all, install the horde3 and Imp4 packages (Ubuntu/Debian)
___
apt-get install horde3 imp4 gollem kronolith2 mnemo2 nag2 turba2
pear install --onlyreqdeps Log Mail Mail_Mime MDB2 File Date
___

It is then necessary to setup an Alias for Apache. 
If you want horde only on single pages, that are created with ispc3:
Add the following line to ISPConfig->Sites->Web Domain->Options->Apache directives
If you want to access webmail on all pages add the following line to /etc/apache2/apache2.conf
###
Alias /horde3 /usr/share/horde3
###

Allow Apache to write horde configuration files :
___
chown -R www-data:www-data /etc/horde
___

Important parameters to change are (in Horde setup) :
###
Horde URL (change it to /horde3)
Enable Database Access. Do Not use MySQL Improved (4+), my attempts at using it failed. MySQL Standard runs fine however
Enable Authentication. I recommend IMAP authentication (something like {localhost:143/imap/notls}. Do not forget the /notls, not specifying failed on my setup). Also make sure to add your username to the list of Administrators, otherwise, you won‚€™t have access to horde/imp4 parameters. Using anything else than IMAP seeemed to fail on my setup
Generate the configuration
Horde should now be setup. You now have to configure imp4
generate a configuration using the horde administration panel
modify the /etc/horde/imp4/servers.php file. Instruction are given inside the file concerning the syntax. If you run Courier-IMAP, and want Imp to automatically authenticate using horde credentials :
$servers[‚€™imap‚€™] = array(
‚€˜name‚€™ => ‚€˜IMAP Server‚€™,
‚€™server‚€™ => ‚€˜localhost‚€™,
‚€˜hordeauth‚€™ => true,
‚€˜protocol‚€™ => ‚€˜imap/notls‚€™,
‚€˜port‚€™ => 143,
‚€˜folders‚€™ => ‚€˜INBOX.‚€™,
‚€˜namespace‚€™ => ‚€˜‚€™,
‚€˜maildomain‚€™ => ‚€˜domain.com‚€™,
‚€™smtphost‚€™ => ‚€˜localhost‚€™,
‚€™smtpport‚€™ => 25,
‚€˜realm‚€™ => ‚€˜‚€™,
‚€˜preferred‚€™ => ‚€˜‚€™,
‚€˜dotfiles‚€™ => false,
‚€˜hierarchies‚€™ => array()
);
###
Reply With Quote
Sponsored Links
  #2  
Old 20th March 2009, 08:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: LŁneburg, Germany
Posts: 35,976
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

I really can not recommend horde, its a mess to install and will be removed from the installation instructions therfor. Better use e.g. squirrelmail, just install it as described here:

http://www.howtoforge.com/perfect-se...-ispconfig3-p5
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th March 2009, 08:58
slaeya slaeya is offline
Junior Member
 
Join Date: Mar 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
I really can not recommend horde, its a mess to install and will be removed from the installation instructions therfor. Better use e.g. squirrelmail, just install it as described here:

http://www.howtoforge.com/perfect-se...-ispconfig3-p5
Thanks till, I already went ahead with it and it installed no problems.

I have one more question regarding this though.

I currently have to use the server domain to access webmail, if I host more than one site, can they access webmail from their own domain and how do I set this up

ie.
current setup.

domain1.net => domain1.net/webmail
domain2.net => domain1.net/webmail

desired setup

domain1.net => domain1.net/webmail
domain2.net => domain2.net/webmail

----

I have installed squirrelmail on my server and everything is currently working fine. I would love to get this working if possible though
Reply With Quote
  #4  
Old 20th March 2009, 09:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: LŁneburg, Germany
Posts: 35,976
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

To do this you would have to create a symlink named "webmail" in every website directory that points to the squirrelmail directory or you add a global alis for webmail in apache2.conf for "webmail" pointing to the squirrelmail installation.

But this only works as long as you have mod_php or suphp enabled in the website. As soon as you enable suexec it will fail with permission problems.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th March 2009, 14:08
slaeya slaeya is offline
Junior Member
 
Join Date: Mar 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default

ok, I have devised a workaround for this now.

I now have yet another question about the mailserver.

When I am sending mail from outside servers towards my mailserver I get errors -
ERR: authdaemon: s_connect() failed: Permission denied Invalid user specified.

Once I encounter this error this command fixes it

chmod 4755 /var/run/courier/authdaemon

is there any way to make it so I don't recieve this error anymore
Reply With Quote
  #6  
Old 20th March 2009, 14:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: LŁneburg, Germany
Posts: 35,976
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

http://www.howtoforge.com/forums/showthread.php?t=32478
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 20th May 2009, 20:04
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

Quote:
Originally Posted by till View Post
I really can not recommend horde, its a mess to install and will be removed from the installation instructions therfor. Better use e.g. squirrelmail, just install it as described here:

http://www.howtoforge.com/perfect-se...-ispconfig3-p5

I think Squirrelmail is disserving itself by not including some themes that can actually be looked at.

This page isn't of any help either: http://squirrelmail.org/themes.php
A little color is not enough to remove this "feeling of the nineties"
Reply With Quote
  #8  
Old 20th May 2009, 21:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: LŁneburg, Germany
Posts: 35,976
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

You may use any webmail application together with ispconfig that supports either pop3 or imap. If you dont like squirrelmail, then take a look at e.g. roundcube.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 20th May 2009, 21:57
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default

Squirrelmail is fine, it just looks ugly!
Reply With Quote
  #10  
Old 21st May 2009, 16:12
fhawk fhawk is offline
Member
 
Join Date: Mar 2009
Posts: 39
Thanks: 2
Thanked 11 Times in 9 Posts
 
Default

You can use Extmail!
http://www.extmail.org/
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42
ISPConfig3 Install writeups and Software integration modules quentusrex Developers' Forum 9 13th November 2008 21:33
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
WebMail choices. Can you install other webmail software? elies Installation/Configuration 2 23rd February 2006 11:54


All times are GMT +2. The time now is 19:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.