#1  
Old 19th May 2009, 19:02
nickpieters nickpieters is offline
Junior Member
 
Join Date: Nov 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default several issues

Hi

I have several issues, and don't understand why this is happening, server is running sinces 2 months now. Installation was with the vmware image and manual downloaded here.

1. Can't update, when i try to run the php script: php -q update.php i get this:
Fatal error: Cannot use string offset as an array in /home/administrator/ispconfig3_install/install/update.php on line 146

2. Now whenever i want to add a database, site whatever nothing happends. It gets on the webfront of the ispconfig site. But no /var/client etc... folder is made, also checked on phpmyadmin also there no added database.

3. Serverconfig etc. is empty on the ispconfig site

Anyobody that could help me?

thx!
Reply With Quote
Sponsored Links
  #2  
Old 19th May 2009, 19:23
ago2guy ago2guy is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

It looks like most changes get added to the "Jobs Queue" Which runs about every 5 minutes.

You can check if your job has run by clicking Monitor > show Jobqueue
Reply With Quote
  #3  
Old 19th May 2009, 21:13
nickpieters nickpieters is offline
Junior Member
 
Join Date: Nov 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thx for your input.

Waited, but no database or folders are beďng made.

Any other idea's?
Reply With Quote
  #4  
Old 19th May 2009, 21:30
nickpieters nickpieters is offline
Junior Member
 
Join Date: Nov 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay, folders are made in /var/clients/client1.

Made an ftp user, connecting is okay, but whenever i want to upload i get a permission denied now...

in /tmp i can write, /web not :-(

Last edited by nickpieters; 19th May 2009 at 21:41.
Reply With Quote
  #5  
Old 19th May 2009, 21:43
ago2guy ago2guy is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

Can you check the permissions on the client1 folder. I did the same myself last week and did not have this issue.

Make sure the Client Limits are set in the Clients section and also check the FTP user limits and disk quota.

The FTP usernames can get quite long as well. make sure you spelt it correctly as displayed in the FTP users list. I made that mistake myself.
Reply With Quote
  #6  
Old 19th May 2009, 22:02
nickpieters nickpieters is offline
Junior Member
 
Join Date: Nov 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ls -l, gives me

drwxr-xr-x 3 root root 4096 2009-03-04 10:25 clients
drwxr-xr-x 6 root root 4096 2009-05-18 14:38 client1

more info:

lrwxrwxrwx 1 root root 26 2009-03-12 11:46 domain.be -> /var/clients/client1/web5/
lrwxrwxrwx 1 root root 26 2009-03-11 16:39 domain.be -> /var/clients/client1/web3/
lrwxrwxrwx 1 root root 26 2009-03-11 16:05 domain.be -> /var/clients/client1/web2/
drwxr-xr-x 6 root root 4096 2009-05-18 15:23 domain
drwxr-xr-x 6 root root 4096 2009-05-18 15:25 web12
drwxr-xr-x 6 root root 4096 2009-03-11 16:05 web2
drwxr-xr-x 6 root root 4096 2009-03-11 16:39 web3
drwxr-xr-x 6 root root 4096 2009-03-12 11:46 web5


Notice the links.

Last edited by nickpieters; 19th May 2009 at 22:05.
Reply With Quote
  #7  
Old 19th May 2009, 22:14
ago2guy ago2guy is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

Sorry, I should have been more clear.

I meant the specific folder for client 1 (i.e the clients web folder )

I my case Client1 > web2 folder should look somthing like this

root@glue:/var/www/clients/client1/web2# ls -al
total 24
drwxr-xr-x 6 root root 4096 2009-05-14 19:47 .
drwxr-xr-x 4 root root 4096 2009-05-14 19:47 ..
drwxr-xr-x 2 web2 client1 4096 2009-05-14 19:47 cgi-bin
lrwxrwxrwx 1 web2 client1 35 2009-05-14 19:47 log -> /var/log/ispconfig/httpd/domain.tld
drwxr-xr-x 2 web2 client1 4096 2009-05-19 13:49 ssl
drwxrwxrwx 2 web2 client1 4096 2009-05-14 19:47 tmp
drwxr-xr-x 5 web2 client1 4096 2009-05-14 20:05 web


The owner is web2 and its in the group client1 in my case it may not be the same for you
Reply With Quote
  #8  
Old 19th May 2009, 22:16
nickpieters nickpieters is offline
Junior Member
 
Join Date: Nov 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

mars:/var/clients/client1# ls -al web12
total 24
drwxr-xr-x 6 root root 4096 2009-05-18 15:25 .
drwxr-xr-x 7 root root 4096 2009-05-18 15:25 ..
drwxr-xr-x 2 root root 4096 2009-05-18 15:25 cgi-bin
lrwxrwxrwx 1 root root 37 2009-05-18 15:25 log -> /var/log/ispconfig/httpd/domain.be
drwxr-xr-x 2 root root 4096 2009-05-18 15:25 ssl
drwxrwxrwx 2 root root 4096 2009-05-18 15:25 tmp
drwxr-xr-x 3 root root 4096 2009-05-18 15:25 web

It's just like iscponfig isn't doing all the things it should be.

for example. Do you enter the Documentroot in sites and in FTP users, do you enter the directory?
Reply With Quote
  #9  
Old 19th May 2009, 23:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,792
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

You tried to update which version which which version?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 19th May 2009, 23:08
nickpieters nickpieters is offline
Junior Member
 
Join Date: Nov 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

3.0.0.9 (was the version when i followed the htf guide).

The script doesn't work, and php -q gave me the error.

I have the feeling that this i rather a beta release, am i wrong with this?

Last edited by nickpieters; 19th May 2009 at 23:11.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Perfect XEN Setup on Debian Lenny - Live Migration Issues AlexKent HOWTO-Related Questions 8 25th April 2009 11:57
Postfix issues NewMee Installation/Configuration 7 20th April 2009 18:52
ClamAV Milter Issues - Virtual Hosting Howto With Virtualmin On CentOS 5.1 pheniks HOWTO-Related Questions 14 26th March 2008 11:04
Ubuntu Mail Server issues (warning: a long list!) klonos HOWTO-Related Questions 3 6th October 2007 14:18
ISPConfig + Turck MMCache + Hardened-PHP - Any Issues? BobbyQ General 8 3rd May 2006 22:52


All times are GMT +2. The time now is 20:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.