Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th April 2006, 08:52
KCPoole KCPoole is offline
Junior Member
 
Join Date: Apr 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default cannot connect Mail client after IMAP server setup

Hi all

I have run through "The Perfect Setup - Debian Sarge (3.1)" and run into a few problems but I think I have got it right now :-)

Might be a bit off topic, but I still cannot find out and is not really covered anywhere that I can find, but ask here in case anyone can help.

What is the format of the Mail client logins ( Mozilla FireFox), in any of the Mailserver howtos here
For the one above, unix username works ( i think) but I cannot see the IMAP or POP maildir.
If I select to view unsigned directories then I can see all dirs in my home dir on the server but cannot see any mail, so must assume I can login OK

If i do the howto "Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)", I can login as username@domain and see all mail, but this is overkill for my requirements.

Suggest that for any of the Howtos, that a section added for any particular client logins required.

Maybe I amm just a bit dumb at the moment :-) or maybe just cannot see straight from too much reading.

Thanks

KenP

ps. Also If i want to restart the howto over again from scratch, Should I just remove all packages and restart, or if I just run apt-get install will it go throught the configs again?
Reply With Quote
Sponsored Links
  #2  
Old 6th April 2006, 12:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Which POP3/IMAP daemon did you install? Do you use Maildir or mbox?

Quote:
Originally Posted by KCPoole
ps. Also If i want to restart the howto over again from scratch, Should I just remove all packages and restart, or if I just run apt-get install will it go throught the configs again?
If you run apt-get install again, it will tell you that you already have the newest package installed.
If you just want to reconfigure an already installed package, run
Code:
dpkg-reconfigure <package_name>
, e.g.
Code:
dpkg-reconfigure postfix
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th April 2006, 12:41
KCPoole KCPoole is offline
Junior Member
 
Join Date: Apr 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Which POP3/IMAP daemon did you install? Do you use Maildir or mbox?

I installed the courier IMAP suite of servers and I am trying to use IMAP with Maildirs.
If use "username" as the login I get no errors but cannot see any emails, but I can see files in my Homedir/Maildir/new on the server itself.
If I use "username@domain name" then I get errors in Posfix log and auth.log

I have seen many posts on the web as to client setup saying to use Maildir, Inbox, INBOX. etc under the advanced settings so I am rather confused!


ps Thanks for the reconfig tips as I will try again later to see if I missed something
Reply With Quote
  #4  
Old 6th April 2006, 16:00
KCPoole KCPoole is offline
Junior Member
 
Join Date: Apr 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default All Fixed now Thanks

I reran the install / setup ( including the apt-get statements) and the courier bit wanted to install more packages
courier-authdemon
courier-base
courier-ssl
liobfam0c102

I have no idea why they did not get installed first time around, but once completed the server started and I could login with my FFox client using "username" only

:-) all happy now
just need to install Webmail to get it all happening from outside my own network ( cannot get imap / pop from work)

Thanks Falko

is there anythng extra needed to get webmail working? other than installing it?
Reply With Quote
  #5  
Old 7th April 2006, 00:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

Quote:
Originally Posted by KCPoole
is there anythng extra needed to get webmail working? other than installing it?
Normally not, but that depends on the webmail software. For example, Horde is a nightmare to set up, but if you install ISPConfig, then you can install the ISPConfig webmail package afterwards, and it will work out of the box.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 12:30
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 12:47
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 11:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 01:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.