Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th May 2009, 15:26
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 10 Times in 4 Posts
Question Need help adding additional IPs to my server and ISPconfig

Hi everyone.
I have a root server with Hetzner that I set up following the perfect server setup (Debian Lenny) HowTo here on HowtoForge.
Now I have received 6 additional IPs that I would like to use.

But I'm really not sure what I need to do, to get this to work. Do I just enter the IP numbers in ISPconfig -> Management -> System Config -> Settings -> IP List ?
It sounds a little too easy.
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
Sponsored Links
  #2  
Old 18th May 2009, 10:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

This works only if $go_info["server"]["network_config"] is set to 1 in /home/admispconfig/ispconfig/lib/config.inc.php. But I suggest that you make your changes in /etc/network/interfaces and add virtual network cards (e.g. eth0:0, eth0:1, etc.).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Been Told (19th May 2009)
  #3  
Old 18th May 2009, 13:52
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 10 Times in 4 Posts
Default

Ok cool, thanks! I'll try this out when I get home. I take it when I add the virtual network cards it's it's the same "modus operandi" as with the eth0 configuration in the perfect setup debian lenny HowTo right?
I've never done this before... I can't wait to try.
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
  #4  
Old 18th May 2009, 18:36
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 10 Times in 4 Posts
Default

OK I have a problem... Here's what I put inside my /etc/network/interfaces file:
Code:
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto  eth0
iface eth0 inet static
  address   111.111.111.111
  broadcast 222.222.222.222
  netmask   255.255.255.224
  gateway   222.333.222.333

# device: eth0:0
iface eth0:0 inet static
  address   55.55.55.192
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:1
  address   55.55.55.193
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:2
  address   55.55.55.194
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:3
  address   55.55.55.195
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:4
  address   55.55.55.196
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:5
  address   55.55.55.197
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:6
  address   55.55.55.198
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# default route to access subnet
up route add -net XX.XXX.XX.XXX netmask 255.255.255.224 gw XXX.XXX.XXX.XXX eth0
When I try to restart the network, here is what I get:
Code:
# /etc/init.d/networking restart
Reconfiguring network interfaces.../etc/network/interfaces:22: duplicate option
ifdown: couldn't read interfaces file "/etc/network/interfaces"
/etc/network/interfaces:22: duplicate option
ifup: couldn't read interfaces file "/etc/network/interfaces"
failed.
Any idea what I'm doing wrong?
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
  #5  
Old 18th May 2009, 20:15
id10t id10t is offline
Senior Member
 
Join Date: Nov 2008
Posts: 242
Thanks: 2
Thanked 22 Times in 22 Posts
Default

Its all those gateways... you only need 1 default gateway... just take 'em off the extra IPs

Quote:
Originally Posted by Been Told View Post
OK I have a problem... Here's what I put inside my /etc/network/interfaces file:
Code:
# Loopback device:
auto lo
iface lo inet loopback

# device: eth0
auto  eth0
iface eth0 inet static
  address   111.111.111.111
  broadcast 222.222.222.222
  netmask   255.255.255.224
  gateway   222.333.222.333

# device: eth0:0
iface eth0:0 inet static
  address   55.55.55.192
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:1
  address   55.55.55.193
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:2
  address   55.55.55.194
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:3
  address   55.55.55.195
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:4
  address   55.55.55.196
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:5
  address   55.55.55.197
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# device: eth0:6
  address   55.55.55.198
  broadcast 55.55.55.199
  netmask   255.255.255.248
  gateway   222.333.222.333
  
# default route to access subnet
up route add -net XX.XXX.XX.XXX netmask 255.255.255.224 gw XXX.XXX.XXX.XXX eth0
When I try to restart the network, here is what I get:
Code:
# /etc/init.d/networking restart
Reconfiguring network interfaces.../etc/network/interfaces:22: duplicate option
ifdown: couldn't read interfaces file "/etc/network/interfaces"
/etc/network/interfaces:22: duplicate option
ifup: couldn't read interfaces file "/etc/network/interfaces"
failed.
Any idea what I'm doing wrong?
Reply With Quote
The Following User Says Thank You to id10t For This Useful Post:
Been Told (19th May 2009)
  #6  
Old 18th May 2009, 20:56
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 10 Times in 4 Posts
Default

Thanks!
I'm afraid it didn't help though.
Code:
server1:~# /etc/init.d/networking restart
Reconfiguring network interfaces.../etc/network/interfaces:22: duplicate option
ifdown: couldn't read interfaces file "/etc/network/interfaces"
/etc/network/interfaces:22: duplicate option
ifup: couldn't read interfaces file "/etc/network/interfaces"
failed.
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
  #7  
Old 19th May 2009, 15:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

You need an
Code:
iface eth0:x inet static
line for each virtual network card, not just for the first one.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Been Told (19th May 2009)
  #8  
Old 19th May 2009, 18:50
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 10 Times in 4 Posts
Default

Awesome thanks! So now I should be able to use the IP addresses in ISPconfig right? I entered them in ISPconfig -> Management -> System Config -> Settings -> IP List
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
  #9  
Old 20th May 2009, 17:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

Yes, that's right.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
User unknown in relay recipient table Taxick Installation/Configuration 12 9th April 2013 12:31
php Apps email not going through palkat General 8 21st September 2011 05:35
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 22:08
ISPConfig 3 - adding 2nd server joemateer Installation/Configuration 1 7th May 2009 18:20
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 14:31


All times are GMT +2. The time now is 17:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.