#1  
Old 15th May 2009, 11:52
admins admins is offline
Senior Member
 
Join Date: Apr 2009
Location: Switzerland
Posts: 210
Thanks: 6
Thanked 6 Times in 3 Posts
Default Apache

Hi all

I've a important problem I've set a server with debian 5 and ispconfig 3 up.
I created two sites my by this sites it only comes the apache default template "It works" .
How can I fix that?

Thanks
admins
Reply With Quote
Sponsored Links
  #2  
Old 15th May 2009, 20:59
fastformer fastformer is offline
Junior Member
 
Join Date: May 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default I have the same problem

I tried going through the apache settings, but it didn't work. Help please.
Reply With Quote
  #3  
Old 15th May 2009, 22:23
fastformer fastformer is offline
Junior Member
 
Join Date: May 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Found a fix

ok, the reason why it doesn't allow for this to work properly is in the vhosts. To fix this follow as instructed:

1. open "/etc/apache2/sites-avaliable/default" with your favorite editor
2. under "<VirtualHost *:80>" and right above "ServerAdmin webmaster@localhost" add "ServerName localhost"
3. save and exit your text editor
4. restart apache by invoking the command "apache2ctl -k restart"
5. go to your ispconfig and create a site with your server's domain name ie. domain.tld, and like normally add the aliases either www. or *. and save
6. wait a few minutes (2-3 mins) and voila it should be all working. You can test this, by modifiying the index.html file which would be under /var/www/domain.tld/web/ and adding a line. You should be able to see that line no matter whether you type in www.domain.tld or domain.tld.

Hope this helps.
Good luck.
Fastformer.
Reply With Quote
  #4  
Old 16th May 2009, 11:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Editing this file is not nescessary. You could have just added the IP address of your server to the IP list in ispconfig and then just select the IP for your sites instead of * in the website settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th May 2009, 16:47
fastformer fastformer is offline
Junior Member
 
Join Date: May 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default A better way?

Hi,

So most of the tutorials talk about ln -s ...
Here's a better way:

[1] cp /etc/squirrelmail/apache.conf /etc/apache2/sites-available/squirrelmail
[2] vi /etc/apache2/sites/available/squirrlemail
and modify Alias /squirrelmail /etc/squirrelmail
to Alias /webmail /etc/squirrelmail
[3] a2ensite squirrelmail

Do similar for phpmyadmin.

next for the site you can do this:
[1] go to ispconfig and create a site with your domain name. ie: domain.tld and set it to auto all subdomain by setting it to *.
[2] cd /etc/apache2/sites-available
[3] mv default default.bak
[4] cp domain.tld.vhost default

Voila!!!

Hope this helps.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
MaxClients set to appropriate level, but ISPconfig is crashing from it (I think) bpmee Server Operation 6 11th January 2007 19:29
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 10:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.