Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd May 2009, 18:08
bryand1 bryand1 is offline
Junior Member
 
Join Date: Apr 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Perfect Server Fedora 10 - make sure mod_rewrite is enabled and working

Hello,

I recently installed Fedora 10 on my new server using the Perfect Server tutorial and the server is working perfectly!!

I have a shopping cart website that I moved over from another host (copied database and all files), but none of my links will work because I think my mod_rewrite is not active.

I searched google and there are a lot of different answers. I think this is an easy problem to solve. I can see in my apache modules that the mod_rewrite.so is already there, so how can I get it to load?

Thanks for your help!

-Bryan
Reply With Quote
Sponsored Links
  #2  
Old 4th May 2009, 12:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

What's the output of
Code:
httpd -M
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th May 2009, 16:22
bryand1 bryand1 is offline
Junior Member
 
Join Date: Apr 2009
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It lists all of the modules.

Code:
...
rewrite_module (shared)
...
Does this mean it is enabled?
Reply With Quote
  #4  
Old 5th May 2009, 16:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Yes, it's enabled.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th May 2009, 13:01
mun mun mun mun is offline
Junior Member
 
Join Date: May 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I have also faced the problem. Solved it by changing the line 'AllowOverride none' to 'AllowOverride All' in the <Directory "/var/www/html"> section of httpd.conf file.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot Log In after perfect desktop/perfect server setup jkrell HOWTO-Related Questions 3 22nd December 2008 07:43
SunRay On Ubuntu, Partially Running :-) badgerbox76 Server Operation 7 7th December 2008 06:24
FTP cannot open remote folder!?! andysm849 Server Operation 23 17th October 2008 00:34
Can't start apache Musty Server Operation 12 9th March 2008 14:58
PHP not working jefash General 10 28th May 2006 09:48


All times are GMT +2. The time now is 02:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.