#1  
Old 18th May 2009, 11:39
planetsi planetsi is offline
Junior Member
 
Join Date: May 2009
Posts: 4
Thanks: 2
Thanked 0 Times in 0 Posts
Red face mydns not starting

I have setup a suse 11 as per the how-to on this site (was very impressed to)

I am having problems and i think it is realated to the start order as it appears that mydns is trying to start before mysql.

How do i make it start after mysql?


Thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 18th May 2009, 18:16
akamarinos akamarinos is offline
Junior Member
 
Join Date: Jan 2009
Posts: 24
Thanks: 6
Thanked 6 Times in 5 Posts
Default

mydnsconfig version 3 does it all by it self during the installation

but just in case

first of all run a ls -l at
/etc/rc.d/rc3.d/
/etc/rc.d/rc4.d/
/etc/rc.d/rc5.d/


and see what number is assigned to mydns
Code:

cd /etc/rc.d/rc3.d
mv S52mydns S99mydns
cd /etc/rc.d/rc4.d
mv S52mydns S99mydns
cd /etc/rc.d/rc5.d
mv S52mydns S99mydns
Reply With Quote
The Following User Says Thank You to akamarinos For This Useful Post:
planetsi (20th May 2009)
  #3  
Old 18th May 2009, 19:36
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
Default

Check this:

http://howtoforge.com/forums/showthread.php?t=31615

It has the solution for opensuse 11.1 and mydns (at least it works for me).
Reply With Quote
  #4  
Old 19th May 2009, 07:31
planetsi planetsi is offline
Junior Member
 
Join Date: May 2009
Posts: 4
Thanks: 2
Thanked 0 Times in 0 Posts
Unhappy Getting there

Yeah... i can start it using the "/etc/init.d/mydns restart"
i have in my rc3.d and rc5.d (nothing in rc4.d)

K01mydns
k03mysql
S08mysql
S99mydns


But it still starting before mysql and failing on start up...

anythoughts (P.S. what is the K01 and K03?)


Thanks.
Reply With Quote
  #5  
Old 19th May 2009, 09:41
baskin baskin is offline
Senior Member
 
Join Date: Jan 2008
Location: Syros, Greece
Posts: 118
Thanks: 9
Thanked 8 Times in 8 Posts
 
Default

You haven't read all the thread that i gave to you.

Change the "RUN_PARALLEL" to "no" in "/etc/sysconfig/boot".
Reply With Quote
The Following User Says Thank You to baskin For This Useful Post:
planetsi (20th May 2009)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MyDNS startup failed gcambull General 13 6th July 2010 15:59
mydns problem uvbnserved Server Operation 3 28th April 2009 16:46
mydns settings/help believo General 1 26th January 2009 12:49
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
dns server error Hellbound General 7 2nd August 2007 09:18


All times are GMT +2. The time now is 16:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.