Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd August 2005, 03:44
jefash jefash is offline
Junior Member
 
Join Date: Aug 2005
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default PHP not working

ok, i have ispconfig installed on fedora core 4 following "the perfect setup" on howtoforge.com, but my php forms do not work correctly, my forms get emailed to me , but no data, just the fields, if i host the form from mydomain.com:81/formname.html, it processes fine and all data gets sent to me, btw, i had to change the default port 81 to 82 per instructions i found as i use ipcop and it wont budge off of port 81, also, am i understanding correctly that ispconfig and the apache web server it controls arent one and the same, that ispconfig runs on apache 1.33 on port 81, and apache 2 runs on port 80

i have php scripts enabled for the sites, i have tried it with safemode on and off, same thing, when php is disabled for the site in ispconfig i get the errors that i should since php scripts are disabled, any ideas?

this is from the info.php from the sticky thread

PHP Core
Directive Local Value Master Value
allow_call_time_pass_reference Off Off
allow_url_fopen On On
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_globals_jit On On
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors Off Off
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_log no value no value
error_prepend_string no value no value
error_reporting 2047 2047
expose_php On On
extension_dir /usr/lib/php/modules /usr/lib/php/modules
file_uploads On On
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .:/usr/share/pear .:/usr/share/pear
log_errors On On
log_errors_max_len 1024 1024
magic_quotes_gpc Off Off
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.force_extra_parameters no value no value
max_execution_time 30 30
max_input_time 60 60
memory_limit 8M 8M
open_basedir no value no value
output_buffering 4096 4096
output_handler no value no value
post_max_size 8M 8M
precision 14 14
register_argc_argv On On
register_globals Off Off
register_long_arrays Off Off
report_memleaks On On
report_zend_debug On On
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 2M 2M
upload_tmp_dir no value no value
user_dir no value no value
variables_order EGPCS EGPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
zend.ze1_compatibility_mode Off Off


apache2handler
Apache Version Apache/2.0.54 (Fedora)
Apache API Version 20020903
Server Administrator webmaster@xxx.gotdns.com
Hostname:Port www.xxx.gotdns.com:80
User/Group apache(48)/48
Max Requests Per Child: 4000 - Keep Alive: off - Max Per Connection: 100
Timeouts Connection: 120 - Keep-Alive: 15
Virtual Server Yes
Server Root /etc/httpd
Loaded Modules core prefork http_core mod_so mod_access mod_auth mod_auth_anon mod_auth_dbm mod_auth_digest util_ldap mod_auth_ldap mod_include mod_log_config mod_logio mod_env mod_mime_magic mod_cern_meta mod_expires mod_deflate mod_headers mod_usertrack mod_setenvif mod_mime mod_dav mod_status mod_autoindex mod_asis mod_info mod_dav_fs mod_vhost_alias mod_negotiation mod_dir mod_actions mod_speling mod_userdir mod_alias mod_rewrite mod_proxy proxy_ftp proxy_http proxy_connect mod_cache mod_suexec mod_disk_cache mod_file_cache mod_mem_cache mod_cgi mod_perl mod_php5 mod_python mod_ssl

Directive Local Value Master Value
engine 1 1
last_modified 0 0
xbithack 0 0


Apache Environment
Variable Value
HTTP_ACCEPT image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
HTTP_ACCEPT_LANGUAGE en-us
HTTP_ACCEPT_ENCODING gzip, deflate
HTTP_USER_AGENT Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
HTTP_HOST xxx.gotdns.com
HTTP_CONNECTION Keep-Alive
HTTP_COOKIE lang=english; admin=YWRtaW46ZTYxYmEzYjAxZDk3ODE0ODBkMDEzY2FmNDhm YWUzNDM6
PATH /sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
SERVER_SIGNATURE <address>Apache/2.0.54 (Fedora) Server at xxx.gotdns.com Port 80</address>
SERVER_SOFTWARE Apache/2.0.54 (Fedora)
SERVER_NAME xxx.gotdns.com
SERVER_ADDR 192.168.1.100
SERVER_PORT 80
REMOTE_ADDR 192.168.1.1
DOCUMENT_ROOT /home/www/web4/web
SERVER_ADMIN webmaster@xxx.gotdns.com
SCRIPT_FILENAME /home/www/web4/web/info.php
REMOTE_PORT 2821
GATEWAY_INTERFACE CGI/1.1
SERVER_PROTOCOL HTTP/1.1
REQUEST_METHOD GET
QUERY_STRING no value
REQUEST_URI /info.php
SCRIPT_NAME /info.php


HTTP Headers Information
HTTP Request Headers
HTTP Request GET /info.php HTTP/1.1
Accept image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
Accept-Language en-us
Accept-Encoding gzip, deflate
User-Agent Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Host xxx.gotdns.com
Connection Keep-Alive
Cookie lang=english; admin=YWRtaW46ZTYxYmEzYjAxZDk3ODE0ODBkMDEzY2FmNDhm YWUzNDM6
HTTP Response Headers
X-Powered-By PHP/5.0.4
Connection close
Transfer-Encoding chunked
Content-Type text/html; charset=UTF-8

mysql
MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 4.1.12
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient

Directive Local Value Master Value
mysql.allow_persistent On On
mysql.connect_timeout 60 60
mysql.default_host no value no value
mysql.default_password no value no value
mysql.default_port no value no value
mysql.default_socket no value no value
mysql.default_user no value no value
mysql.max_links Unlimited Unlimited
mysql.max_persistent Unlimited Unlimited
mysql.trace_mode Off Off


mysqli
MysqlI Support enabled
Client API version 4.1.12
MYSQLI_SOCKET /var/lib/mysql/mysql.sock

Directive Local Value Master Value
mysqli.default_host no value no value
mysqli.default_port 3306 3306
mysqli.default_pw no value no value
mysqli.default_socket no value no value
mysqli.default_user no value no value
mysqli.max_links Unlimited Unlimited
mysqli.reconnect Off Off

Last edited by jefash; 22nd August 2005 at 04:39.
Reply With Quote
Sponsored Links
  #2  
Old 22nd August 2005, 07:54
Tribal-Dolphin Tribal-Dolphin is offline
Member
 
Join Date: Jul 2005
Location: Rives - Isère - FRANCE
Posts: 50
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hello,

Your PHP works fine ! but you have a problem with the configuration.
Edit php.ini file and do this :
Code:
 register_globals On
and try again.
Reply With Quote
  #3  
Old 22nd August 2005, 10:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Have a look here: http://www.howtoforge.com/forums/showthread.php?t=87
and here: http://www.howtoforge.com/forums/showthread.php?t=246
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 23rd August 2005, 04:35
jefash jefash is offline
Junior Member
 
Join Date: Aug 2005
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thank you, worked perfect, i scoured the internet for 2 days and didnt find that
Reply With Quote
  #5  
Old 21st May 2006, 01:12
K_meleonu K_meleonu is offline
Senior Member
 
Join Date: May 2006
Posts: 108
Thanks: 1
Thanked 5 Times in 4 Posts
Default

Hi,
I have that blank page problem with .php ... i searched and readed on this forum all the posts regarding that problem but it seemn nothing work's to me. I installed a Mambo web site and when i try to access it i get a blank page.
Also i made a simple php mailer, it is working but i o not receive the e-mails i send with it.
Can someone help me? I whould be more than gratefull... Thank you all in advance
Reply With Quote
  #6  
Old 21st May 2006, 20:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by K_meleonu
Hi,
I have that blank page problem with .php ... i searched and readed on this forum all the posts regarding that problem but it seemn nothing work's to me. I installed a Mambo web site and when i try to access it i get a blank page.
Also i made a simple php mailer, it is working but i o not receive the e-mails i send with it.
Can someone help me? I whould be more than gratefull... Thank you all in advance
Did you create a web site for Mambo with ISPConfig? Make sure you do not enable PHP Safe Mode for that web site.
Regarding your email problem: any errors in the mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 21st May 2006, 22:58
K_meleonu K_meleonu is offline
Senior Member
 
Join Date: May 2006
Posts: 108
Thanks: 1
Thanked 5 Times in 4 Posts
Default

About the email problem : I will post the errors here: http://www.howtoforge.com/forums/sho...7026#post27026

Regarding the php problem:
Yes it's about a Mambo web site but i have the php safe mode disabled
I also triyed with a php nuke web site. After install i also have a white page.

PLEASE HEEEEELLP ME
:P

Thank you a lot in advance
Reply With Quote
  #8  
Old 22nd May 2006, 09:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by K_meleonu
Regarding the php problem:
Yes it's about a Mambo web site but i have the php safe mode disabled
I also triyed with a php nuke web site. After install i also have a white page.
Anything in your Apache error log? Is there an .htaccess file in your web root? If so, what's in it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 22nd May 2006, 09:50
K_meleonu K_meleonu is offline
Senior Member
 
Join Date: May 2006
Posts: 108
Thanks: 1
Thanked 5 Times in 4 Posts
Default

I only have .htpasswd .
But i don't think that is a problem. I have no apache errors. i have restarted it and all workt ok. I also installed a phpBB2 forum and that is working great. no problems at all... i triyed with a php made web site and it also works great.
i don't know what to do to make this work.
Reply With Quote
  #10  
Old 23rd May 2006, 19:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

What's the output of
Code:
updatedb
locate .htaccess
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[error] an unkown filter was not added: PHP Arien Installation/Configuration 12 7th October 2006 14:17
Cannot compile new PHP with apxs olli Installation/Configuration 11 4th March 2006 15:32
php safe mode not working.. hagel Installation/Configuration 2 18th August 2005 10:44
Multiple domains jysse Installation/Configuration 2 10th August 2005 11:22
Apache + PHP lola Server Operation 1 25th April 2005 13:41


All times are GMT +2. The time now is 17:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.