#1  
Old 12th May 2009, 06:21
tedeu tedeu is offline
Junior Member
 
Join Date: May 2009
Posts: 22
Thanks: 2
Thanked 0 Times in 0 Posts
Question how to: themes

Hello,
after i install IPS Config 3, where to go for themes ?
Where to go to modify them , that's what i ment ...
Becasue i installed as told on the howtoforge, and my linux (Fedora10) is in text mode, and i can't make any templates or modify template in text mode, so how can i extract the themes part and put it on a windows machine so i can customize the template ?
Thank you verry mutch , and i wait for an answer.
Reply With Quote
Sponsored Links
  #2  
Old 19th May 2009, 06:48
tedeu tedeu is offline
Junior Member
 
Join Date: May 2009
Posts: 22
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Nobody knows ?
Come on, it's a simple question (i guess)
Reply With Quote
  #3  
Old 19th May 2009, 21:13
ago2guy ago2guy is offline
Junior Member
 
Join Date: Dec 2007
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

I'm no expert, but I tripped upon the following while hunting for the jobs quere trigger.

/usr/local/ispconfig/interface/web/theme/defaut

also the theme appears to be set as part of the config() array variable so if you change folder name, you will have to edit it as well.

a.
Reply With Quote
  #4  
Old 20th May 2009, 00:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Correct. Just make a copy of the folder /usr/local/ispconfig/interface/web/theme/defaut e.g. like this:

cp -prf /usr/local/ispconfig/interface/web/theme/defaut /usr/local/ispconfig/interface/web/theme/mytheme

and then change the files in the mytheme folder. The theme will be available automatically, you can choose it when you change a cp user or client.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
rudolfpietersma (29th September 2009)
  #5  
Old 22nd May 2009, 10:56
patrick232 patrick232 is offline
Junior Member
 
Join Date: May 2009
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

ok, i just made a copy of the default-folder and made some changes. i choosed to use the new theme in the controlpanel and .. nothing happened

then i made a mistake (at least i think this is the problem) - because i tried to rename the default-folder from "default" to "default_backup" and renamed my new theme to "default". now i get the error (when browsing ispconfig with my webbrowser):
Code:
Strict Standards: Non-static method vlibTemplateError::raiseError() should not be called statically, assuming $this from incompatible context in /usr/local/ispconfig/interface/lib/classes/tpl.inc.php on line 161
vlibTemplate Error: Template (main.tpl.htm) file not found.
after re-changing the name of the default-backup-folder back to "default" it still doesnt work.

i dont have any clue why it doesnt work anymore.. so any hints or suggestions would be nice

best regards patrick
Reply With Quote
  #6  
Old 22nd May 2009, 11:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Maybe you changed the owner of the files or the permissions.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 22nd May 2009, 11:31
patrick232 patrick232 is offline
Junior Member
 
Join Date: May 2009
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

ty for the fast reply

Code:
root@webhost:/usr/local/ispconfig/interface/web/themes# ls -al
total 16
drwxr-s---  4 ispconfig ispconfig 4096 May 22 09:36 .
drwxr-s--- 16 ispconfig ispconfig 4096 Feb 26 23:12 ..
drwxr-sr-x  8 ispconfig ispconfig 4096 May 22 08:52 mytheme
drwxr-sr-x  7 ispconfig ispconfig 4096 Feb 26 23:12 default
i changed the owner with chown to ispconfig and changed permissions with chmod -R 755

i can even browse http:// domain.com:8080/themes/default/templates/main.tpl.htm
Reply With Quote
  #8  
Old 22nd May 2009, 11:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Ok. Then there might be a problem with the session. Close all browser windows and then start the internet browser again and connect to ispconfig.

If this does not help, download the latest ispconfig again (no problem if its the same version that you have installed) and run the update.php script. Choose 'n' when you were asked if your services shall be reconfigured so that only the ispconfig files will be copied again.

Not sure what causes this on your setup. Making a new theme by copying the default theme should work, but I will try it on my test server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 22nd May 2009, 11:52
patrick232 patrick232 is offline
Junior Member
 
Join Date: May 2009
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

yep, restarting the browser did the trick

but changing the theme for a specific user didnt work so far. what i did so far:
* change user-theme for user XY
* logged in with user XY (via the login-button, right to the user in the system-user-list)
* restarted browser

the user gets displayed the default-theme

as i only need 1 theme, im changing the default-theme now (so it works for me)
Reply With Quote
  #10  
Old 27th May 2009, 09:56
patrick232 patrick232 is offline
Junior Member
 
Join Date: May 2009
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

ok, here is another problem i couldnt solve so far.

i changed the main.tpl.htm and added some divs and other stuff. all works fine except when i refresh the site or logout. then all the stuff i added in the main.tpl.htm has gone.

it seems like any other template has been loaded - but didnt find any hint in the code yet. i think its releated on the $_SESSION?

maybe anyone can give me some hints, ty

--
patrick
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail Themes warlock Installation/Configuration 1 13th November 2008 16:00
phpmyadmin error lifeisboost Installation/Configuration 9 14th August 2008 20:19
Help With GUI Menu nightfire Programming/Scripts 3 1st July 2008 16:27
Bluerua New theme for Ubimiau jfruano Tips/Tricks/Mods 3 2nd September 2006 00:41
Themes adamluz Feature Requests 0 19th October 2005 00:55


All times are GMT +2. The time now is 02:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.