#1  
Old 8th May 2009, 15:31
bob808 bob808 is offline
Junior Member
 
Join Date: Jan 2009
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix config problem

Hello all. I am running an Ubuntu 8.10 perfect server with ispconfig 2.

In time I found that I have to configure very good postfix. Because of spammers and to increase security I found myself in the middle of a config-line spaghetti.

My master.cf is :

#
# Postfix master process configuration file. For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ================================================== ========================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ================================================== ========================
smtp inet n - - - - smtpd
-o message_size_limit=25000000
submission inet n - - - - smtpd
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticate d,reject
-o milter_macro_daemon_name=ORIGINATING
-o message_size_limit=25000000
-o smtpd_tls_wrappermode=yes
smtps inet n - - - - smtpd
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticate d,reject
-o milter_macro_daemon_name=ORIGINATING
-o smtpd_tls_wrappermode=yes
-o message_size_limit=25000000
#628 inet n - - - - qmqpd
pickup fifo n - - 60 1 pickup
cleanup unix n - - - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - - 300 1 oqmgr
tlsmgr unix - - - 1000? 1 tlsmgr
rewrite unix - - - - - trivial-rewrite
bounce unix - - - - 0 bounce
defer unix - - - - 0 bounce
trace unix - - - - 0 bounce
verify unix - - - - 1 verify
flush unix n - - 1000? 0 flush
proxymap unix - - n - - proxymap
proxywrite unix - - n - 1 proxymap
smtp unix - - - - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - - - - smtp
-o smtp_fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - - - - showq
error unix - - - - - error
retry unix - - - - - error
discard unix - - - - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - - - - lmtp
anvil unix - - - - 1 anvil
scache unix - - - - 1 scache
#
# ================================================== ==================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ================================================== ==================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman unix - n n - - pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}


I had some spammers problem and I had to use port 587 for submitting email.
Because most computers in my company have Microsoft Outlook 2003 witch does not support TLS, I must use port 587 with SSL option. I wish to close port 25 for submitting emails also port 467. I want only 587 with ssl and tls. What to I keep and what do I comment out?
Also when I run a postconf /etc/postfix/master.cf I get an error saying that smtp is twice in the master.cf file. I commented out the second one from bottom, and then I couldn't send emails outside my network. Why are there 2 smtp options? e.g. smtp inet n - - - - smtpd

Furthermore, how secure is sending email over port 587 with ssl or tls? Does the actual email message gets encrypted between the client sending it and my server that's receiving it? Or only the password gets encrypted?
I just put -o smtpd_tls_wrappermode=yes under submission port settings and now I can send emails via 587 with SSL, but TLS on 587 doesn't work anymore. Is it supposed to work that way?

Hope someone clears out all that for me because I was looking alot for this info on the internet and couldn't find all info I need.
Thank you very much and have a nice day.

Last edited by bob808; 8th May 2009 at 17:00.
Reply With Quote
Sponsored Links
  #2  
Old 11th May 2009, 14:18
bob808 bob808 is offline
Junior Member
 
Join Date: Jan 2009
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hmmz...
Can anyone tell me how do I close port 25 for sending emails, leave 587 only with TLS and 465 with ssl and without?
what lines do I comment out and what lines do I leave?
this should be easy but I'm somewhat a beginner...
Reply With Quote
  #3  
Old 12th May 2009, 19:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

To close port 25, comment out the line
Code:
smtp inet n - - - - smtpd
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix config - virtual domain mapping problem spdavid Installation/Configuration 1 24th May 2008 13:49
Ubuntu / Postfix problem - [newbie] barney.parker Server Operation 6 7th November 2007 14:44
Postfix: connection refused error tosin Server Operation 1 30th October 2007 18:30
ISPConfig 2.2.14 released till General 48 20th July 2007 00:46
spamassasin/clamAV not working Daisy Installation/Configuration 32 15th February 2007 01:09


All times are GMT +2. The time now is 09:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.