#1  
Old 29th March 2006, 18:12
kaygroth kaygroth is offline
Junior Member
 
Join Date: Mar 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default MySQL

Im trying to install ISPConfig, but im stuck on MySQL, having never used it im at a loss what to do, when installling ISPConfig it tells me to start the DB but i have checked and MySQL is running ok, not sure if i have to create a DB for it to install or not, any help would be accepted with open arms

oh and im running mandriva 2006 powerpack x64 btw

Last edited by kaygroth; 29th March 2006 at 18:14.
Reply With Quote
Sponsored Links
  #2  
Old 29th March 2006, 19:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's the exact error message?
Please post the output of
Code:
netstat -tap
and
Code:
ps aux|grep -i mysql
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 30th March 2006, 12:37
kaygroth kaygroth is offline
Junior Member
 
Join Date: Mar 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok the error is
ERROR: MySQL is not running! Please start your MySQL database and run the ISPConfig setup again.


netstat -tapand

(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:netbios-ssn *:* LISTEN -
tcp 0 0 *:5900 *:* LISTEN -
tcp 0 0 *:sunrpc *:* LISTEN -
tcp 0 0 *:http *:* LISTEN -
tcp 0 0 *:https *:* LISTEN -
tcp 0 0 *:microsoft-ds *:* LISTEN -
tcp 0 0 192.168.0.11:55017 imap.plus.net:imap ESTABLISHED 18100/kontactIYmwSa
tcp 0 0 192.168.0.11:50896 216.239.59.104:http ESTABLISHED 18124/konqueroreju9
tcp 0 0 192.168.0.11:50900 216.239.59.104:http TIME_WAIT -
tcp 0 0 192.168.0.11:50902 216.239.59.104:http ESTABLISHED 18121/konquerorlfFd
tcp 0 0 192.168.0.11:5900 host-80-194-98-133.st:32710 ESTABLISHED -
tcp 0 0 192.168.0.11:42993 209.50.189.200:http TIME_WAIT -
tcp 1 1 192.168.0.11:34419 www.howtoforge.com:http CLOSING -
tcp 1 1 192.168.0.11:34417 www.howtoforge.com:http CLOSING -
tcp 0 0 192.168.0.11:34413 www.howtoforge.com:http TIME_WAIT -
tcp 0 0 192.168.0.11:34412 www.howtoforge.com:http TIME_WAIT -
tcp 0 0 192.168.0.11:34411 www.howtoforge.com:http TIME_WAIT -
tcp 0 0 192.168.0.11:34410 www.howtoforge.com:http TIME_WAIT -
tcp 0 0 192.168.0.11:48481 84.53.134.200:http TIME_WAIT -
tcp 0 0 192.168.0.11:39940 84.53.134.208:http TIME_WAIT -
tcp 0 0 *:ssh *:* LISTEN


ps aux|grep -i mysql

root 18664 0.0 0.1 6740 1356 pts/0 S 12:37 0:00 /bin/sh /usr/bin/mysqld_safe --defaults-file=/etc/my.cnf --skip-networking --pid-file=/var/run/mysqld/mysqld.pid
mysql 18699 0.0 2.3 130176 23580 pts/0 Sl 12:37 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking

Last edited by kaygroth; 30th March 2006 at 12:40.
Reply With Quote
  #4  
Old 30th March 2006, 15:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

You must disable --skip-networking for MySQL. Edit /etc/sysconfig/mysqld and remove --skip-networking from the Variable MYSQLD_OPTIONS:
Code:
MYSQLD_OPTIONS=""
Then restart MySQL:
Code:
/etc/init.d/mysqld restart
and try to install ISPConfig again.
Also have a look at this tutorial: http://www.howtoforge.com/perfect_setup_mandriva_2006
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 2nd April 2006, 11:20
wdwm wdwm is offline
Junior Member
 
Join Date: Apr 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[QUOTE=falko]You must disable --skip-networking for MySQL. Edit /etc/sysconfig/mysqld and remove --skip-networking from the Variable MYSQLD_OPTIONS:
Code:
MYSQLD_OPTIONS=""

Sorry, I'm a total noob to all this. Can you please tell me how I edit out the --skip-networking please?
Reply With Quote
  #6  
Old 2nd April 2006, 12:20
wdwm wdwm is offline
Junior Member
 
Join Date: Apr 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

NM found emacs
Reply With Quote
  #7  
Old 2nd April 2006, 22:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

You can also use vi: http://www.howtoforge.com/faq/12_15_en.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
MySQL installation roblem [/me sad] Nejko Installation/Configuration 16 11th January 2006 13:28
Failed at MySQL lhatle Installation/Configuration 4 29th November 2005 01:26
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41


All times are GMT +2. The time now is 14:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.