Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd August 2011, 19:59
Fairbanks Fairbanks is offline
Junior Member
 
Join Date: Jul 2011
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation Spamassassin not working - ISPConfig v2.2.39 / CentOS 5.6 / postfix

Im running an ISPConfig server over CentOS 5.6. I followed the perfect setup from ISPConfig.org but now running the platform for a few weeks and trying to setup mail account with SPAM / Virus, I realize that those filters are not working (I do not get any effect regardless of what I do in the config panel e.g. re-write, discard, score changes, ).

Please, let me know what kind of info you need for diagnosis purposes as I dont even know where to start

Thanks,
Reply With Quote
Sponsored Links
  #2  
Old 23rd August 2011, 10:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Are there any errors in your mail log (in the /var/log/ directory)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 23rd August 2011, 14:34
Fairbanks Fairbanks is offline
Junior Member
 
Join Date: Jul 2011
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Not that I see (or not obvious). There's something about "Freshclam" updating ClamAV signatures. Other then that, regular connect/disconnect as mails are routed.

What am I looking for...
Reply With Quote
  #4  
Old 23rd August 2011, 14:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,638
Thanks: 793
Thanked 4,998 Times in 3,909 Posts
Default

Do you get any errors when you run:

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint

you might also want to run this command to update the spamassassin rules:

/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 23rd August 2011, 15:04
Fairbanks Fairbanks is offline
Junior Member
 
Join Date: Jul 2011
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Below is what I got (I ran the update after getting the first warning). Something to worry about "the Line 65" message...

[root ~]# /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint
Subroutine IO::Socket::INET6::AF_INET6 redefined at /usr/lib/perl5/5.8.8/Exporter.pm line 65.
at /usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm line 16
config: no rules were found! Do you need to run 'sa-update'?
[root ~]# /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
[root ~]# /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint
Subroutine IO::Socket::INET6::AF_INET6 redefined at /usr/lib/perl5/5.8.8/Exporter.pm line 65.
at /usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm line 16
[root@ns1 ~]#
Reply With Quote
  #6  
Old 23rd August 2011, 15:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,638
Thanks: 793
Thanked 4,998 Times in 3,909 Posts
Default

The rules were missing, I think it should work now after the sa-update run even with the line 65 error.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 23rd August 2011, 15:11
Fairbanks Fairbanks is offline
Junior Member
 
Join Date: Jul 2011
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks "for now" Till. It won't be long before I see Spam coming my way, so I will let you know shorthly if things are better or not.

Should I CRON this update or is it done thru regular ISPConfig processes ?...
Reply With Quote
  #8  
Old 23rd August 2011, 15:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,638
Thanks: 793
Thanked 4,998 Times in 3,909 Posts
Default

You can create a cronjob for that.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 23rd August 2011, 15:49
Fairbanks Fairbanks is offline
Junior Member
 
Join Date: Jul 2011
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Well - THANKS Till.

I got an email re-written to "[*** SPAM ***]-[Score 17.8]" ...

I can now play with the ISPConfig setup and finetune what I want to do with those eMails (discard, or accept and flush with Outlook...).

Thanks Again.

G
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Control Panel - E-mail Tab is empty domi-nik General 15 14th April 2011 18:17
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 14:31
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 16:22
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 14:31


All times are GMT +2. The time now is 13:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.