Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd May 2009, 14:48
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default trouble with wordpress and suPhp

wordpress has placed this .htaccess inside my web folder and needs it:

Quote:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
seems ok to me, at least it ran with ispcfg2
now I get an 500 server error and the log file says:

.htaccess: RewriteEngine not allowed here

can't find much on this with google, I checked and the rewrite module is loaded with apache2.
I tried adding this directive within the ispcfg3 administration ot this certain website but it didn't help:

Quote:
<Directory "/var/www/clients/client1/web2/">
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>
Reply With Quote
Sponsored Links
  #2  
Old 2nd May 2009, 14:59
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default

k, solved that. my syntax was a little wrong, this fixed it:

Quote:
<Directory /var/www/clients/client1/web2/web>
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>
now I get another 500 error and the log says:

Quote:
SoftException in Application.cpp:245: File "/var/www/clients/client1/web2/web/index.php" is writeable by group
chmod -R 755 web/ helped here
Reply With Quote
  #3  
Old 2nd May 2009, 15:56
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default

ok, seems I got it to run. how can I check if it is indeed running on suPhp?

###edit###
answered my own question, top says:

Quote:
6621 web2 20 0 482m 62m 11m R 3 1.6 0:01.42 web2 php-cgi
Reply With Quote
  #4  
Old 2nd May 2009, 16:46
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
 
Default

ahhh! another problem!

all of a sudden the site doesn't work anymore, I go back and find the default index.html that I deleted is back, thus preventing my index.php from working, then I get a 404 error and notice my .htacess file has been overwritten by an empty default one?

is ispcfg restoring itsself? how could I prevent this?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What "PHP" option to use? Fast-CGI, CGI, Mod-PHP or SuPHP. edge General 24 17th July 2010 19:53
Friendly urls problem (before set suPHP) little_oak Installation/Configuration 13 16th January 2009 15:18
suPHP: Unworkable. jonwatson Installation/Configuration 6 29th March 2007 09:03


All times are GMT +2. The time now is 14:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.