Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st May 2009, 22:06
abmoller abmoller is offline
Junior Member
 
Join Date: Apr 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default SMTP server response: Bad recipient address syntax (state 14)

Hi

I am trying to config my SMTP server to receiving incoming emails, yet to no avail. I just tried to send an e-mail from a gmail account and this was the server response

501 501 5.1.3 Bad recipient address syntax (state 14)

What could be causing this, it is obviously the config of the SMTP server but I don't know what. Pls help!

Kind regards

FYI - I have been using the http://www.howtoforge.com/virtual-users-domains-postfix-courier-mysql-squirrelmail-fedora-10 . Also I think it could matter that my host is still running on a global IP address ref so the e-mail addresses would be something like user@1.2.3.4
Reply With Quote
Sponsored Links
  #2  
Old 2nd May 2009, 17:16
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Check your /var/log/maillog, its a misconfiguration causing the mail to be rejected.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 2nd May 2009, 17:44
abmoller abmoller is offline
Junior Member
 
Join Date: Apr 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by topdog View Post
Check your /var/log/maillog, its a misconfiguration causing the mail to be rejected.
I am getting a line in my maillog:
Code:
postfix/smtpd[21450]: warning: Illegal address syntax from localhost.localdomain[127.0.0.1] in RCPT command: <user@1.2.3.4>
I am getting the feeling I am overlooking something stupid here. I set the proxy_interfaces setting to 1.2.3.4 since my server behind a NAT. Nothing.

What is the difference between editing the settings in main.cf versus postconf -e? Is it the same thing?

Also, I can send mail from the server to a gmail account using mailx. When trying to use Squirrelmail to send email from a user account it throws a bad syntax error at me, similar to the server response when trying to send emails to it. What am I missing here??
Reply With Quote
  #4  
Old 3rd May 2009, 00:03
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Please post your main.cf file.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #5  
Old 3rd May 2009, 15:27
abmoller abmoller is offline
Junior Member
 
Join Date: Apr 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the suspicion that postfix rejects all mails to a user@1.2.3.4 address and therefore the Illegal address syntax msg. Can someone confirm this before I post my main.cf file???
Reply With Quote
  #6  
Old 3rd May 2009, 17:42
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Quote:
Originally Posted by abmoller View Post
I have the suspicion that postfix rejects all mails to a user@1.2.3.4 address and therefore the Illegal address syntax msg. Can someone confirm this before I post my main.cf file???
Not if you have setup your mail system to support ip literals.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #7  
Old 3rd May 2009, 18:22
abmoller abmoller is offline
Junior Member
 
Join Date: Apr 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is that a setting in the config file or is it a more complicated matter? Thank you very much for all your replies!
Reply With Quote
  #8  
Old 19th January 2010, 23:12
codexico codexico is offline
Junior Member
 
Join Date: Jan 2010
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

This worked for me!
If you find that you are receiving 5.1.x errors while trying to send
SMTP emails it may be that your mail server has either the parameter
strict_rfc821_envelopes = yes or adheres strictly to the ESMTP (RFC
5321) protocols which require email addresses to be enclosed in < > as
in "John Doe <j...@email.com>".
Ref:
http://groups.google.com/group/cake-...c3ffbf32?pli=1
Reply With Quote
The Following User Says Thank You to codexico For This Useful Post:
falko (20th January 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Opening TPC ports thehappyappy Installation/Configuration 12 7th May 2008 18:39
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 16:30
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 18:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.