Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Other Forums > Smalltalk

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 22nd August 2005, 10:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,268 Times in 4,130 Posts
Default

Quote:
Originally Posted by domino
I'm afraid that will be a losing battle, but i'll try. My IP changes at least every 2 days. Another thing to consider is that other scums/clients with my ISP do spam, adding the block to be blacklisted again. Correct me if i'm wrong, but I think the only solution is to purchase a dedicated IP. So if it happens again, I can email them with the static IP.
Have you thought about my solution posted above? Normally every DSL Provider has Mailservers that can be used as mailrelay from the clients. Why not configure your postfix to send all outgoing email trough this mailserver from your DSL Provider?
Reply With Quote
Sponsored Links
  #12  
Old 22nd August 2005, 10:46
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default

Quote:
Originally Posted by till
Have you thought about my solution posted above? Normally every DSL Provider has Mailservers that can be used as mailrelay from the clients. Why not configure your postfix to send all outgoing email trough this mailserver from your DSL Provider?
Actually I didn't think about it but if it will resolve this embarrassment, I can try it. I'm in Webmin now under Postfix Configuration --> General Options. There is a setting: What domain to use in outbound mail. I would enter my ISP mail server there?

And also there is another setting in the Other General Options. it is labled: Send outgoing mail via host I would again enter my ISP mail server there?
Reply With Quote
  #13  
Old 22nd August 2005, 10:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,268 Times in 4,130 Posts
Default

Quote:
Originally Posted by domino
Actually I didn't think about it but if it will resolve this embarrassment, I can try it. I'm in Webmin now under Postfix Configuration --> General Options. There is a setting: What domain to use in outbound mail. I would enter my ISP mail server there?
I think this setting will rewrite your outgoing email adresses, better leave it blank.

Quote:
Originally Posted by domino
And also there is another setting in the Other General Options. it is labled: Send outgoing mail via host I would again enter my ISP mail server there?
Yes this looks like the right option, enter the relayserver of your provider here. Sorry, I'am not very familar with webmin
Reply With Quote
  #14  
Old 22nd August 2005, 11:07
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default

Quote:
Yes this looks like the right option, enter the relayserver of your provider here. Sorry, I'am not very familar with webmin
That's okay. Most real admins don't need webmin and I have heard horror stories about newbies using webmin and tashing there box .

I still don't understand how this will remove the IP address from the blacklist database though. I mean, once I use my ISP's smtp for outbound, will the IP be removed from the blacklist database?
Reply With Quote
  #15  
Old 22nd August 2005, 11:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,268 Times in 4,130 Posts
Default

Quote:
Originally Posted by domino
I still don't understand how this will remove the IP address from the blacklist database though. I mean, once I use my ISP's smtp for outbound, will the IP be removed from the blacklist database?
This will not remove your IP from the blacklist, but this is not nescessary any more because the IP of the mailserver of your provider is not blacklisted.
Reply With Quote
  #16  
Old 22nd August 2005, 11:34
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default

Ahh! I get it now. By using my ISP's smtp server, the mail server receiving my mail will not see it as blacklisted. Just a work around so ALL emails that originate from my domains are received. I just hope my friends dont tease me or stone me by running a whois on there domains and foinding out that the domains are blacklisted . I really hope only the IP address are blacklisted, and NOT the domain as well. As it is very hard to remove yourself from the database. Especially from sorbs.net

Last edited by domino; 22nd August 2005 at 11:37.
Reply With Quote
  #17  
Old 22nd August 2005, 11:45
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default

I have a bit of bad news

Quote:
<myself@gmail.com>: host mail.myisp.com[xxx.xxx.xxx.xxx] said: 550 5.7.1
Unable to relay for myself@gmail.com (in reply to RCPT TO command)
I did another test and configured my email client (outook) to send thruogh my ISP smtp server and it works.
Reply With Quote
  #18  
Old 22nd August 2005, 11:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by domino
And also there is another setting in the Other General Options. it is labled: Send outgoing mail via host I would again enter my ISP mail server there?
You could also directly edit /etc/postfix/main.cf. Insert these lines:
Code:
relayhost = smtp.yourisp.com
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options =
Then create /etc/postfix/sasl_passwd with a line like this in it:
Code:
smtp.yourisp.com   smtp_user:smtp_password
Afterwards do this:
Code:
chown root:root /etc/postfix/sasl_passwd
chmod 600 /etc/postfix/sasl_passwd
postmap /etc/postfix/sasl_passwd
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 22nd August 2005, 12:15
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default

As for my ISP, they dont require a username and password. so creating a sasl_passwd isn't neccessary. However they dont allow relaying my from linux.domain.com server . Looks like i'll have to go back to direct send and hope people receive messages originating from my server.

I haven't had any problems directly sending to gmail or yahoo, but I bet there are other servers out there that will label my emails as SPAM.
Reply With Quote
  #20  
Old 28th January 2007, 16:11
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 5 Times in 4 Posts
 
Default

I have the same problem If I am sending mail to some. I get the mesage that I am on a blacklist. It's a whole range of ip adresses from my isp.
Going to try to get un listed.
But for that to happen going to use my isp smtp server. I have some questions thoug.

1 must I use smtp.myispdomain.nl or must I use the server, that I also have setup in outlook like netmail.myisp.nl?

And if I send with my isp server witch mail address will the receiver see?
The one I made in ISPConfig or the One I have with my ISP?

TIA DaRKNeSS
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.