#1  
Old 28th March 2006, 20:13
dumb-medic dumb-medic is offline
Junior Member
 
Join Date: Jan 2006
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Question mysql upgrade

dear falko, till!

i need to upgrade mysql (from 4.0.23 to 4.1.14).
i wonder if i have to update php too

can you tell in short what steps are necessary?

or does a guideline exist in this board? i've searched, but haven't found anything concerning this issue.

regards,
dumb-medic
Reply With Quote
Sponsored Links
  #2  
Old 28th March 2006, 20:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by dumb-medic
dear falko, till!

i need to upgrade mysql (from 4.0.23 to 4.1.14).
Which distribution do you use?

Quote:
Originally Posted by dumb-medic
i wonder if i have to update php too
Normally that's not necessary.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th March 2006, 00:55
dumb-medic dumb-medic is offline
Junior Member
 
Join Date: Jan 2006
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Default

suse 9.2 pro
ISPConfig Version: 2.1.1
Reply With Quote
  #4  
Old 29th March 2006, 14:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by dumb-medic
suse 9.2 pro
Use yast then to find and install a newer MySQL package.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 29th March 2006, 22:05
dumb-medic dumb-medic is offline
Junior Member
 
Join Date: Jan 2006
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Thumbs up

puh, if it's really that easy sorry for boring you

i'll give it a try tomorrow.

thx,
dumb-medic
Reply With Quote
  #6  
Old 30th March 2006, 11:02
dumb-medic dumb-medic is offline
Junior Member
 
Join Date: Jan 2006
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Default yast shows some dependency-probs:

phpmyadmin requires the old mysql-shared libraries.
so i'm going to remove phpmyadmin and try again the mysql-upgrade this evening.

regards,
dumb-medic
Reply With Quote
  #7  
Old 30th March 2006, 15:51
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

I just upgraded from mysql 4 to 4.1 so I could use utf-8. I did the upgrade with apt-get, so I guess you could just use yast as falko said. I didn't have any issues with mysql, but I did with utf-8
Reply With Quote
  #8  
Old 30th March 2006, 20:02
dumb-medic dumb-medic is offline
Junior Member
 
Join Date: Jan 2006
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Default

hi danf.1979,

you've managed to upgrade mysql without reinstalling phpmyadmin?

regards,
dumb-medic
Reply With Quote
  #9  
Old 30th March 2006, 23:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,796
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Why dont you use the phpmyadmin in ISPConfig?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 31st March 2006, 11:32
dumb-medic dumb-medic is offline
Junior Member
 
Join Date: Jan 2006
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

hi till,

i do use phpmyadmin via isp-config, but using yast it shows some dependency-problems.
my distribution is in german, i've tried to translate analogously:

Conflict with mysql-shared 4.1.14-1
perl-DBD-mysql requires libmysqlclient.so.12
php4-mysql requires libmysqlclient.so.12

possible options
delete packages involved with this conflict:
perl-DBD-mysql
phpMyAdmin
php4-mysql

my plan so far was: removing phpmyadmin from ispconfig, upgrading mysql and reinstalling phpmyadmin via ispconfig.

now falko said that it's not necessary to upgrade php (version 4.3.8 is installed), but yast shows up php4-mysql involved with conflicts.

now i do not really know where to start.

regards,
dumb-medic
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How would I upgrade php, mysql, and apache for debian phantomk Installation/Configuration 10 4th June 2007 19:01
MySQL Problems after Upgrade DiOmega Installation/Configuration 8 17th November 2006 22:35
MySQL Upgrade?? toyito Installation/Configuration 3 10th February 2006 18:56
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 17:04
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 10:41


All times are GMT +2. The time now is 06:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.