Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th April 2009, 15:31
rjamesd rjamesd is offline
Member
 
Join Date: Aug 2007
Posts: 35
Thanks: 3
Thanked 4 Times in 3 Posts
 
Question multi-boot Windows-Debian-Ubuntu all encrypted-some success, help needed to complete

Just thought I'd share with you my partial (so far) success with installing encrypted Windows, Debian and Ubuntu multi-boot/triple boot onto a Toshiba NB100 Netbook, 5400rpm SATA.

Idea is that I want all three OSs to keep my skills up-to-date and for work, and encrypted as will put company material on it.

Partitioned drive
Primary partition 1) Windows XP Home, 52Gb
Primary partition 2) Debian /boot, 2Gb
Primary partition 3) Ubuntu /boot, 2Gb
Primary partition 4) Extended partition
Logical partition 1) LVM encrypted Debian installation / root (ext3), 15Gb
Logical partition 2) Ubuntu /root (not encrypted yet)* (ext3), 15Gb
Logical partition 3) LVM encrypted Debian /swap, 2Gb
Logical partition 4) Ubuntu /swap (not encrypted yet)*, 2Gb
Logical partition 5) Share, NTFS, not encrypted yet, 30Gb

*(Ubuntu 8 install doesn't have this option, have to do it later)


Steps:
1) Windows XP already installed as purchased
2) Partitioned using boot it
3) Installed debian and GRUB - to give choice of XP or Debian on booting
4) Installed Ubuntu and GRUB - overwrote Debian GRUB - to give choice of Ubuntu and Windows
4) moved GRUB to debian boot partition http://blog.nikolaidis.com/2008/06/2...all-partition/
5) Encrypted Windows XP with Truecrypt 6, installed Truecrypt bootloader, which asks for password on boot or offers ESC escape key option which takes you to 2 options, Debian or Ubuntu


what I want to do next - any thoughts
Encrypt Ubuntu
Make Debian boot sequence only ask for the LUKS LVM password once, instead of twice: for the main debian filesystem and for the swap

If I find answers I'll update here, but let me know if you have any ideas. Cheers.
Reply With Quote
Sponsored Links
Reply

Bookmarks

Tags
boot, debian, truecrypt, ubuntu, windows

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 13:49
Upgrade to php 5.2 in suse 10.1 gimhan90 Installation/Configuration 3 1st January 2009 20:32
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 23:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.