#1  
Old 5th April 2006, 09:03
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Exclamation No statistics - Webalizer

I have installed a server according “The Perfect setup for Debian Sarge”
Although webalizer is installed, I can not use it.
I know that stats are not available during the first 24 hours, but that is not the question.
If I go to address http://mydomain.tld/stats/ I receive an error message that this URL is not available.
And yes there is no /web/stats/ directory on the server.

What can be wrong?

Hans
Reply With Quote
Sponsored Links
  #2  
Old 5th April 2006, 09:22
22hosting 22hosting is offline
Junior Member
 
Join Date: Apr 2006
Posts: 26
Thanks: 0
Thanked 1 Time in 1 Post
Default

/var/www/webalizer is the default directory for the install of webalizer and thus the index page should be available in there. In the /etc/webalizer.conf you need to point it to the correct directory for polling.
Have you added a cron job in /etc/cron.daily ?
Are your logs of /var/log/apache/access.log type? If they aren't webalizer will error.
Incidently you can manually run webalizer from the command line /usr/bin/webalizer (or locate it to find it). Then just run it and see what the output is. This will give you a clue as to where you went wrong.
________
CumforsexyKas

Last edited by 22hosting; 22nd August 2011 at 13:00.
Reply With Quote
  #3  
Old 5th April 2006, 10:04
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Question

Thanks for your quick reply.

I will check my system tonight.
Strange to me is that I have setup a system with webalizer before.
All acc. Falko’s “Perfect setup for Debian Sarge” and I had not to worry about Webalizer.
Everything was functioning, right from the beginning.

Who can help me a little further?

Hans

Last edited by Hans; 5th April 2006 at 12:55.
Reply With Quote
  #4  
Old 5th April 2006, 16:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,964
Thanks: 825
Thanked 5,366 Times in 4,213 Posts
Default

Webalizer is run by ISPConfig and not directly from Cron. Did you install ISPConfig on this system?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 5th April 2006, 21:54
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Default

Hello Till,

Yes, i have ISPConfig 2.2.0 installed on this system, but webalizer is not creating /web/stats/ directories for webstatistics.

I do not know how to solve this. Can you give me advise?

Hans
Reply With Quote
  #6  
Old 5th April 2006, 23:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Have a look at this thread, especially post #8: http://www.howtoforge.com/forums/showthread.php?t=562
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 6th April 2006, 06:54
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
 
Smile Statistics are available again

I did this:

/etc/init.d/cron stop
pkill cron (Make sure no cron processes are left.)
Edit your crontab (crontab -e) and save it again.
Then restart cron: /etc/init.d/cron start

And yes, it works!

Thanks Falko,


Hans
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto: Make Webalizer show full QueryString!! Zoon Tips/Tricks/Mods 1 5th November 2007 02:12
Dynamics sites in webalizer matheron Server Operation 4 13th December 2005 13:15
Webalizer tab files matheron Server Operation 4 11th December 2005 13:26
webalizer and logrotate damaskinos Server Operation 4 24th November 2005 23:16
Webalizer - Usage by Country statistics leno Installation/Configuration 3 28th April 2005 18:12


All times are GMT +2. The time now is 03:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.