Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th March 2006, 18:07
ct2193 ct2193 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Post The Perfect Setup: SuSE 9.3

I'm attempting to build a SuSE 9.3 system via the "Perfect Setup" document and I've come into a problem configuring Quotas.

I'm at the part:

-=-=-=-
touch /aquota.user /aquota.group
chmod 600 /aquota.*
mount -o remount /
quotacheck -avugm
quotaon -avug
-=-=-=-

The first time I ran this, quotacheck -avugm returned the message "quotafile was probably truncated".

And the line quotaon -avug returned "quota format not supported in kernel".

I attempted to repeat the entire quota section and the line quotacheck -avugm said nothing more about truncated files. So I assume this part is
ok.

The line quotaon -avug still returns the message about "quota format not supported in kernel". I'm not really sure as to why. I have not loaded anything custom, as everything has been installed per the "Perfect Setup" documentation.

Any suggestions?

-=-

I'm also interested in a "Perfect Setup" specifically for RedHat 9 and/or RedHat Enterprise Linux 4 (RHEL4). Any information on these versions?

Last edited by ct2193; 29th March 2006 at 17:39.
Reply With Quote
Sponsored Links
  #2  
Old 28th March 2006, 19:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by ct2193
And the line quotaon -avug returned "quota format not supported in kernel".
Have a look at this thread: http://www.howtoforge.com/forums/showthread.php?t=3083
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th March 2006, 17:34
ct2193 ct2193 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Still having quota problems

I looket at http://www.howtoforge.com/forums/showthread.php?t=3083 and still have problems.

-=-
touch /aquota.user /aquota.group
chmod 600 /aquota.*
mount -o remount /
quotacheck -avug

then i get the message "quotacheck: Cannot remount filesystem mounted on / read-only so counted values might not be right. Please stop all programs writing to filesystem or use -m flag to force checking.

(didn't get this message before)

then I ran

quotaon -avug

and got the message

quotaon: using //aquota.group on /dev/hda2 [/]: No such process
quotaon: Quota format not supported in kernel.
quotaon: using //aquota.user on /dev/hda2 [/]: No such process
quotaon: Quota format not supported in kernel.

-=-
here's my fstab

/dev/hda2 / reiserfs acl,user_xattr,usrquota,grpquota 1 1
/dev/hda1 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrom /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocha rset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0


Not sure what the problem is.

I've redone the entire "Perfect Setup" and the "how-to" dies here again.
Reply With Quote
  #4  
Old 29th March 2006, 17:38
ct2193 ct2193 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default also...

also tried

modprobe quota_v1

FATAL: Could not load /lib/modules/2.6.11.4-20a-default/modules.dep: No such file or directory

modprobe quota_v2

FATAL: Could not load /lib/modules/2.6.11.4-20a-default/modules.dep: No such file or directory

quotaon -avug

quotaon: using //aquota.group on /dev/hda2 [/]: No such process
quotaon: Quota format not supported in kernel.
quotaon: using //aquota.user on /dev/hda2 [/]: No such process
quotaon: Quota format not supported in kernel.
Reply With Quote
  #5  
Old 29th March 2006, 19:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by ct2193
here's my fstab

/dev/hda2 / reiserfs acl,user_xattr,usrquota,grpquota 1 1
/dev/hda1 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrom /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocha rset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
You're using reiserfs. Quota doesn't work on reiserfs - you should have used ext3 instead.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 4th April 2006, 18:57
ct2193 ct2193 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Quotas... again!

OK. I reinstalled SuSE 9.3, being sure to use EXT3 (instead of ReiserFS)

This time, running:

touch /aquota.user /aquota.group
chmod 600 /aquota.*
mount -o remount /
quotacheck -avug

Seemingly worked fine. Then I ran:

quotaon -avug

and got the message

quotaon: using //aquota.group on /dev/hda2 [/]: No such process
quotaon: Quota format not supported in kernel.
quotaon: using //aquota.user on /dev/hda2 [/]: No such process
quotaon: Quota format not supported in kernel.

Don't know what the problem is. I tried "modprobe quota_v1" and v2. Both say "could not load /lib/modules/2.6.11.4-20a-default/modules.dep No such file or folder"

I rechecked all the previous steps from the how-to document. Everything appears to have been completed as well as properly spelled.

Any more ideas?
Reply With Quote
  #7  
Old 6th April 2006, 00:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Please run
Code:
echo quota_v1 >> /etc/modules
echo quota_v2 >> /etc/modules
and reboot the system. Does it work then?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 7th April 2006, 18:30
ct2193 ct2193 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix postconf

OK. I'm now to the postconf part of Postfix. Thus far (with much thanks) I've gotten here with no further problems. I would like clairification as to which parts are your "put your data here" and which parts are system phrases / config strings. The section I am in question of is below.

-=-

postconf -e 'mydomain = example.com'
postconf -e 'myhostname = server1.$mydomain'
postconf -e 'smtpd_sasl_local_domain ='
postconf -e 'smtpd_sasl_auth_enable = yes'
postconf -e 'smtpd_sasl_security_options = noanonymous'
postconf -e 'broken_sasl_auth_clients = yes'
postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains'
postconf -e 'inet_interfaces = all'
postconf -e 'alias_maps = hash:/etc/aliases'
postconf -e 'smtpd_tls_auth_only = no'
postconf -e 'smtp_use_tls = yes'
postconf -e 'smtpd_use_tls = yes'
postconf -e 'smtp_tls_note_starttls_offer = yes'
postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'
postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'
postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'
postconf -e 'smtpd_tls_loglevel = 1'
postconf -e 'smtpd_tls_received_header = yes'
postconf -e 'smtpd_tls_session_cache_timeout = 3600s'
postconf -e 'tls_random_source = dev:/dev/urandom'

-=-
Reply With Quote
  #9  
Old 7th April 2006, 18:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Code:
postconf -e 'mydomain = example.com'
postconf -e 'myhostname = server1.$mydomain'
You must replace this with your own data.


Code:
 postconf -e 'smtpd_sasl_local_domain ='
 postconf -e 'smtpd_sasl_auth_enable = yes'
 postconf -e 'smtpd_sasl_security_options = noanonymous'
 postconf -e 'broken_sasl_auth_clients = yes'
 postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains'
 postconf -e 'inet_interfaces = all'
 postconf -e 'alias_maps = hash:/etc/aliases'
 postconf -e 'smtpd_tls_auth_only = no'
 postconf -e 'smtp_use_tls = yes'
 postconf -e 'smtpd_use_tls = yes'
 postconf -e 'smtp_tls_note_starttls_offer = yes'
 postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'
 postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'
 postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'
 postconf -e 'smtpd_tls_loglevel = 1'
 postconf -e 'smtpd_tls_received_header = yes'
 postconf -e 'smtpd_tls_session_cache_timeout = 3600s'
 postconf -e 'tls_random_source = dev:/dev/urandom'
You can copy and paste this part.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 17th April 2006, 19:04
ct2193 ct2193 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default index.pl

OK. Finally back to working on install.

I got through most of the Apache/PHP5 section and just before the Proftpd section, I'm doing the commands:

SuSEconfig
/etc/init.d/apache2 start

Restarting apache yields an error saying index.pl is either misspelled or refers to a module not installed.

Do I need to remove index.pl from the httpd.conf file, or am I missing a step?

The documentation said to comment out the line application/x-perl pl pm from the mime.types file.

Last edited by ct2193; 17th April 2006 at 19:07.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Setup - SUSE 9.3/Install apt For SUSE PROBLEM gimhan90 Installation/Configuration 13 27th January 2006 09:34
Is there also a Perfect Setup for SuSE 9.1 bluegrass Installation/Configuration 7 18th January 2006 17:16
The Perfect Setup - SUSE 9.3 (firewall?!) bogdinator HOWTO-Related Questions 7 12th December 2005 12:31
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30
PEAR Support with Perfect Setup SuSE 9.3 SidSkiba Installation/Configuration 8 31st August 2005 08:42


All times are GMT +2. The time now is 12:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.