Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th April 2009, 17:47
Joern Joern is offline
Junior Member
 
Join Date: Apr 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default "sh: /which ..." error during install

Hey there!

I am trying to install ISPConfig3.1.1. on my Ubuntu system.
I am following the directions given in the HowToForge tutorial "The perfect server - Ubuntu 8.10".
The system was already set up so I skipped a few steps in the tutorial - because e.g. MySQL was already installed.

Anyway, when I try to install ISPConfig with the command
Code:
php -q install.php
I get this error message sixteen times
Code:
sh: /which: No such file or directory
sh: /which: No such file or directory
sh: /which: No such file or directory
...
Anyhow I try to proceed...
I answer the questions starting which language I would like to use and which installation mode I would like.
After the installation mode question I get the following error
Code:
sh: /hostname: No such file or directory

Notice: Undefined offset:  0 in /tmp/ispconfig3_install/install/install.php on line 105
I keep on entering the information about the FQDN and the database information. After the last question about the charset I get the following error message
Code:
sh: /mysql: No such file or directory
sh: /echo: No such file or directory
ERROR: Unable to load SQL-Dump into database table.
Then the install script stops.
I can see that the script was able though to create the database named "dbispconfig". Anyhow it is empty...

So this is my problem during the install.
Is there anyone who could try to help me solve this problem?
It would be great!

Thanks a lot in advance,

Joern
Reply With Quote
Sponsored Links
  #2  
Old 15th April 2009, 20:54
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,001 Times in 3,911 Posts
Default

Please login as root user before you execute the setup script. You can not execute it with sudo!
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 15th April 2009, 20:59
Joern Joern is offline
Junior Member
 
Join Date: Apr 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your reply, Till.
I disabled root login.
Therefor I login with my username and then grant root access by doing this
Code:
su -
That's what I was doing before already.

Or do you think I really need to login as root and not do it the way I mentioned above?

Last edited by Joern; 15th April 2009 at 21:06.
Reply With Quote
  #4  
Old 15th April 2009, 23:13
Joern Joern is offline
Junior Member
 
Join Date: Apr 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Please login as root user before you execute the setup script. You can not execute it with sudo!
I just tried it again by login in directly as user 'root' - but same result as if I do it as I mentioned above... Same error msgs as well!
Reply With Quote
  #5  
Old 16th April 2009, 12:34
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,001 Times in 3,911 Posts
 
Default

Please post the output of:

echo $PATH
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
install Net::DNS chrno Installation/Configuration 4 5th September 2006 17:01


All times are GMT +2. The time now is 19:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.